+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Reload Thread: 95 Range Rover stereo installation help!

  1. #1
    SwedishChef's Avatar
    SwedishChef is offline Junior Member



    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    95 Range Rover stereo installation help!

    Hi there, I have a 95 Range Rover 'Classic' with the factory Harmon/Kardon upgrade. The system has 6 speakers plus a factory amp, subwoofer and external CD changer.

    I replaced the factory AM/FM/tape head unit with a Parrott RKi8400. I had to splice the wiring because I couldn't find a harness adapter. I did this very carefully since I know it's a bad idea. After I did that, NO sound whatsoever came out of the speakers.

    I then took it to my local Al & Eds shop and he gave me a R+L (what looks like) RCA cable to plug into the (yet unused) RCA R+L jacks on the back of the head unit. Now I get sound but it won't fade front to back, and there is a lot of ground/RPM feedback, and a loud pop when the stereo starts up and shuts down.

    Any help on how to remedy this would be very much appreciated!
    Last edited by SwedishChef; 01-14-2014 at 10:50 PM.







  2. #2
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,979
    Post Thanks / Like
    Images
    28
    Mentioned
    159 Post(s)

    Re: 95 Range Rover stereo installation help!

    you are feeding the factory amp from the aftermarket head unit. the factory amp should turn on/off with the head unit - that means using the head unit's remote turn-on wire to feed the factory amp turn-on (making sure it's not the power source for the factory amp which would require a relay).

    for signal, if the factory amp can use the speaker outputs from the new deck as the input, that may be a better choice than unbalanced RCA. using RCA, you need to make sure the shields (signal ground) are properly handled in the factory amp.



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/608637-2014-accord-sport-sq-build-keep_hope_alive.html
    ***My YouTube Channel https://www.youtube.com/channel/UCkYUo2EShW9lgtrfXiDvLNQ/videos
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html

  3. #3
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Another issue I forgot to mention is that the volume knob on my new HU is incredibly sensitive. I have to stay within the 1-4 range of a 30-degree volume knob or else it just blasts like crazy. AL & Ed's guy said this was because it's using the RCA instead of the standard speaker wiring or something.

    Quote Originally Posted by keep_hope_alive View Post
    you are feeding the factory amp from the aftermarket head unit. the factory amp should turn on/off with the head unit - that means using the head unit's remote turn-on wire to feed the factory amp turn-on (making sure it's not the power source for the factory amp which would require a relay).
    I don't know if it's the power source for the amp or not. How would I test that?

    Quote Originally Posted by keep_hope_alive View Post
    for signal, if the factory amp can use the speaker outputs from the new deck as the input, that may be a better choice than unbalanced RCA. using RCA, you need to make sure the shields (signal ground) are properly handled in the factory amp.
    This is how I had it wired initially - without using the RCA cables, and I got no sound at all with this setup.




  4. #4
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,979
    Post Thanks / Like
    Images
    28
    Mentioned
    159 Post(s)

    Re: 95 Range Rover stereo installation help!

    depends on how the speaker wires are connected. if you wired the speaker wires into the same wires you connected the RCA's into - it would work. but you may still run into volume issues (though noise would go away).

    massive volume changes means the signal is too strong. you may be could use a ground loop isolator and an attenuator on the head unit RCA outputs to resolve both issues.

    i think you need to get some schematics of the factory amplifier and factory radio and start over.



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/608637-2014-accord-sport-sq-build-keep_hope_alive.html
    ***My YouTube Channel https://www.youtube.com/channel/UCkYUo2EShW9lgtrfXiDvLNQ/videos
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html

  5. #5
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Quote Originally Posted by keep_hope_alive View Post
    depends on how the speaker wires are connected. if you wired the speaker wires into the same wires you connected the RCA's into - it would work. but you may still run into volume issues (though noise would go away).

    massive volume changes means the signal is too strong. you may be could use a ground loop isolator and an attenuator on the head unit RCA outputs to resolve both issues.

    i think you need to get some schematics of the factory amplifier and factory radio and start over.
    Thanks. I know this has been done before on my car, it's just complicated. I remember that with the factory setup, the HU is not powered, the amp is powered. I suspect as you say the problem is that the HU is kicking out too much power and the amp is not expecting it. Would an attenuator and ground loop isolator solve this? If so, do you have any product recommendations?




  6. #6
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    1,001
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    post some pics of the harness that was plugged into the factory deck. Or did it look like thishttp://www.crutchfield.com/p_120701784/Metra-70-1784-Receiver-Wire-Harness.html?tp=2977. how many plugs were there? If you have the factory amp wired to the rca's then changing to the speaker outputs will only put more power to the amp and increase the actual volume. you may have to use something like this to get proper volume levels.Pac-Audio.com Product Details | iPod Integration for your car and More by Pac-Audio - Connecting you to the future This may also take care of your popping issue.




  7. #7
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,979
    Post Thanks / Like
    Images
    28
    Mentioned
    159 Post(s)

    Re: 95 Range Rover stereo installation help!

    Quote Originally Posted by CrossoverOre View Post
    post some pics of the harness that was plugged into the factory deck. Or did it look like thishttp://www.crutchfield.com/p_120701784/Metra-70-1784-Receiver-Wire-Harness.html?tp=2977. how many plugs were there? If you have the factory amp wired to the rca's then changing to the speaker outputs will only put more power to the amp and increase the actual volume. you may have to use something like this to get proper volume levels.Pac-Audio.com Product Details | iPod Integration for your car and More by Pac-Audio - Connecting you to the future This may also take care of your popping issue.
    correct, that is what i meant by an attenuator (also called a LOC) if you use speaker wire outputs.

    if you use RCA outputs then you can get RCA attenuators that go in-line, one per RCA.



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/608637-2014-accord-sport-sq-build-keep_hope_alive.html
    ***My YouTube Channel https://www.youtube.com/channel/UCkYUo2EShW9lgtrfXiDvLNQ/videos
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html

  8. #8
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    I'd rather use the speaker wires than the RCA because then I get my fade control back. Yes- all the right & left speaker wires are currently going into a single right and a single left RCA. I will try to get some docs & schematics to reference. Worth noting that right now it is using the RCAs and there is still a LOT of whine with RPMs




  9. #9
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Here's the back schematic of my new head unit, the Parrott RKi8400, And here's the link to the full Parrott RKi8400 PDF

    It looks like the problem might be that the stereo doesn't have "pre-amp" inputs?


    Here are some pics I found of the same factory stereo I had in.


    And here are the schematics for the factory radio wiring:
    [IMG]




  10. #10
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Quote Originally Posted by keep_hope_alive View Post
    correct, that is what i meant by an attenuator (also called a LOC) if you use speaker wire outputs.

    if you use RCA outputs then you can get RCA attenuators that go in-line, one per RCA.
    As I understand it, I need to use the speaker wiring as opposed to the RCA's in order to keep my front/rear fade control. I found 4 products that seem to fit, the first one has a 12v AMP trigger, which sounds like something I may need?

    1) PAC SOEM-T 2-Channel Premium Line-Out Converter with Remote Turn-On Trigger
    2) Scosche Loc80 2-Channel Adjustable Lineout Converter
    3) PAC SNI35 Adjustable 2-Channel Line Out Converter
    4) Boss Audio Systems Car High Level to Low Level Converter (B65N)

    Will any of these work or do I need to get the first one with the 'remote turn-on trigger'?




  11. #11
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,979
    Post Thanks / Like
    Images
    28
    Mentioned
    159 Post(s)

    Re: 95 Range Rover stereo installation help!

    they would work but you will need two of them - four channels total.

    one of these is my recommendation:
    Navone Engineering Inc. N-RHL4 4 Channel, 50 Watt per channel, Line Output Converter



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/608637-2014-accord-sport-sq-build-keep_hope_alive.html
    ***My YouTube Channel https://www.youtube.com/channel/UCkYUo2EShW9lgtrfXiDvLNQ/videos
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html

  12. #12
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Quote Originally Posted by keep_hope_alive View Post
    they would work but you will need two of them - four channels total.

    one of these is my recommendation:
    Navone Engineering Inc. N-RHL4 4 Channel, 50 Watt per channel, Line Output Converter
    Great I just bought the Navone. Will report back with results. Thanks very much!




  13. #13
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Just pulled out my Parrott rki8400 head unit and compared what's going on to the Navone product (above) I purchased. One thing I am initially concerned about is the product description from the website:

    "will perfectly interface to any OEM automotive system to an aftermarket power amplifier, equalizer, electronic crossover, etc."

    This is exactly the opposite of my issue - I have an aftermarket HEAD UNIT which I'm using with a FACTORY amplifier. Not sure if this matters, any input would be appreciated.

    The Navone product has 4 RCAs on the AMP end, and 8 speaker wires to the head unit end. The wires going to my AMP do NOT have RCAs, but are split into 8 positive & negative speaker wires. I'm assuming it's fine for me to strip the RCAs from the Navone unit to split out the +/- wires from each RCA to connect to the 8 +/- wires going into my HU?

    Thanks again guys for all your help. Can't wait to get this thing up and running !




  14. #14
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Just spoke with David Navone. What a hoot! He's great. He also happened to know my 95 Range Rover Classic very well. He assured me it was the right product and that splicing out the RCAs would be fine. Looking forward to getting the unit in tonight!




  15. #15
    SwedishChef's Avatar
    SwedishChef is offline Junior Member

    Threadstarter


    Join Date
    Jan 2014
    Location
    Ft Collins, CO
    Posts
    19
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: 95 Range Rover stereo installation help!

    Hmm. Okay do I installed the Navone. Not great. It basically made the volume even MORE sensitive and the speaker POP is still there on startup & shutdown, and now I have a louder, more constant hum. I spliced it into the head unit speaker wires, not the RCAs like I was using before.

    One thing I noticed is the factory labeling on the wires out of the head unit show PINK = ACC + and YELLOW = Line Mute. These are opposite from the coloring of the stock wiring harness. I will try swapping them tonight and see if there's any difference.

    Other than that, any ideas? Hope I can get this sorted. Just spent $40 and two weeks on getting nowhere.




+ Reply to Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. Stereo Install Help---Trim Piece Won't Fit..Pics Included
    By globe9 in forum General Discussion
    Replies: 7
    Last Post: 09-08-2010, 01:07 AM
  2. 97 Range Rover Stereo Issues...
    By got_focus? in forum Wiring, Electrical and Installation Help
    Replies: 12
    Last Post: 11-04-2007, 10:23 PM
  3. 1999 range rover sub install
    By wild.gasgas in forum Subwoofers
    Replies: 0
    Last Post: 07-20-2007, 10:52 AM
  4. lcd w/ stereo installation help...
    By bpkmrtoes in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 03-08-2006, 09:50 AM
  5. Car Amp Installation Help On A Stock Stereo
    By Chamkila911 in forum General Discussion
    Replies: 0
    Last Post: 07-01-2002, 02:29 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum