+ Reply to Thread
Results 1 to 14 of 14

Reload Thread: Amp keeps cutting off

  1. #1
    Stovall863's Avatar
    Stovall863 is offline Junior Member



    Join Date
    Mar 2010
    Location
    lakeland, Fl
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp keeps cutting off

    I have four Power Acoustik MOFO 12's running off of a 2000 watt SoundStream amp, recently the amp keeps cutting off when I hit the gas and brake pedals when the bass is barely turned up then sometimes comes right back on or not. Sometimes i'm not even driving and it will cut off and on?? I have no idea what is going on.







  2. #2
    pickup1's Avatar
    pickup1 is offline Audiosystem,Dynaudio...



    Join Date
    Aug 2005
    Location
    Roanoke,TX
    Age
    49
    Posts
    7,622
    Post Thanks / Like
    Images
    19
    Mentioned
    29 Post(s)

    Re: Amp keeps cutting off

    Have you checked the ground connection?




  3. #3
    argenis69's Avatar
    argenis69 is online now SQ Bass Lover



    Join Date
    Dec 2012
    Location
    NY, USA
    Posts
    781
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: Amp keeps cutting off

    Maybe, Loose connections.



    02 Nissan Maxima
    HU JVC KW-AV61BT.
    Front stage Image Dynamics 6.5 CX62 V2. Rear stage O2 Audio 5 1/4in.
    Cadence Tweeters. KnuKonceptz Rcas and Wiring.
    Kicker Impulse x3i 3-way Active Electronic Crossover(disconnected for now).
    JL Audio 300/4 . Crescendo BC3500D.
    15" Fi Audio SP4 fully loaded in 3.5cu ft flared ported box.
    200 amp HO Alt. One complete +/- run of Knu Ofc 0 gauge with big 3, volt meter inside, biggest acid battery under hood, Battery Isolator. A XS Power D3100 and a Crescendo Logic F-31HP battery in trunk.

  4. #4
    Slo_Ride's Avatar
    Slo_Ride is offline Midnight Rider



    Join Date
    Oct 2005
    Location
    Atlanta
    Posts
    7,796
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Amp keeps cutting off

    loose wire or short



    Refs = PapaGeno21, Goindef154, 92c1v1c, Disarmer, chemmins, 97maxima, kroid777, ithertz, basscort2009, hunterw, mar08052, appleyard, millimac247, jonny101abc, sundownz, cranberryyumyum, mig139, daboyfrumdabx, skateguy92, basebalz13.

  5. #5
    Stovall863's Avatar
    Stovall863 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2010
    Location
    lakeland, Fl
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp keeps cutting off

    I've checked that, even move the wires around with it on and they seem to be fine. Any other suggestions?




  6. #6
    argenis69's Avatar
    argenis69 is online now SQ Bass Lover



    Join Date
    Dec 2012
    Location
    NY, USA
    Posts
    781
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: Amp keeps cutting off

    Check fuses and measure voltage along the power line.



    02 Nissan Maxima
    HU JVC KW-AV61BT.
    Front stage Image Dynamics 6.5 CX62 V2. Rear stage O2 Audio 5 1/4in.
    Cadence Tweeters. KnuKonceptz Rcas and Wiring.
    Kicker Impulse x3i 3-way Active Electronic Crossover(disconnected for now).
    JL Audio 300/4 . Crescendo BC3500D.
    15" Fi Audio SP4 fully loaded in 3.5cu ft flared ported box.
    200 amp HO Alt. One complete +/- run of Knu Ofc 0 gauge with big 3, volt meter inside, biggest acid battery under hood, Battery Isolator. A XS Power D3100 and a Crescendo Logic F-31HP battery in trunk.

  7. #7
    Jes 42's Avatar
    Jes 42 is offline karma!



    Join Date
    Aug 2012
    Location
    Ohio/Ind
    Posts
    2,040
    Post Thanks / Like
    Mentioned
    22 Post(s)

    Re: Amp keeps cutting off

    Is the amp mounted to your box?



    Kenwood x996
    Punch 501x
    4 Prv 6.5's-Bazooka Euphonic tweets
    18'' T3 TSNS
    MA Audio HK4000D
    300 amp Ohio Gen alt
    2 CS9000 batts

  8. #8
    Stovall863's Avatar
    Stovall863 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2010
    Location
    lakeland, Fl
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp keeps cutting off

    Okay I will, and yeah it's mounted to the back of the box.




  9. #9
    garychoffmann's Avatar
    garychoffmann is offline CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Missouri
    Posts
    720
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Amp keeps cutting off

    Check the wiring inside your box, sounds like a short. Does amp protect or power down?




  10. #10
    radwilsons5803's Avatar
    radwilsons5803 is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    Minnesota
    Posts
    1,526
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp keeps cutting off

    If you have another amp throw that in, if it still does it it's obviously something else




  11. #11
    Jes 42's Avatar
    Jes 42 is offline karma!



    Join Date
    Aug 2012
    Location
    Ohio/Ind
    Posts
    2,040
    Post Thanks / Like
    Mentioned
    22 Post(s)

    Re: Amp keeps cutting off

    Quote Originally Posted by radwilsons5803 View Post
    If you have another amp throw that in, if it still does it it's obviously something else
    This^^^You may have jarred something loose in your amp.



    Kenwood x996
    Punch 501x
    4 Prv 6.5's-Bazooka Euphonic tweets
    18'' T3 TSNS
    MA Audio HK4000D
    300 amp Ohio Gen alt
    2 CS9000 batts

  12. #12
    Stovall863's Avatar
    Stovall863 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2010
    Location
    lakeland, Fl
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp keeps cutting off

    The amp goes into protect




  13. #13
    bbeljefe's Avatar
    bbeljefe is online now Premium Member bbeljefe is a Supporting Member of the forum!



    Join Date
    Jul 2013
    Location
    Shreveport, LA
    Posts
    1,746
    Post Thanks / Like
    Mentioned
    20 Post(s)

    Re: Amp keeps cutting off

    When you get a new amp, don't mount it to the box. Any vibration on the box will cause the internals to vibrate as well and after a long time of that happening, you stand a really good chance of causing solder joints to weaken and begin to fail.

    And if the box is the only place you can mount the amp, make sure the box wall it's on is very sturdy and isolate the amp from the box with rubber grommets on the top and bottom of each mounting screw.



    Owner, Audio Anarchy, LLC
    2915 Youree Drive, Shreveport, LA
    318-780-6149

    Authorized Dealer in NW Louisiana for CT Sounds & Execution Audio. We also carry other products but you really don't want that stuff... ;-)


  14. #14
    jrdnhsnbrg's Avatar
    jrdnhsnbrg is offline Pimped my grandma's ride



    Join Date
    Aug 2012
    Location
    Menomonie, WI
    Age
    19
    Posts
    1,789
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: Amp keeps cutting off

    Make sure there aren't any loose wires inside the box shorting out, also it's generally a bad idea to mount the amp to the box due to vibration from the subs. Try a different amp in the system and if it is your amp that is the problem, try and sell it on Craigslist for cheap. If possible, don't mount the amp to your box next time, get a small chunk of plywood or MDF or something and attach it to there. I use screws long enough to go through the amp mounts, through the wood, and just poke through the bottom of the wood a little bit so it doesn't slide around in the trunk. Good luck man!



    01 Lincoln Continental - Mary

    XFL 12" on a VFL150.1, 4.5 cubes net @27Hz
    Powerware 150ah monster, SHCA 1/0 & 8ga
    Pioneer D Series 6.5" and 6x8" on a VFL150.4

    References: mylows10, 2000LaDe , VWGolfMKVI, Garcia915, UnderFire, joeybutts
    Quote Originally Posted by Beatin' View Post
    You HAVE to look.

    If after 5 wipes you're still getting mega shit on the paper, it's shower time.

+ Reply to Thread

Similar Threads

  1. Amp keeps cutting off
    By fire919 in forum Amplifiers
    Replies: 1
    Last Post: 02-05-2010, 06:45 PM
  2. HELP, my amp keeps cutting off
    By slconde in forum Amplifiers
    Replies: 2
    Last Post: 03-15-2009, 02:57 PM
  3. amp keeps cutting off
    By JHawk972 in forum Amplifiers
    Replies: 9
    Last Post: 10-19-2005, 03:28 PM
  4. My amp keeps cutting off!?!?
    By supraman1379 in forum Amplifiers
    Replies: 1
    Last Post: 04-14-2004, 08:53 PM
  5. my amp keeps cutting out...why?
    By audioman in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 01-01-2002, 05:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum