+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 29

Reload Thread: NEED HELP ASAP... tryin to fix now!

  1. #1
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member



    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    NEED HELP ASAP... tryin to fix now!

    so i have a dodge ram 1500 2005... i just replaced the alternator and added a 0 guage from the alt to the battery which is also connectd to a optima red top in the back... and i just put my rockford fosgate t1000.1bd back in the truck running 2 alpine type r (1000rms) subs... when i hooked everything up my subs wont budge until im around half volume and when they do move its like a horrible sounding bass possibly clipping and it skips pretty bad?... i dont think its the rca's because i have a 5 channel amp following that one and the sub on that one sounds good...

    my voltage is good but when the subs start to hit the battery guage goes down really fast...
    the last time i had this setup i didnt have the 0 guage hooked up from the alt to the battery and it worked fine... i dont know whats going on??
    thanks for the your help in advance!







  2. #2
    argenis69's Avatar
    argenis69 is offline SQ Bass Lover



    Join Date
    Dec 2012
    Location
    NY, USA
    Posts
    754
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Did you check all the fuses and connections?



    02 Nissan Maxima
    HU JVC KW-AV61BT.
    Front stage Image Dynamics 6.5 CX62 V2. Rear stage O2 Audio 5 1/4in.
    Cadence Tweeters. KnuKonceptz Rcas and Wiring.
    Kicker Impulse x3i 3-way Active Electronic Crossover(disconnected for now).
    JL Audio 300/4 . Crescendo BC3500D.
    15" Fi Audio SP4 fully loaded in 3.5cu ft flared ported box.
    200 amp HO Alt. One complete +/- run of Knu Ofc 0 gauge with big 3, volt meter inside, biggest acid battery under hood, Battery Isolator. A XS Power D3100 and a Crescendo Logic F-31HP battery in trunk.

  3. #3
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    The amp is connected straight from the battery in the back. And everything looks solid




  4. #4
    Chriszle's Avatar
    Chriszle is offline CarAudio.com Elite



    Join Date
    Jan 2011
    Location
    SD
    Posts
    1,718
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Are your subs wired out of phase?




  5. #5
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    No both subs are wired the right way...




  6. #6
    ThatChevyGuy's Avatar
    ThatChevyGuy is offline i heart Jager



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,180
    Post Thanks / Like
    Mentioned
    12 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Only The Best View Post
    No both subs are wired the right way...
    Check the impedance of each sub with a dmm.

    Sounds like a bad ground also



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  7. #7
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    my grounds are solid but ill check the impedence today after i get out of gov. and im goin to take it to a shop and see what they think as well and hopefully i can figure out whats wrong... i had a problem with the amp buzzing before i took it out previously and put a bead of silicone on top of the toroid to stop the buzzing which did stop the buzzing but now its doing this?... even if the silicone was put in the wrong spot it wouldnt matter right?




  8. #8
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    So I switched the amp out with another amp and nothing was wrong. So now I know it's the amp. But is there a way to test if the RCA is causing the problem?




  9. #9
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    So I remeber I touched my power wire to the rca jack. And that's what blew my sub. Now how do I fix this?




  10. #10
    jrdnhsnbrg's Avatar
    jrdnhsnbrg is offline Pimped my grandma's ride



    Join Date
    Aug 2012
    Location
    Menomonie, WI
    Age
    19
    Posts
    1,789
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Only The Best View Post
    So I remeber I touched my power wire to the rca jack. And that's what blew my sub. Now how do I fix this?
    So you touched the power wire to the RCA input and the amp and sub blew... Not surprised here. Most amps can't handle input voltages higher than 6V, and your truck puts out 12.5-14.4V depending on if it's running or not. Time for new subs and an amp.



    01 Lincoln Continental - Mary

    XFL 12" on a VFL150.1, 4.5 cubes net @27Hz
    Powerware 150ah monster, SHCA 1/0 & 8ga
    Pioneer D Series 6.5" and 6x8" on a VFL150.4

    References: mylows10, 2000LaDe , VWGolfMKVI, Garcia915, UnderFire, joeybutts
    Quote Originally Posted by Beatin' View Post
    You HAVE to look.

    If after 5 wipes you're still getting mega shit on the paper, it's shower time.

  11. #11
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    well it only blew one of the subs... and there has to be a way to fix this? like there should be a fuse somewhere after the rca connections




  12. #12
    jrdnhsnbrg's Avatar
    jrdnhsnbrg is offline Pimped my grandma's ride



    Join Date
    Aug 2012
    Location
    Menomonie, WI
    Age
    19
    Posts
    1,789
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Only The Best View Post
    well it only blew one of the subs... and there has to be a way to fix this? like there should be a fuse somewhere after the rca connections
    As far as I know they don't fuse the RCA inputs. I could be wrong though. If they're blown, they're blown. You got lucky it didn't blow both. Warranty at all?



    01 Lincoln Continental - Mary

    XFL 12" on a VFL150.1, 4.5 cubes net @27Hz
    Powerware 150ah monster, SHCA 1/0 & 8ga
    Pioneer D Series 6.5" and 6x8" on a VFL150.4

    References: mylows10, 2000LaDe , VWGolfMKVI, Garcia915, UnderFire, joeybutts
    Quote Originally Posted by Beatin' View Post
    You HAVE to look.

    If after 5 wipes you're still getting mega shit on the paper, it's shower time.

  13. #13
    garychoffmann's Avatar
    garychoffmann is offline CarAudio.com Elite



    Join Date
    Mar 2011
    Location
    Missouri
    Posts
    699
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    No fuse on the rca's, if your not familiar with how to repair an amp you'll probably end up having to send it off for repair. Its not a do it yourself task for someone without knowledge. Trying to fix it yourself can do costly damage.




  14. #14
    Only The Best's Avatar
    Only The Best is offline Senior VIP Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    499
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by garychoffmann View Post
    No fuse on the rca's, if your not familiar with how to repair an amp you'll probably end up having to send it off for repair. Its not a do it yourself task for someone without knowledge. Trying to fix it yourself can do costly damage.
    ive taken a couple of them apart im just not familiar with this issue... was just tryin to get some insight before I took it on myself... if I cant fix it I will probably just buy a new one




  15. #15
    cfox10's Avatar
    cfox10 is offline Rock the house.



    Join Date
    Mar 2011
    Location
    Albany, Oregon
    Posts
    1,242
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    You have another sub running off a 5 channel including those two?

    WHY?




+ Reply to Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. how to find port area need help asap
    By 81chevystep in forum Enclosure Design & Construction Help
    Replies: 24
    Last Post: 12-29-2008, 10:43 AM
  2. Need help ASAP! Installing Right Now! *PICS*
    By JoeSmith502 in forum Wiring, Electrical and Installation Help
    Replies: 19
    Last Post: 06-14-2008, 06:02 PM
  3. Need help ASAP, need to send woofer out...
    By btnhfan in forum Car Audio Competition, Shows and Events
    Replies: 7
    Last Post: 01-26-2005, 05:51 PM
  4. Ah I really need help asap, what sub to get!
    By Afboy143 in forum Subwoofers
    Replies: 2
    Last Post: 05-26-2004, 10:02 PM
  5. How to hook up a Electronic Crossover? Need HELP ASAP
    By nofriends46 in forum General Discussion
    Replies: 2
    Last Post: 05-16-2002, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum