+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 29 of 29

Reload Thread: NEED HELP ASAP... tryin to fix now!

  1. #16
    jrdnhsnbrg's Avatar
    jrdnhsnbrg is offline Pimped my grandma's ride



    Join Date
    Aug 2012
    Location
    Menomonie, WI
    Age
    19
    Posts
    1,804
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by cfox10 View Post
    You have another sub running off a 5 channel including those two?

    WHY?
    Lol, why not? Maybe the one running off the 5 channel is in a sealed box to help with upper bass frequencies and the others are ported for really hitting the lows. Who knows, doesn't hurt anything



    01 Lincoln Continental - Mary

    XFL 12" on a VFL150.1, 4.5 cubes net @27Hz
    Powerware 150ah monster, SHCA 1/0 & 8ga
    Pioneer D Series 6.5" and 6x8" on a VFL150.4

    References: mylows10, 2000LaDe , VWGolfMKVI, Garcia915, UnderFire, joeybutts
    Quote Originally Posted by Beatin' View Post
    You HAVE to look.

    If after 5 wipes you're still getting mega shit on the paper, it's shower time.




  2. #17
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Exactly right sir! I like skilled type of music so it helps immensly




  3. #18
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    so the i've taken it apart a little bit to look at the internals and all of the transistors LOOK solid... nothing looks blown it looks brand new on the inside... when i hooked the amp up it powers up fine and does not go into protect mode whatso-ever and lately i was trying to figure something out and i did not even have music playing and the subs were connected .... the amp was pushing the subs to their xmax repeatedly??? any tell tale signs?... it only needs 1 rca cable in for this to happen as well... even if i plug the rca into the output instead of the inputs...




  4. #19
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    that amp has to be bugger'd can you post pics of the internals of the amp and the amp settings themselves, also what gear is in the car hooked up and running and what are the headunit settings ect ect




  5. #20
    phemps's Avatar
    phemps is offline CarAudio.com Elite



    Join Date
    May 2009
    Location
    PA
    Posts
    1,983
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by jrdnhsnbrg View Post
    Lol, why not? Maybe the one running off the 5 channel is in a sealed box to help with upper bass frequencies and the others are ported for really hitting the lows. Who knows, doesn't hurt anything
    Ugh what a load of shit this is. Not how it works





    Refs: Rio, DbzArson, goodstuff, Worstenemy453


    Quote Originally Posted by Altec View Post
    Then obviously I am asking the wrong person, because you don't know how to hook up subs if they sounded like "****". Maybe learn your ohms and your diagrams before you call something ****. Learn to make boxes to specs and use the right wires and its called dynomat. Then maybe your car wouldn't of sounded like ****, yeah?

  6. #21
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!




    theres the amp... the amp's settings are around half for the bass boost and 1/4 on the punch lvl... set at around 75 hz... the truck is in park when this was happening and im not sure why the head units settings would be of any issue?... i plugged another amp in its same spot and that amp worked just fine so its somthing to do with the RF.




  7. #22
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Side Show View Post
    that amp has to be bugger'd can you post pics of the internals of the amp and the amp settings themselves, also what gear is in the car hooked up and running and what are the headunit settings ect ect
    There ya go




  8. #23
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    so every RCA input and output on this amp causes the amp the push the sub to x-max repeatedly whilst there is no signal going through the rca? also does the amp have a burning rubber/platic smell to is?




  9. #24
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Side Show View Post
    so every RCA input and output on this amp causes the amp the push the sub to x-max repeatedly whilst there is no signal going through the rca? also does the amp have a burning rubber/platic smell to is?
    yes if any of the rca's are plugged in the sub is repeatedly pushed in and out with my bluetooth or radio turned all the way down or paused.. and there isnt any smell or weird sounds




  10. #25
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    ummm take the amp in for repair, and just do the old......... (it just stopped working) they might replace it for you or check on how much they'll charge you to fix it. the fault is in the amp and I am not an authorised repairer.
    goodluck with fixing that. check all switches and knobs on the amp too, might be a dicky switch from high to low level inputs or sumfin




  11. #26
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    ummm take the amp in for repair, and just do the old......... (it just stopped working) they might replace it for you or check on how much they'll charge you to fix it. the fault is in the amp and I am not an authorised repairer.
    goodluck with fixing that. check all switches and knobs on the amp too, might be a dicky switch from high to low level inputs or sumfin




  12. #27
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Side Show View Post
    ummm take the amp in for repair, and just do the old......... (it just stopped working) they might replace it for you or check on how much they'll charge you to fix it. the fault is in the amp and I am not an authorised repairer.
    goodluck with fixing that. check all switches and knobs on the amp too, might be a dicky switch from high to low level inputs or sumfin
    yeah the ****** part is that its a 2 year old amp past its warranty and i got it from car toys in which they would send me directly to rockford where they want to charge me 250$ which includes shipping.




  13. #28
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Side Show View Post
    ummm take the amp in for repair, and just do the old......... (it just stopped working) they might replace it for you or check on how much they'll charge you to fix it. the fault is in the amp and I am not an authorised repairer.
    goodluck with fixing that. check all switches and knobs on the amp too, might be a dicky switch from high to low level inputs or sumfin
    yeah the ****** part is that its a 2 year old amp past its warranty and i got it from car toys in which they would send me directly to rockford where they want to charge me 250$ which includes shipping.




  14. #29
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    whoa, that's a lot... maybe try sell it as non-working to som1 on here that knows how to repair it.

    or contact Rockford direct, doubt they know what it'll cost without knowing whats bugger'd




  15. #30
    Only The Best's Avatar
    Only The Best is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    texas
    Posts
    501
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: NEED HELP ASAP... tryin to fix now!

    Quote Originally Posted by Side Show View Post
    whoa, that's a lot... maybe try sell it as non-working to som1 on here that knows how to repair it.

    or contact Rockford direct, doubt they know what it'll cost without knowing whats bugger'd
    You know anyone here that has a good rep for fixing rockford fosgate or other similar amps that i could either sell to or have repaired?




+ Reply to Thread
Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. how to find port area need help asap
    By 81chevystep in forum Enclosure Design & Construction Help
    Replies: 24
    Last Post: 12-29-2008, 10:43 AM
  2. Need help ASAP! Installing Right Now! *PICS*
    By JoeSmith502 in forum Wiring, Electrical and Installation Help
    Replies: 19
    Last Post: 06-14-2008, 06:02 PM
  3. Need help ASAP, need to send woofer out...
    By btnhfan in forum Car Audio Competition, Shows and Events
    Replies: 7
    Last Post: 01-26-2005, 05:51 PM
  4. Ah I really need help asap, what sub to get!
    By Afboy143 in forum Subwoofers
    Replies: 2
    Last Post: 05-26-2004, 10:02 PM
  5. How to hook up a Electronic Crossover? Need HELP ASAP
    By nofriends46 in forum General Discussion
    Replies: 2
    Last Post: 05-16-2002, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum