+ Reply to Thread
Results 1 to 10 of 10

Reload Thread: Amp Going Into Protection Mode

  1. #1
    Macy's Avatar
    Macy is offline Junior Member



    Join Date
    Sep 2013
    Location
    Millville
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp Going Into Protection Mode

    Alright so my Phoenix Gold Octane-R Amp for my mids and highs keeps going into protection mode, this is the second amp I've tried and its done the same thing so its not the amp. I've un-hooked My RCA cables. Still in protection mode. I've unhooked All the speaker wire AND the RCA cables and its still in protection mode. I cant figure out why its doing it...My Rockford Fosgate T1500 is completely fine though, Bass still knocks and that amp isnt going into protection mode.

    My system for reference

    Kenwood DNX7100- Head Unit

    Rockford Fosgate T1500

    Phoenix Gold Octane-R

    2 12'' Alpine subs

    2 DB Drive 6 1/2 mids in the doors

    2 DB drive bullets in both doors

    2 HI-Def loud horns In the Grill

    vehicle: 1979 Monte Carlo

    any help would be greatly appreciate this thing is driving me nuts...also I cant show off with no music thanks guys..

    P.S I've also noticed now because I haven't had it on while driving in awhile but I'm now getting that engine whining sound so maybe a ground may have came loose? idk if that would affect anything.







  2. #2
    Slo_Ride's Avatar
    Slo_Ride is offline Midnight Rider



    Join Date
    Oct 2005
    Location
    Atlanta
    Posts
    7,762
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Amp Going Into Protection Mode

    I believe those amps are only 2 ohm stable so make sure your speakers are wired correctly.



    Refs = PapaGeno21, Goindef154, 92c1v1c, Disarmer, chemmins, 97maxima, kroid777, ithertz, basscort2009, hunterw, mar08052, appleyard, millimac247, jonny101abc, sundownz, cranberryyumyum, mig139, daboyfrumdabx, skateguy92, basebalz13.

  3. #3
    Macy's Avatar
    Macy is offline Junior Member

    Threadstarter


    Join Date
    Sep 2013
    Location
    Millville
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp Going Into Protection Mode

    Quote Originally Posted by Slo_Ride View Post
    I believe those amps are only 2 ohm stable so make sure your speakers are wired correctly.

    even with the speakers and RCA cables unhooked it still goes into protection mode from the moment it gets power. thank you for the speedy reply




  4. #4
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,397
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: Amp Going Into Protection Mode

    Deff a solid ground is necessary.Check your Power wiring as well, make sure you dont have any exposed strands grounding out/touching any metal/.Check to see if you exposed any wiring,by rubbing through the firewall if you did not use a grommet also.Whats your voltage like?Whats your electrical like?HO alt,Standard?,Wet cell battery,one AGM,two AGM with Stock alt,Size of power wiring?



    2)American Bass VFL Mini Hybrid 4480.1D@1ohm Ea 4)American Bass XFL DVC 4ohm 12s@2.06cu Ft Ea.@32htz CDT 6,5 HD6 Briax.,CDT CL60,CDT 25 tweets,Kicker KS25 tweets Autotek Mean Machine 99@2ohms,Autotek BTX 7204@40hms AlterStarts Alt 255A/Dallas,Tx,2)Orileys Super Start AGM batts(1more coming)Cadence CCA 0ga on Big 6,AudioTechnix 0ga CCA Kicker Kq9 Eq,Eclipse CD3000(lookingfor upgrade)StingerPro Distro,3)XS Scorpian 8in Scroll Fans 1998 3dr Xcab Chevy(under construction,but operational)

  5. Likes Ahmed Johnson liked this post
  6. #5
    Slo_Ride's Avatar
    Slo_Ride is offline Midnight Rider



    Join Date
    Oct 2005
    Location
    Atlanta
    Posts
    7,762
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Amp Going Into Protection Mode

    Quote Originally Posted by Macy View Post
    even with the speakers and RCA cables unhooked it still goes into protection mode from the moment it gets power. thank you for the speedy reply
    well thats not good. Make sure you have good voltage. If so make sure you have a good ground. Here read this it will explain...
    Amp in Protection - Troubleshooting



    Refs = PapaGeno21, Goindef154, 92c1v1c, Disarmer, chemmins, 97maxima, kroid777, ithertz, basscort2009, hunterw, mar08052, appleyard, millimac247, jonny101abc, sundownz, cranberryyumyum, mig139, daboyfrumdabx, skateguy92, basebalz13.

  7. #6
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,397
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: Amp Going Into Protection Mode

    Quote Originally Posted by Macy View Post
    even with the speakers and RCA cables unhooked it still goes into protection mode from the moment it gets power. thank you for the speedy reply
    You can take the amp out, take it to the battery of the vehicle, and wire/test it quickly there.POWER and REMOTE together to + on batt, and - to Neg on the battery.If she lights up fine, you should have an issue with either your power,or ground wiring,or Ohm configuration as stated.If she goes back to protect, you need to get her repaired,or replace the amp.



    2)American Bass VFL Mini Hybrid 4480.1D@1ohm Ea 4)American Bass XFL DVC 4ohm 12s@2.06cu Ft Ea.@32htz CDT 6,5 HD6 Briax.,CDT CL60,CDT 25 tweets,Kicker KS25 tweets Autotek Mean Machine 99@2ohms,Autotek BTX 7204@40hms AlterStarts Alt 255A/Dallas,Tx,2)Orileys Super Start AGM batts(1more coming)Cadence CCA 0ga on Big 6,AudioTechnix 0ga CCA Kicker Kq9 Eq,Eclipse CD3000(lookingfor upgrade)StingerPro Distro,3)XS Scorpian 8in Scroll Fans 1998 3dr Xcab Chevy(under construction,but operational)

  8. Likes Ahmed Johnson liked this post
  9. #7
    hispls's Avatar
    hispls is offline CarAudio.com Veteran



    Join Date
    Sep 2009
    Location
    Cape Cod, Massachusetts
    Posts
    5,739
    Post Thanks / Like
    Images
    15
    Mentioned
    104 Post(s)

    Re: Amp Going Into Protection Mode

    Inadequate grounds do not cause an amp to go go into protect mode. Typically it's either low impedance (short), or over voltage, or overheating that "protect" circuits look for.

    If it goes straight into protect when you power it up with no speaker wires attached the amp is probably toast, throw it away and try to find something better.

    IMO Phoenix Gold hasn't made a good amp since the 90's.




  10. #8
    Macy's Avatar
    Macy is offline Junior Member

    Threadstarter


    Join Date
    Sep 2013
    Location
    Millville
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp Going Into Protection Mode

    Quote Originally Posted by hispls View Post
    Inadequate grounds do not cause an amp to go go into protect mode. Typically it's either low impedance (short), or over voltage, or overheating that "protect" circuits look for.

    If it goes straight into protect when you power it up with no speaker wires attached the amp is probably toast, throw it away and try to find something better.

    IMO Phoenix Gold hasn't made a good amp since the 90's.

    right, thing is I had a decent kenwood before this one. My car audio guy tried to hook up my rear-window speakers and it instantly went into Protect mode. When he put the PG amp in he tried to hook my rear-window speakers up again after I asked him several times not to worry about them and that they might just be fried. Now this amp is doing the same thing I think my REAL issue here is I need to find a new car audio guy thanks everyone I appreciate the help!




  11. Likes Ahmed Johnson liked this post
  12. #9
    hispls's Avatar
    hispls is offline CarAudio.com Veteran



    Join Date
    Sep 2009
    Location
    Cape Cod, Massachusetts
    Posts
    5,739
    Post Thanks / Like
    Images
    15
    Mentioned
    104 Post(s)

    Re: Amp Going Into Protection Mode

    Quote Originally Posted by Macy View Post
    right, thing is I had a decent kenwood before this one. My car audio guy tried to hook up my rear-window speakers and it instantly went into Protect mode. When he put the PG amp in he tried to hook my rear-window speakers up again after I asked him several times not to worry about them and that they might just be fried. Now this amp is doing the same thing I think my REAL issue here is I need to find a new car audio guy thanks everyone I appreciate the help!
    Very likely there is a short between the amp and speaker(s) which killed both amps.




  13. #10
    jrdnhsnbrg's Avatar
    jrdnhsnbrg is offline Pimped my grandma's ride



    Join Date
    Aug 2012
    Location
    Menomonie, WI
    Age
    18
    Posts
    1,726
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Amp Going Into Protection Mode

    Quote Originally Posted by Macy View Post
    right, thing is I had a decent kenwood before this one. My car audio guy tried to hook up my rear-window speakers and it instantly went into Protect mode. When he put the PG amp in he tried to hook my rear-window speakers up again after I asked him several times not to worry about them and that they might just be fried. Now this amp is doing the same thing I think my REAL issue here is I need to find a new car audio guy thanks everyone I appreciate the help!
    Time for a new amp. If you learn how to install everything on your own you will save TONS of money and get to know your car/truck/whateveryoumightdrive at the same time, not to mention it really is not hard to do. If I can do it, you can, too



    01 Lincoln Continental - Mary

    XFL 12" on a VFL150.1, 4.5 cubes net @27Hz
    Powerware 150ah monster, SHCA 1/0 & 8ga
    Pioneer D Series 6.5" and 6x8" on a VFL150.4

    References: mylows10, 2000LaDe , VWGolfMKVI, Garcia915, UnderFire, joeybutts
    Quote Originally Posted by Beatin' View Post
    You HAVE to look.

    If after 5 wipes you're still getting mega shit on the paper, it's shower time.

  14. Likes Ahmed Johnson liked this post
+ Reply to Thread

Similar Threads

  1. Amp going into protect mode?
    By rlemieux in forum Amplifiers
    Replies: 11
    Last Post: 11-10-2006, 11:25 PM
  2. Amp going into protection mode
    By Tiger Bass in forum Amplifiers
    Replies: 21
    Last Post: 10-11-2006, 07:07 PM
  3. Amp going into protection mode
    By Tiger Bass in forum General Discussion
    Replies: 0
    Last Post: 10-08-2006, 02:33 AM
  4. Amps going into protection mode
    By yne721 in forum Amplifiers
    Replies: 2
    Last Post: 02-07-2006, 06:52 PM
  5. amp going into protection mode
    By psprowler in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 03-17-2004, 10:05 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum