Closed Thread
Results 1 to 2 of 2

Reload Thread: Running new wire to 1989 Mercedes Benz 300 SE speakers

  1. #1
    codycool55's Avatar
    codycool55 is offline Junior Member



    Join Date
    Jul 2013
    Location
    Wahington
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Running new wire to 1989 Mercedes Benz 300 SE speakers

    Hello, I have recently purchased a Kenwood Excelon to replace the stock head unit in my 1989 Mercedes Benz 300 SE. I've decided I want to run new wires to the stock speakers, to skip the stock fader and amps, and so if in the future I decide to replace the stock speakers it will be easier. Can anyone help me through this or point me towards information on this?







  2. #2
    Side Show's Avatar
    Side Show is offline Bringin The Noise



    Join Date
    Aug 2007
    Location
    Australia
    Posts
    3,339
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Running new wire to 1989 Mercedes Benz 300 SE speakers

    i'd suggest you use the existing wiring that's run to the speakers & ust wire them to the new headunit (b4 or after the amp)




Closed Thread

Similar Threads

  1. '99 civic hatch how to boost or run new antena wire ?
    By toyopl in forum General Discussion
    Replies: 5
    Last Post: 03-09-2010, 07:38 AM
  2. Build In My 1989 Mercedes-Benz 300SE - AudioQue HDC312 + Hifonics BXI1608D + 2.3ft^3
    By grillman6000 in forum Car Audio Build Logs - Cars/Trucks/SUVs
    Replies: 38
    Last Post: 07-14-2009, 11:12 PM
  3. Running New Wires For HU
    By FullThrottle7 in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 01-24-2003, 10:26 AM
  4. Running new speaker wire
    By <Muff DVR> in forum General Discussion
    Replies: 1
    Last Post: 12-22-2001, 05:30 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum