+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 45

Reload Thread: System keeps killing my battery.. need some advice.. PLEASE!

  1. #1
    EGordon_'s Avatar
    EGordon_ is offline Junior Member



    Join Date
    Jul 2013
    Location
    United States
    Age
    18
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 System keeps killing my battery.. need some advice.. PLEASE!

    So I'm running 2 12inch subs in the trunk from a Sony Xplod 1200W amp. For some reason it keeps killing my battery and I've been doing research all morning.

    My alternator is aftermarket and puts out 200 amps.

    Battery just got replaced and is an interstate battery.. pic attached.

    What I drew from my research is that I obviously need a stronger battery, and a two battery set up with an isolator would be my best bet.. as the strong alternator should be able to handle all that.

    Please let me know what you guys think or any advice!

    System keeps killing my battery.. need some advice.. PLEASE!-photo-11-.jpg

    System keeps killing my battery.. need some advice.. PLEASE!-image-11-.jpg







  2. #2
    basswiigee's Avatar
    basswiigee is offline CarAudio.com Veteran



    Join Date
    Apr 2013
    Location
    MICHIGAN
    Posts
    3,057
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    you got something wrong, how many cca on batt. any thing 650 or better is more than enough, especially with that alt... do you got big 3?




    H.U. - Pioneer P7200HD
    Fronts - Pioneer premier TS-C720PRS
    Rear - Pioneer TS-D6902R
    Amp - kx2500.1
    Sub - AQ HDC4 12
    just a lil' slam for now.... tuned to 33hz!!!!!

    complete budget system under 400.00... (kenwoods)
    http://www.youtube.com/watch?v=YtyFmWXI94U&list=LLCQ1MqkfSOcRep6vDFWsWxg

  3. #3
    basswiigee's Avatar
    basswiigee is offline CarAudio.com Veteran



    Join Date
    Apr 2013
    Location
    MICHIGAN
    Posts
    3,057
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    I got 2000w on stock batt. stock alt. no problems




    H.U. - Pioneer P7200HD
    Fronts - Pioneer premier TS-C720PRS
    Rear - Pioneer TS-D6902R
    Amp - kx2500.1
    Sub - AQ HDC4 12
    just a lil' slam for now.... tuned to 33hz!!!!!

    complete budget system under 400.00... (kenwoods)
    http://www.youtube.com/watch?v=YtyFmWXI94U&list=LLCQ1MqkfSOcRep6vDFWsWxg

  4. #4
    Chaotic_Thought's Avatar
    Chaotic_Thought is offline Senior VIP Member



    Join Date
    Oct 2011
    Location
    Vinita, OK
    Posts
    159
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Where did the alt come from? I find it hard to believe a low quality xplod warrants an upgraded alt.




  5. #5
    basswiigee's Avatar
    basswiigee is offline CarAudio.com Veteran



    Join Date
    Apr 2013
    Location
    MICHIGAN
    Posts
    3,057
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    go to autozone and test your alt.




    H.U. - Pioneer P7200HD
    Fronts - Pioneer premier TS-C720PRS
    Rear - Pioneer TS-D6902R
    Amp - kx2500.1
    Sub - AQ HDC4 12
    just a lil' slam for now.... tuned to 33hz!!!!!

    complete budget system under 400.00... (kenwoods)
    http://www.youtube.com/watch?v=YtyFmWXI94U&list=LLCQ1MqkfSOcRep6vDFWsWxg

  6. #6
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,389
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Get the BIG 3 Done on your supply.Should help with that




  7. #7
    EGordon_'s Avatar
    EGordon_ is offline Junior Member

    Threadstarter


    Join Date
    Jul 2013
    Location
    United States
    Age
    18
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    I don't believe so.. I bought the car off a guy about 2 weeks ago with the system all hooked up so I am not entirely sure. Big 3 would fix that problem without the need of a second battery + isolator?




  8. #8
    EGordon_'s Avatar
    EGordon_ is offline Junior Member

    Threadstarter


    Join Date
    Jul 2013
    Location
    United States
    Age
    18
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    I brought it to advanced auto parts the other day and he said that the only way to prevent battery dying is second batt + iso.. I am not the most knowledgable with cars so I've been trying to inform myself through research the best I can




  9. #9
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,389
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Quote Originally Posted by EGordon_ View Post
    I don't believe so.. I bought the car off a guy about 2 weeks ago with the system all hooked up so I am not entirely sure. Big 3 would fix that problem without the need of a second battery + isolator?
    If you have the big three done, and the 200 amp alt as you say you have, and a decent battery(perferb.a min of an Orileys AGM batt)You shouldnt have ANY ISSUES With that kind of supply demand




  10. #10
    EGordon_'s Avatar
    EGordon_ is offline Junior Member

    Threadstarter


    Join Date
    Jul 2013
    Location
    United States
    Age
    18
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Quote Originally Posted by audiobaun View Post
    If you have the big three done, and the 200 amp alt as you say you have, and a decent battery(perferb.a min of an Orileys AGM batt)You shouldnt have ANY ISSUES With that kind of supply demand
    That's reassuring. So is the battery current equipped up to par or should I return/replace ? Big 3 should fix issue of battery dying?




  11. #11
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,389
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    I wouldnt spend my time or money on an Isolator




  12. #12
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,389
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Quote Originally Posted by EGordon_ View Post
    That's reassuring. So is the battery current equipped up to par or should I return/replace ? Big 3 should fix issue of battery dying?
    That battery is actually too small im my opinion for anything over 600rms

    ---------- Post added at 12:27 PM ---------- Previous post was at 12:27 PM ----------

    What vehicle is it??




  13. #13
    EGordon_'s Avatar
    EGordon_ is offline Junior Member

    Threadstarter


    Join Date
    Jul 2013
    Location
    United States
    Age
    18
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Quote Originally Posted by audiobaun View Post
    That battery is actually too small im my opinion for anything over 600rms

    ---------- Post added at 12:27 PM ---------- Previous post was at 12:27 PM ----------

    What vehicle is it??
    2003 Ford Mustang, 3.8L v6.

    What should the min. battery size/power I should be looking for have? Any specific suggestions/brands?




  14. #14
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,389
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Super Start® Platinum 78PLT - AGM Battery | O'Reilly Auto Parts
    I run two of these in my truck w 200 amp alt on 4k,and one in my honda crv with big3 stock alt on approx 2k with ELD bypass




  15. #15
    des343's Avatar
    des343 is offline CarAudio.com Elite



    Join Date
    Feb 2011
    Location
    Kalamazoo, MI
    Posts
    962
    Post Thanks / Like
    Mentioned
    7 Post(s)

    Re: System keeps killing my battery.. need some advice.. PLEASE!

    Make sure something isn't screwy with the remote wire..say the amp isn't shutting off like It is supposed to..

    You mean your vehicle dies when not in use right?




+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. almost done with my box, need some advice
    By derek33 in forum Enclosure Design & Construction Help
    Replies: 5
    Last Post: 02-19-2005, 10:51 AM
  2. Etronics and my cm3...need some advice.
    By Strecker25 in forum Subwoofers
    Replies: 5
    Last Post: 05-03-2004, 11:13 PM
  3. decided to port my box, need some advice
    By substance in forum Enclosure Design & Construction Help
    Replies: 11
    Last Post: 04-04-2003, 10:44 AM
  4. need some advice please
    By slickrick in forum Subwoofers
    Replies: 2
    Last Post: 02-06-2002, 11:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum