Closed Thread
Results 1 to 5 of 5

Reload Thread: Alternator Problems

  1. #1
    SounDrive's Avatar
    SounDrive is offline SounDrive RCA



    Join Date
    Apr 2013
    Location
    Lebanon & Knoxville, TN
    Posts
    1,920
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Alternator Problems

    My "check charging system" light was on and Oreilly's tested my alt and said the diodes and regulator were bad. (wiper fluid hose broke and soaked my alternator...) It was charging somewhere around 14.5v, but the current was weak. I just now got my Mechman 240a (internally regulated) in, and the light still comes on. It's only charging up to 13.3v at idle and at 2k RPM.

    DMM reads 13.3v at the battery AND alt, so it isn't a connection issue.

    The harness has 3 wires reading 11.9v and 12.3v (and ground) with the car off. Battery rests at 12.4v. Can't test the harness with the alt running. Alt fuse is still good. And yes, I know I need a new battery but that should have nothing to do with the alt not charging past 13.3v



    Can anyone think of anything else that could be bad? It seems odd to me that an alternator that was literally built and tested yesterday would be bad. I've emailed mechman but I'm still waiting on a reply, and it could be a while since it's the weekend.



    Owner, SounDrive Custom RCAs (and other cables)

    Find us on Facebook!




  2. #2
    Jepalan's Avatar
    Jepalan is offline Senior VIP Member



    Join Date
    Jun 2013
    Location
    Midwest
    Posts
    335
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alternator Problems

    What model/year car?




  3. #3
    SounDrive's Avatar
    SounDrive is offline SounDrive RCA

    Threadstarter


    Join Date
    Apr 2013
    Location
    Lebanon & Knoxville, TN
    Posts
    1,920
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Alternator Problems

    Quote Originally Posted by Jepalan View Post
    What model/year car?
    '04 Ford Taurus, 3.0 OHV motor



    Owner, SounDrive Custom RCAs (and other cables)

    Find us on Facebook!

  4. #4
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,403
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Alternator Problems

    yes a bad batt can limit output voltage of the alt. As can belt slip if the wiper fluid got on the belt and you reused it...




  5. Likes raptor727 liked this post
  6. #5
    Jepalan's Avatar
    Jepalan is offline Senior VIP Member



    Join Date
    Jun 2013
    Location
    Midwest
    Posts
    335
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Alternator Problems

    Quote Originally Posted by mlstrass View Post
    yes a bad batt can limit output voltage of the alt. As can belt slip if the wiper fluid got on the belt and you reused it...
    ^^^ I agree. The batt could be loading down the alt if it has an internal short. I would drop in another battery and test it - try to get a loaner so you won't be out the $$$ if it is not the batt.




Closed Thread

Similar Threads

  1. alternator problems HELP!
    By budahbuddy803 in forum General Discussion
    Replies: 3
    Last Post: 03-07-2006, 07:04 PM
  2. bad alternator problem the whole time?
    By Twistid in forum General Discussion
    Replies: 2
    Last Post: 01-15-2006, 01:42 PM
  3. Major Alternator Problem
    By RumbleNTheTrunk in forum General Discussion
    Replies: 4
    Last Post: 08-13-2005, 04:37 PM
  4. I'm having alternator problems guys...please help me out
    By loudfivepoint0 in forum General Discussion
    Replies: 1
    Last Post: 05-21-2005, 01:32 PM
  5. Alternator problem
    By enygma in forum General Discussion
    Replies: 8
    Last Post: 09-21-2002, 04:04 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum