Closed Thread
Results 1 to 6 of 6

Reload Thread: Amp questions!

  1. #1
    lipski24.ml's Avatar
    lipski24.ml is offline Member



    Join Date
    Feb 2013
    Location
    Wisconsin
    Posts
    117
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp questions!

    So I am looking to buy an audiopipe apsm1300 and maybe two kewood kfc-w2513ps subs with it. Now the amp ratings say 1x 600x 2ohms. So does that mean it won't power both subs correctly? I am confused! Oh and do you think that an 8 guage audiopipe wiring kit will work well with this amp? Thanks again for helping with all my stupid questions! I'm only 15 and new to everything but yet I know a good deal for my age!







  2. #2
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,356
    Post Thanks / Like
    Mentioned
    44 Post(s)

    Re: Amp questions!

    That means of.u wire the subs at 2 ohms each sub will roughly get 300rms ....best bet is to run that amp at 1ohm does close to 1000rms cleanly ..also u will need at least a solid 4 gauge kit.to run that amp




  3. #3
    lipski24.ml's Avatar
    lipski24.ml is offline Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Wisconsin
    Posts
    117
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp questions!

    Okay! How would I run two SVC subs at 1 ohm though? I know how to wire down to two ohms. But idk about under that! And alright! I will get a different wiring kit!




  4. #4
    NASTY08IMPALA's Avatar
    NASTY08IMPALA is offline CarAudio.com Veteran



    Join Date
    Aug 2012
    Location
    LOUISVILLE, KENTUCKY
    Posts
    5,356
    Post Thanks / Like
    Mentioned
    44 Post(s)

    Re: Amp questions!

    Quote Originally Posted by lipski24.ml View Post
    Okay! How would I run two SVC subs at 1 ohm though? I know how to wire down to two ohms. But idk about under that! And alright! I will get a different wiring kit!
    Yea true ..forgot those kenwoods were svc ..i would try to find some decent 500-600rms dvc 4ohm subs so u can wire to 1 ohm ..u will be so much more pleased with that setup




  5. #5
    lipski24.ml's Avatar
    lipski24.ml is offline Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Wisconsin
    Posts
    117
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp questions!

    I am really tight on money so I am just going to say screw it for now! But thanks for the help! Already picked out the other amp wiring kit for a better price! So I can't wait to get it with the amp! Thanks again!




  6. #6
    stereoguy's Avatar
    stereoguy is offline Member



    Join Date
    Jun 2013
    Location
    notown
    Posts
    43
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp questions!

    Havent run or heard anyone with those amps but on the power wire for sure go with 4 gauge or bigger cause itll save you money on the long run i just make those mistakes..




Closed Thread

Similar Threads

  1. Amp question
    By adam182002 in forum Amplifiers
    Replies: 8
    Last Post: 02-09-2002, 10:34 PM
  2. Amp question
    By Adam182002 in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 02-08-2002, 05:32 PM
  3. Amp Question
    By RangerMan in forum Subwoofers
    Replies: 2
    Last Post: 02-03-2002, 03:16 PM
  4. Xplod Amp Question
    By Unregistered in forum Amplifiers
    Replies: 2
    Last Post: 01-26-2002, 10:39 PM
  5. Amp question
    By Albokid in forum Amplifiers
    Replies: 1
    Last Post: 01-23-2002, 01:41 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum