+ Reply to Thread
Results 1 to 2 of 2

Reload Thread: V8 WJ Jeep Install

  1. #1
    Braindead's Avatar
    Braindead is offline Senior VIP Member



    Join Date
    May 2013
    Location
    York, SC
    Posts
    324
    Post Thanks / Like
    Mentioned
    0 Post(s)

    V8 WJ Jeep Install

    I'm running 4 gauge for my amp (in a 2001 grand cherokee, with a v8) and need to know where to run the power wire through the firewall, and i don't have a drill powerful enough to make a hole. So anybody who's done a WJ install with the v8 have any suggestions?







  2. #2
    JeepWithLows's Avatar
    JeepWithLows is offline Junior Member



    Join Date
    Jun 2013
    Location
    Turlock, Ca
    Posts
    15
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: V8 WJ Jeep Install

    i drive a 2000 WJ straight6 but it doesnt matter. i had the same problem but its because i didnt want to drill any holes. I finally just gave in and just drilled. Its too dark right now to look. Ill go outside and show you where my wires feed through in the morning.



    H/U: Pioneer 9400bt
    Amps: Skar 1500, RF 400.4
    Subs: (2) Dc lvl 2 15"
    Mids: Crescendo 6.5"

+ Reply to Thread

Similar Threads

  1. V8 WJ Jeep Install problem
    By Braindead in forum Subwoofers
    Replies: 1
    Last Post: 06-22-2013, 09:21 PM
  2. Questions for my upcoming 2010 Jeep Install
    By caewen in forum General Discussion
    Replies: 7
    Last Post: 05-13-2012, 03:05 AM
  3. 2000 Jeep Grand Cherokke Install
    By BALDheadedGRL in forum Speakers
    Replies: 2
    Last Post: 04-13-2004, 03:28 PM
  4. My Jeep system install...
    By goofballer in forum General Discussion
    Replies: 5
    Last Post: 06-26-2003, 03:41 AM
  5. Jeep Grand Cherokee - - installing a flipup monitor!
    By fusi0nhq in forum Enclosure Design & Construction Help
    Replies: 0
    Last Post: 05-21-2003, 06:06 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum