Closed Thread
Results 1 to 8 of 8

Reload Thread: Head unit power problem

  1. #1
    chevykid86's Avatar
    chevykid86 is offline Junior Member



    Join Date
    Apr 2013
    Location
    NJ
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon10 Head unit power problem

    Hey guys . Im posting on behalf of a previous post . Im starting a new post because I couldn't post on the last because tokens were expired ??? . Anyway I got a lot of good advice from you guys about troubleshooting my head unit . This is what I did so far . I checked all wiring and the fuse behind the head unit and everything looks good the fuse is not blown . I unplugged the power supply to the head unit then plugged it back in . It turned on for about 15 to 20 seconds then turned off again . If it is grounding out where would it possibly be ? Can door speakers cause this problem also ? I'm sorry if im asking so much . I am new to this and trying to learn . Everyone's advise and suggestions has helped / worked so far . Im stuck once again . Im not sure what my next step would be .


    This what I have installed into my truck . 2003 s10 crew cab .


    2 Infinity Kappa 100.9w Subwoofer 2 infinity reference 1600a . Kenwood Excelon KDC-X492 deck .







  2. #2
    CrossoverOre's Avatar
    CrossoverOre is online now CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    781
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: Head unit power problem

    when it stops working is the lights and everything turning off or just sound?




  3. #3
    chevykid86's Avatar
    chevykid86 is offline Junior Member

    Threadstarter


    Join Date
    Apr 2013
    Location
    NJ
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Head unit power problem

    everything turns off the whole system . Including the amps .




  4. #4
    CrossoverOre's Avatar
    CrossoverOre is online now CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    781
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: Head unit power problem

    with the deck out but plugged in turn it on and see what happens to the voltage levels at the back of the deck




  5. Thanks chevykid86 thanked for this post
  6. #5
    chevykid86's Avatar
    chevykid86 is offline Junior Member

    Threadstarter


    Join Date
    Apr 2013
    Location
    NJ
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Head unit power problem

    Ok I will check that . what reading should I get ?




  7. #6
    dbertoli's Avatar
    dbertoli is offline Member



    Join Date
    Apr 2013
    Location
    London ontario
    Posts
    42
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Head unit power problem

    Find the black wire which should be ground. Attach it to a metal plate behind Hu. S10s are garbage for wiring Imo.




  8. Thanks chevykid86 thanked for this post
  9. #7
    vented's Avatar
    vented is offline Member



    Join Date
    Feb 2011
    Location
    phenix city al
    Posts
    48
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Head unit power problem

    I had a similar issue, what i ended up having to do is not use the OEM ground at all nor the positive lead, i ran a 12 ga wire directly to the batt and rewired my ac power (the yellow wire) to my fuse panel then my ground to a good spot on the chassis, after that. no issues what so ever




  10. Thanks chevykid86 thanked for this post
  11. #8
    robert420's Avatar
    robert420 is offline Senior VIP Member



    Join Date
    Dec 2012
    Location
    geneva ne
    Posts
    313
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Head unit power problem

    i ended up running a power cable from the pos from the battery, then grounded it out behind the hu. but i had to use a switch to prevent constant power




Closed Thread

Similar Threads

  1. Head Unit Power Issues
    By xGERMx in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 03-02-2005, 05:05 PM
  2. Head unit output problems
    By BlownEARdRUMS in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 01-20-2005, 04:42 PM
  3. Head Unit Power
    By Dark-18 in forum Speakers
    Replies: 3
    Last Post: 12-20-2004, 11:15 AM
  4. Head unit power/capabilities
    By JustPerfect in forum General Discussion
    Replies: 3
    Last Post: 02-20-2004, 05:24 AM
  5. head unit power ratings
    By ructwenty2 in forum General Discussion
    Replies: 1
    Last Post: 02-06-2003, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum