User Tag List

Closed Thread
Results 1 to 12 of 12

Reload Thread: Android head unit wiring help. Cant get it to work anymore :(

  1. #1
    ph0en1xtk's Avatar
    ph0en1xtk is offline Junior Member



    Join Date
    Mar 2013
    Location
    Houston, TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Android head unit wiring help. Cant get it to work anymore :(

    Hello there everyone. I recently purchased a new head unit for my car, along with the metra harness and dash kit. I had the unit installed just fine for about 2 weeks, with no problems at all, but when i went to test my rear view camera that i bought separately, i think i shorted something out. Immediately after hooking it up, the screen on my HU just shows white and is unresponsive. Thinking i shorted out the harness, i unhooked everything and tried hooking the unit up directly to the battery by touching the wires to the 2 battery terminals. Doing that made it boot up like normal, with no problems at all. So thinking i was right in shorting the harness, i took the opportunity to order the beatsonic harness and dash kit (as i was having problems with the metra fitment) and much to my dismay, i had the exact same problem with this one as well, now the unit wont even boot on at all from the harness, but still works fine on the battery (again)

    This led me to believe that something is shorted even further down the line, but to me this doesnt make sense, because reinstalling my stock head unit works perfectly fine.

    Can someone shed some light on this, as im at my wits end now, and im trying to avoid taking it to an expensive audio installer just to troubleshoot.







  2. #2
    colmc11's Avatar
    colmc11 is offline Junior Member



    Join Date
    Mar 2013
    Location
    Charleston, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    I dont know very much about all this, but looks like I am the only one.

    1. I would guess that your head unit is advanced enough to know the power it is getting, so it has gone into some sort of protected mode(?) to protect itself from damage. I guess this would be because somewhere it is getting to much power.

    2. If you installed both accessories yourself you may have cut/connected/tapped into a wire you shouldn't have.

    I would make sure both accessories have no common wires. If they do then disconnect the backup camera's wire and see if that helps. If not then check all connections. That always seems to solve something. Post what your results are and what you have done to troubleshoot.

    Thanks




  3. #3
    ph0en1xtk's Avatar
    ph0en1xtk is offline Junior Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Houston, TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    well i tried again last night. disconnected the back up camera and all accessories. I unhooked the harness and taped off all the wires aside from the yellow, red and black wires, and connected only those to the harness and plugged in the HU, and got the same results




  4. #4
    colmc11's Avatar
    colmc11 is offline Junior Member



    Join Date
    Mar 2013
    Location
    Charleston, SC
    Posts
    10
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    The only other thing I can think of is does your head unit have any safety air bag/seatbelt/park restriction wires?(wires that prevent you from watching movies while you are driving) I would make sure those are good.




  5. #5
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    1,001
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    What kind of vehicle and what kind of deck? Can you still connect straight to the battery and have it work? If you have a dmm verify that you have power and ground at the plug for the aftermarket deck.




  6. #6
    ph0en1xtk's Avatar
    ph0en1xtk is offline Junior Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Houston, TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    I drive a Scion Fr-s and its a knockoff of the following unit:

    Ca-Fi Infotainment | Android

    If i touch the wires to the battery terminal, it works just fine.




  7. #7
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    1,001
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    double check the power at the harness.




  8. #8
    MEMPHISKANE's Avatar
    MEMPHISKANE is offline Junior Member



    Join Date
    Sep 2011
    Location
    Chicago burbs
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    First thing check the fuse panel for your Radio and accessory fuses.




  9. #9
    dbertoli's Avatar
    dbertoli is offline Member



    Join Date
    Apr 2013
    Location
    London ontario
    Posts
    42
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    Yeah I would check fuses.




  10. #10
    ph0en1xtk's Avatar
    ph0en1xtk is offline Junior Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Houston, TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    i checked all of the fuses, and though none of them looked to be blown, i replaced the radio and acc fuses, then i double checked all the connections between the harness and the head unit to make sure they were all getting a good connection, then i moved the ground wire to a different metal spot under the dash.

    some part of this combination allowed the head unit to power up properly and work just fine for about half a day, and now its doing the same thing as before. im not sure what made it work in the first place, but its now back to white screen. testing against the battery terminals once more make it boot properly as before. Im not sure whats going on.

    Are there any other things i could test?




  11. #11
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    1,001
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    what are the voltage levels at the deck plug when you have it installed with the white screen. You might just have to run new constant and acc wires.




  12. #12
    ph0en1xtk's Avatar
    ph0en1xtk is offline Junior Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Houston, TX
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Android head unit wiring help. Cant get it to work anymore :(

    i put a DMM on the wires and both yellow and red get 14.

    also suddenly the unit wont power on anymore when touching the battery terminals. it would previously, but not anymore.

    Im beginning to think the problem is inside of the unit, since my old stock unit works perfectly fine in the car. Im gonna try to send it in to the vendor for service.




Closed Thread

Similar Threads

  1. Picture help. cant get pics to come up without link
    By basscort2009 in forum General Discussion
    Replies: 4
    Last Post: 06-07-2009, 04:41 PM
  2. Pioneer Head Unit broke help me fix it
    By BreakDaLaw in forum Head Units
    Replies: 1
    Last Post: 02-05-2007, 05:21 PM
  3. Head unit wiring help
    By beckSHO in forum Head Units
    Replies: 2
    Last Post: 09-01-2006, 11:21 AM
  4. I need head unit wiring help!!!!
    By FLYASAPELICAN in forum Wiring, Electrical and Installation Help
    Replies: 9
    Last Post: 12-29-2004, 04:51 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum