Closed Thread
Results 1 to 4 of 4

Reload Thread: AVH-P8400BH will NOT power up

  1. #1
    Rod89's Avatar
    Rod89 is offline Junior Member



    Join Date
    Mar 2013
    Location
    United states
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Icon8 AVH-P8400BH will NOT power up

    I just purchased a pioneer AVH-P8400BH from crutchfield NEW $499 and I am soo angry.

    I purchased it becaused I liked the idea of removing the face plate to avoid theft.

    So everytime I park and leave my car, the face plate comes off fine and goes everywhere with me

    But when I go back to my car and TRY to put the face plate back on, its a PAIN IN THE ***!!!!!

    At first I had to slide it up then click it into place about 3 times before it actually powered up.

    Then, 5 times.

    Now today, I probably tried for 30 minutes and it never powered on!!!

    I've had single din face plates before and NEVER had this issue. Wtf could be causing this?!







  2. #2
    robert420's Avatar
    robert420 is offline Senior VIP Member



    Join Date
    Dec 2012
    Location
    geneva ne
    Posts
    333
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    84 Post(s)

    Re: AVH-P8400BH will NOT power up

    could be a bad connection between the faceplate and the unit




  3. #3
    rfmayhem's Avatar
    rfmayhem is offline audio4life



    Join Date
    May 2012
    Location
    near your
    Posts
    824
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    163 Post(s)

    Re: AVH-P8400BH will NOT power up

    i have that same problem putting the face back on i want to believe pioneer didn't think this design thru clearly.i take face of when i really have to which is rearly




  4. #4
    Hjames710's Avatar
    Hjames710 is offline Member



    Join Date
    Mar 2013
    Location
    Douglas County, CO
    Posts
    92
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    29 Post(s)

    Re: AVH-P8400BH will NOT power up

    Crutchfield has pretty good customer support. I'd give them a call and see if they'll replace it.




Closed Thread

Similar Threads

  1. HU will not power on
    By jakeup in forum Wiring, Electrical and Installation Help
    Replies: 14
    Last Post: 06-28-2007, 04:01 PM
  2. ah crap, buddy's HU not powering up...
    By NJTStang11 in forum Head Units
    Replies: 2
    Last Post: 03-02-2007, 03:25 PM
  3. Amplifier not powering up
    By 937DYTBOI in forum Amplifiers
    Replies: 30
    Last Post: 07-25-2006, 01:18 AM
  4. JL 250/1 will not power up
    By sinahptik in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 06-09-2005, 06:07 PM
  5. Amp Not Powering Up
    By dakenwoodman in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 03-24-2005, 10:58 PM

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum