Closed Thread
Results 1 to 7 of 7

Reload Thread: Simple question about Alt. size

  1. #1
    Staynlean's Avatar
    Staynlean is offline Senior VIP Member



    Join Date
    Mar 2013
    Location
    Memphis, TN
    Posts
    338
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Simple question about Alt. size

    So I just found out my factory alternator is 130 amp, is this pretty good, avereage... What do you pros think? Also is it good for the 1000 watt amp I just added. No problems what so ever so far. Big 3 completed as well.

    Oh and also what is the advantage to adding an extra battery, what purpose does it serve?
    Thanks in advance.







  2. #2
    logan963's Avatar
    logan963 is offline Senior VIP Member



    Join Date
    Mar 2013
    Location
    Dallas, TX
    Posts
    290
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Simple question about Alt. size

    Quote Originally Posted by Staynlean View Post
    So I just found out my factory alternator is 130 amp, is this pretty good, avereage... What do you pros think? Also is it good for the 1000 watt amp I just added. No problems what so ever so far. Big 3 completed as well.

    Thanks in advance.
    Its pretty average, you should be fine with the big 3 and an upgraded battery, a little dimming never hurt anyone what is the fuse rating on that amp?




  3. #3
    Staynlean's Avatar
    Staynlean is offline Senior VIP Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Memphis, TN
    Posts
    338
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Simple question about Alt. size

    Fuse rating is 80 A

    It's crazy because I knew that the big 3 had made some kind of difference as soon as I started my truck because the starter motor spun up VERY fast, much faster than before the big 3. I like it a lot.




  4. #4
    logan963's Avatar
    logan963 is offline Senior VIP Member



    Join Date
    Mar 2013
    Location
    Dallas, TX
    Posts
    290
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Simple question about Alt. size

    Quote Originally Posted by Staynlean View Post
    Fuse rating is 80 A

    It's crazy because I knew that the big 3 had made some kind of difference as soon as I started my truck because the starter motor spun up VERY fast, much faster than before the big 3. I like it a lot.
    Thats good, you have 130 amps and the amp will only be pulling 80 at full swing leaving you with 50 amps for everything else, so you should be fine




  5. #5
    Staynlean's Avatar
    Staynlean is offline Senior VIP Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Memphis, TN
    Posts
    338
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Simple question about Alt. size

    Thanks man, sounds good




  6. #6
    mlstrass's Avatar
    mlstrass is online now Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,488
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Simple question about Alt. size

    Quote Originally Posted by Staynlean View Post
    Fuse rating is 80 A

    It's crazy because I knew that the big 3 had made some kind of difference as soon as I started my truck because the starter motor spun up VERY fast, much faster than before the big 3. I like it a lot.
    Means one of your factory wires is old/corroded....




  7. #7
    Staynlean's Avatar
    Staynlean is offline Senior VIP Member

    Threadstarter


    Join Date
    Mar 2013
    Location
    Memphis, TN
    Posts
    338
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Simple question about Alt. size

    Quote Originally Posted by mlstrass View Post
    Means one of your factory wires is old/corroded....
    Yeah, I don't doubt it. Wiring can make such a difference given the right circumstance.




Closed Thread

Similar Threads

  1. question about alts...
    By iceteebone in forum Wiring, Electrical and Installation Help
    Replies: 27
    Last Post: 01-24-2006, 12:46 PM
  2. question about what size fuse
    By iceteebone in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 11-09-2003, 11:18 PM
  3. Simple question about 2 amps
    By TBIRD 38 LX in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 04-23-2003, 04:32 PM
  4. A question about alts.
    By Janus in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 09-02-2002, 11:32 AM
  5. simple question about bridging
    By ZmanTT in forum Amplifiers
    Replies: 7
    Last Post: 08-22-2002, 01:54 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum