Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19

Reload Thread: Amp won't shut off completely!

  1. #1
    youngbump's Avatar
    youngbump is offline Junior Member



    Join Date
    Oct 2011
    Location
    denham springs,LA
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Amp won't shut off completely!

    Ok,so I have no clue why this is happening and I am in desperate need of some help.So I got a new amp and wiring kit in(it's an RE XTX 5000.1 with a knuconceptz 0 gauge wiring kit)and for some reason when my truck is off the power light on my amp still stays on very dim.But when the key is on I flip my toggle switch for my remote wire and it comes on all the way.I tried taking out the remote wire to see if that was it and the light just stayed on dim like before.I checked my terminals and no strands from the power are poking into the remote terminal.Also when the amp is on my sub is making a constant humming sound but when I turn up the volume it plays fine.Any suggestions PLEASE!!! I have a show this weekend I want to compete at and I want my setup good to go.

    Thanks in advance!







  2. #2
    jteske88's Avatar
    jteske88 is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    collinsville il
    Posts
    1,119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    415 Post(s)

    Re: Amp won't shut off completely!

    hey man, i have the same issue. Ive checked draw and it isnt a enought to warrant anything, RE gave me some bs about caps could be discharging but who knows.


    Then the hum sound your talking about could be a ground issue, does the hum go away if you unplug the rca's?




  3. #3
    youngbump's Avatar
    youngbump is offline Junior Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    denham springs,LA
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: Amp won't shut off completely!

    I haven't tried RCA's yet.I did just put in a new ground and I'm not sure if it is holding up to the 0 gauge.I was already going to bolt it directly to the frame today.The rca's are new so they might be screwed up.I'll definitely look into it though,thanks.




  4. #4
    jteske88's Avatar
    jteske88 is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    collinsville il
    Posts
    1,119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    415 Post(s)

    Re: Amp won't shut off completely!

    you feel better about the light now? And what you mean holding up to the 0 gauge? please dont tell me your power is 0 and the ground isnt.




  5. #5
    youngbump's Avatar
    youngbump is offline Junior Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    denham springs,LA
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: Amp won't shut off completely!

    No no it's all 0 gauge.I just don't think the place I have it grounded to is thick enough to conduct very well.




  6. #6
    jteske88's Avatar
    jteske88 is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    collinsville il
    Posts
    1,119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    415 Post(s)

    Re: Amp won't shut off completely!

    well you got the big three done too? That always helps, and you can check your ground with a dmm, you want less than .4 on the resistance. And we all know what a cheap ground looks like.




  7. #7
    youngbump's Avatar
    youngbump is offline Junior Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    denham springs,LA
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: Amp won't shut off completely!

    Don't have the big three done yet,that's my next project though.




  8. #8
    jteske88's Avatar
    jteske88 is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    collinsville il
    Posts
    1,119
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    415 Post(s)

    Re: Amp won't shut off completely!

    what electrical you have? you have to have missive voltage drop with that amp.




  9. #9
    SourDeez's Avatar
    SourDeez is offline CarAudio.com Veteran



    Join Date
    Apr 2007
    Location
    Fuqy u
    Posts
    4,128
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1857 Post(s)

    Re: Amp won't shut off completely!

    This sounds like an amplifier problem. I'd contact RE about it.

    What happens if you remove the power cord? Light still on



    Headunit - Stock cassette player - Pioneer P9400
    Front Stage - Pyle 8 inch subs (1000 watt peak!!) - Polk DB6.5 (about to be CDT 6.5s)
    Rear stage - Deleted (stolen) - Deleted
    Sub stage - custom built 15 inch sony xplod (5k watt peak!!!) (huge box) - Two SA12's built by Corey
    Sub amp - Pyle 8000w peak!! (spl edition) - AQ2200
    Electircal - 35 amp alt from ford festiva upgrade, stolen battery, 28 gauge solder coil for my cable - Dual D34 Yellows, 1/0 trystar OFC, 135amp alt

  10. #10
    youngbump's Avatar
    youngbump is offline Junior Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    denham springs,LA
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: Amp won't shut off completely!

    Terrible voltage drop.don't have a voltmeter yet but I can definitely hear the bass dying down after a minute.Only running one 275 amp deep cycle battery with the stock 60 amp alt for now.




  11. #11
    gamehawk55's Avatar
    gamehawk55 is offline CarAudio.com Elite



    Join Date
    Nov 2012
    Location
    Victoria BC, Canada
    Age
    27
    Posts
    506
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    220 Post(s)

    Re: Amp won't shut off completely!

    The humming could also be the gain turned up to high? I know if I turn my gain up too much I'll get noise through the sub when nothing is playing.




  12. #12
    youngbump's Avatar
    youngbump is offline Junior Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    denham springs,LA
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: Amp won't shut off completely!

    Pulled the power cord and the amp shuts off.like I said it's not staying on enough to send power to the subs.it's just sending just enough power to keep the power light on really dim.




  13. #13
    youngbump's Avatar
    youngbump is offline Junior Member

    Threadstarter


    Join Date
    Oct 2011
    Location
    denham springs,LA
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1 Post(s)

    Re: Amp won't shut off completely!

    The humming isn't the gain.I turned it all the way down and it didn't make a difference.




  14. #14
    slim217's Avatar
    slim217 is offline Member



    Join Date
    Nov 2011
    Location
    illinois
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    11 Post(s)

    Re: Amp won't shut off completely!

    u can try using a filter or ground loop isolator for the sound wont do a thing for the light stayin on but it should help with the noise




  15. #15
    robert420's Avatar
    robert420 is offline Senior VIP Member



    Join Date
    Dec 2012
    Location
    geneva ne
    Posts
    333
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    84 Post(s)

    Re: Amp won't shut off completely!

    the 0 gauge wire could be too big for the amp your running. what kind of power is the amp rated at?




Closed Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. bass shuts off completely help
    By systemJLx in forum General Discussion
    Replies: 4
    Last Post: 11-30-2007, 12:20 AM
  2. Amp to hot. shuts off. pop noises.
    By YoungBuk in forum General Discussion
    Replies: 8
    Last Post: 07-08-2007, 10:20 AM
  3. Amps are just shutting off, not enough power?
    By SkwurlyFab in forum Amplifiers
    Replies: 23
    Last Post: 05-07-2006, 03:32 PM
  4. My amp won't turn off? (WTF)
    By adammk5 in forum General Discussion
    Replies: 10
    Last Post: 04-25-2004, 04:36 PM
  5. ::Help:: My amp won't cut off
    By focused313 in forum Amplifiers
    Replies: 0
    Last Post: 03-29-2004, 01:31 PM

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum