Closed Thread
Results 1 to 14 of 14

Reload Thread: Need some help with my amp

  1. #1
    Drone123's Avatar
    Drone123 is offline Junior Member



    Join Date
    Feb 2013
    Location
    Wichita, Kansas
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Need some help with my amp

    I ordered my Hifonics Hifi1000.d amp from Amazon yesterday got it today. (brand new)

    I have it hooked up to 4 guage wires everything is hooked up currently but the power light wont turn on for some reason.

    The HF logo turns on but neither the Power or Protection light turns on.


    Any idea what the problem could be? I'm trying to hook it up to 2 12 cvrs







  2. #2
    mylows10's Avatar
    mylows10 is online now Dc,tantric,singer,phd rep mylows10 is a Supporting Member of the forum!

    mylows10 is a Supporting Vendor of the forum!

    Join Date
    Sep 2009
    Location
    monterey , ca
    Age
    51
    Posts
    18,628
    Post Thanks / Like
    Images
    9
    Mentioned
    482 Post(s)

    Re: Need some help with my amp

    bad remote wire or bad ground




    pioneer avhx 5500 dvd, gzpa 1.4000 x 2
    ab vfl 350.4 ,7 pc 2150 and a 150 ah power ware agm ,275 amp singer alt , 2nd one coming soon
    cdt 6.5 es 6 im mids,cdt es 010 tweets,es 02 mids ,mx1000 3 way x overs , sky high and stinger hpm o gauge wires ,also 2 tantric hdd 15's in a 9.5. ^3 ported no wall box 11.5 octo port.
    NOR CAL DB DRAG JUDGE
    http://www.dcsoundlab.com

  3. #3
    Drone123's Avatar
    Drone123 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Wichita, Kansas
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    Does the remote wire need to be thicker?




  4. #4
    okcthunder2010's Avatar
    okcthunder2010 is offline Junior Member



    Join Date
    Feb 2013
    Location
    Wynnewood, Ok
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    you say the HF logo lights up on the amp so that means the remote wire is fine, all it needs to do is send a signal to the amp to turn it on and then the power wire from the battery will take care of the rest, but the ground needs to be solid to ensure a strong connection. I would get a digital multimeter or a test light and test your connections. actually your thread will probably help me with my amp problem now. You should get a piece of wire and connect it to the power and remote on the amp and see if your amp powers up




  5. #5
    mylows10's Avatar
    mylows10 is online now Dc,tantric,singer,phd rep mylows10 is a Supporting Member of the forum!

    mylows10 is a Supporting Vendor of the forum!

    Join Date
    Sep 2009
    Location
    monterey , ca
    Age
    51
    Posts
    18,628
    Post Thanks / Like
    Images
    9
    Mentioned
    482 Post(s)

    Re: Need some help with my amp

    you need to check continuity and voltage at the amps remote and power wires when the deck is on




    pioneer avhx 5500 dvd, gzpa 1.4000 x 2
    ab vfl 350.4 ,7 pc 2150 and a 150 ah power ware agm ,275 amp singer alt , 2nd one coming soon
    cdt 6.5 es 6 im mids,cdt es 010 tweets,es 02 mids ,mx1000 3 way x overs , sky high and stinger hpm o gauge wires ,also 2 tantric hdd 15's in a 9.5. ^3 ported no wall box 11.5 octo port.
    NOR CAL DB DRAG JUDGE
    http://www.dcsoundlab.com

  6. #6
    Drone123's Avatar
    Drone123 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Wichita, Kansas
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    I'm getting fed up with this amp, I tried rewiring twice already.... If the fuse that connects from the battery to the amp is blown will that make it stop from powering up? but at the same time the logo lights up.

    The grounding wire is very secure




  7. #7
    mclerico83's Avatar
    mclerico83 is offline CarAudio.com Veteran



    Join Date
    Oct 2009
    Location
    tampa
    Posts
    6,784
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: Need some help with my amp

    Post picture of ground




  8. #8
    trumpet's Avatar
    trumpet is online now Supporting Vendor trumpet is a Supporting Member of the forum!

    trumpet is a Supporting Vendor of the forum!

    Join Date
    Jan 2011
    Location
    Langdon, ND
    Age
    33
    Posts
    4,424
    Post Thanks / Like
    Mentioned
    75 Post(s)

    Re: Need some help with my amp

    Quote Originally Posted by Drone123 View Post
    If the fuse that connects from the battery to the amp is blown will that make it stop from powering up?
    Yes. The low current 12V on the remote line could make the logo light up.




    Small town service, family owned and operated. See our new mobile friendly web site at www.513electronics.com
    Home to CDT Audio's Systems Design Specialist
    Our CDT Audio dealer store, Clarion,_JBL,_Pioneer,_Precision_Power,_RE_Audio,_DB Drive,_Metra,_T-Spec, perfect fit speaker kits for your vehicle
    My system: Pioneer AVH-4000NEX, JBL MS-8, Clarion XC6610 x 2, CDT 6.7"/4"/1.1" in the front doors, 4"/1.1" center channel, QES-1220 12" x 2, Clarion SRG-1622R rear fill

  9. #9
    Drone123's Avatar
    Drone123 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Wichita, Kansas
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    So all I have to do is replace the current blown 100 A fuse and the light should turn on?

    I'll post pictures later, I have to go to work soon.
    I've had this wires hooked up for a while I just replaced my kenwood amp with the hifonics, but the fuse does look a little burnt n cracked. I ordered a new Fuse today it should come in by tomorrow. I appreciate all of you trying to help




  10. #10
    okcthunder2010's Avatar
    okcthunder2010 is offline Junior Member



    Join Date
    Feb 2013
    Location
    Wynnewood, Ok
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    Quote Originally Posted by Drone123 View Post
    So all I have to do is replace the current blown 100 A fuse and the light should turn on?

    I'll post pictures later, I have to go to work soon.
    I've had this wires hooked up for a while I just replaced my kenwood amp with the hifonics, but the fuse does look a little burnt n cracked. I ordered a new Fuse today it should come in by tomorrow. I appreciate all of you trying to help
    LOL the fuse looks a little burnt and cracked...HAHA i'd say that's what your problem is




  11. #11
    Join Date
    Feb 2013
    Location
    Wisconsin
    Posts
    45
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    Quote Originally Posted by Drone123 View Post
    So all I have to do is replace the current blown 100 A fuse and the light should turn on?

    I'll post pictures later, I have to go to work soon.
    I've had this wires hooked up for a while I just replaced my kenwood amp with the hifonics, but the fuse does look a little burnt n cracked. I ordered a new Fuse today it should come in by tomorrow. I appreciate all of you trying to help
    Your problem here is defiantly the fuse. I would check the fuses from your amp to make sure they are in good condition as well.




  12. #12
    Drone123's Avatar
    Drone123 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Wichita, Kansas
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    Yes thank god, my fuse and my holder gets shipped in tomorrow. I'm so ready to test out my subs




  13. #13
    prajeet's Avatar
    prajeet is offline Junior Member



    Join Date
    Feb 2013
    Location
    Rajasthan, India
    Posts
    21
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    Means Fuse save your rupees.... now do check the error... of amps remote and power wires.




  14. #14
    Drone123's Avatar
    Drone123 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Wichita, Kansas
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Need some help with my amp

    Few thank god (:




Closed Thread

Similar Threads

  1. Need some help with my amp settings!!!
    By boosted9-3 in forum General Discussion
    Replies: 2
    Last Post: 04-09-2009, 02:16 PM
  2. Need some help with my sub, amp, and connecting it.
    By BMWAUDIO in forum General Discussion
    Replies: 1
    Last Post: 10-06-2008, 01:48 PM
  3. Replies: 1
    Last Post: 04-09-2008, 09:52 PM
  4. Need some help with my type r's and hifonics amp. what would you do?
    By StupidLoud727 in forum Wiring, Electrical and Installation Help
    Replies: 30
    Last Post: 12-26-2007, 11:12 AM
  5. Need some help with sub/amp combo
    By RoushMan3 in forum General Discussion
    Replies: 0
    Last Post: 02-04-2004, 08:32 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum