Closed Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 20 of 20

Reload Thread: Speakers Hissing

  1. #16
    Knowmadic's Avatar
    Knowmadic is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Gainesville, VA
    Posts
    487
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Speakers Hissing

    Quote Originally Posted by Kingstroker View Post
    not sure, that's what my 80PRS and 700BT says. Probably keeps them from picking up electrical noise from each other
    I mean I'll give it a try, can't hurt anything.







  2. #17
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,439
    Post Thanks / Like
    Mentioned
    13 Post(s)

    Re: Speakers Hissing

    Sounds like a problem with the EQ to me. Which one are you using?



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  3. #18
    pickup1's Avatar
    pickup1 is offline Audiosystem,Dynaudio...



    Join Date
    Aug 2005
    Location
    Roanoke,TX
    Age
    49
    Posts
    7,686
    Post Thanks / Like
    Images
    19
    Mentioned
    29 Post(s)

    Re: Speakers Hissing

    Did the problem start when you added the eq?




  4. #19
    Knowmadic's Avatar
    Knowmadic is offline Senior VIP Member

    Threadstarter


    Join Date
    Feb 2013
    Location
    Gainesville, VA
    Posts
    487
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Speakers Hissing

    Quote Originally Posted by maylar View Post
    Sounds like a problem with the EQ to me. Which one are you using?
    AutoTek 7007 - That is what I'm thinking as well.

    Quote Originally Posted by pickup1 View Post
    Did the problem start when you added the eq?
    Yup.


    Update: I've managed to get it somewhat work.
    • Added ground loop isolators.
    • Separate grounds for EQ and HU
    • Beefier wiring (Was using some crappy thin wire before)
    • Power directly from my distribution block to EQ
    • RCA's moved to right side of car from center, and away from remote wire
    • Grounded RCA's at amp and HU


    Problems Left:
    • Still a slight hiss, but not noticeable when engine is on. - Definitely not my gain, as the gain is set at the lowest and is still getting plenty loud at 15 volume on HU
    • Whine introduced when EQ input goes above 1/4.




  5. #20
    joselr3668's Avatar
    joselr3668 is online now Senior VIP Member



    Join Date
    Feb 2013
    Location
    miami
    Posts
    154
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Speakers Hissing

    I wonder what fxed a large portion of this no matter what I do it doesn't change



    H/U Clarion nx702
    2 sets of massive ck6x off a md42
    1 set of PPI nt.2 super tweets of a Massive bx2
    2 re mx 12" subs in a STARMOUNTAIN enclosure powered by 2 MD3D amps
    MATRIX/

Closed Thread
Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Speaker Hiss
    By FuNKieJuNK in forum Speakers
    Replies: 4
    Last Post: 04-08-2005, 12:12 PM
  2. Speaker hiss and poping
    By 98hd in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 03-22-2005, 03:21 AM
  3. Speakers hissing...
    By xtent in forum General Discussion
    Replies: 7
    Last Post: 10-20-2004, 08:26 PM
  4. back speakers hissing
    By wywy in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 09-15-2004, 09:10 PM
  5. Speaker Hiss, Not Alt Whine.
    By Boomin Granny in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 10-13-2003, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum