Closed Thread
Results 1 to 3 of 3

Reload Thread: bass from my subs hit hard for about 10 minutes then go flat

  1. #1
    tyronekndrck's Avatar
    tyronekndrck is offline Junior Member



    Join Date
    Jan 2013
    Location
    cincinnati oh
    Posts
    15
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)

    bass from my subs hit hard for about 10 minutes then go flat

    i have 2 15 kicker l7s. let me try to explain my problem. ok when I first start my car (chevy lumina) my l7s shake everything in my car then about 10 minutes later the bass don't be hitting like it was. I thought it was my ears just adjusted to it but I don't think its the case could it be battery, amp, or something like that







  2. #2
    ciaonzo's Avatar
    ciaonzo is offline TheContinental



    Join Date
    Feb 2009
    Location
    WI
    Age
    39
    Posts
    9,234
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    549 Post(s)

    Re: bass from my subs hit hard for about 10 minutes then go flat

    Could be the thermal roll back protection in your amplifier or you're experiencing near total thermal compression because your coils are hot.



    Quote Originally Posted by audioholic View Post
    Saying "clipping doesn't kill speakers" is a half-truth at best. Technically no, clipping itself does not hurt the speaker. But in clipping your amp, you can easily create a situation that WILL kill the speaker. Was the squared waveform the DIRECT cause of the failure? No. In the end, the answer is, always has been, and can only be... heat kills speakers. BUT, clipping increases heat generation, sometimes by a drastic amount. So to start a thread simply to state that clipping does not hurt speakers is, again, a half-truth at best.

  3. Thanks tyronekndrck thanked for this post
  4. #3
    tyronekndrck's Avatar
    tyronekndrck is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    cincinnati oh
    Posts
    15
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    3 Post(s)

    Re: bass from my subs hit hard for about 10 minutes then go flat

    makes sense. I will run two amps then




Closed Thread

Similar Threads

  1. No bass coming from my sub with Kicker ZR-600
    By mikecella in forum Amplifiers
    Replies: 17
    Last Post: 06-16-2010, 12:17 AM
  2. my 1 10 in jbl sub hits hard but after awhile it turns down
    By justin082810 in forum General Discussion
    Replies: 7
    Last Post: 11-22-2009, 09:13 PM
  3. my 1 10 in jbl sub hits hard but after awhile it turns down
    By justin082810 in forum General Discussion
    Replies: 0
    Last Post: 11-22-2009, 02:28 AM
  4. How come my subs cut out for a second and then come back on?
    By Jer510 in forum General Discussion
    Replies: 31
    Last Post: 04-21-2009, 10:48 AM
  5. Replies: 24
    Last Post: 04-05-2004, 08:00 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum