Closed Thread
Results 1 to 7 of 7

Reload Thread: rust!? I ain't got time for rust!

  1. #1
    Beatin''s Avatar
    Beatin' is online now CarAudio.com Elite



    Join Date
    Nov 2012
    Location
    MI
    Posts
    986
    Post Thanks / Like
    Mentioned
    2 Post(s)

    rust!? I ain't got time for rust!

    Yesterday I popped the trunk to inspect and got water droplets on the amp. I wiped it down and thought no big deal.

    Today, I saw the ground terminal screw is rusted! wtf!

    There was also some condensation on the square part of the terminal but no rust.

    Is this a problem? Will I have issues down the road?







  2. #2
    orphe's Avatar
    orphe is offline CarAudio.com Elite



    Join Date
    Feb 2005
    Location
    Houston
    Posts
    1,011
    Post Thanks / Like
    Images
    1
    Mentioned
    2 Post(s)

    Re: rust!? I ain't got time for rust!

    find out where that leak is coming from ASAP!!!




  3. #3
    Falcons's Avatar
    Falcons is offline that **** i dont like



    Join Date
    Jan 2011
    Location
    Albion, New York, United States
    Posts
    5,224
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: rust!? I ain't got time for rust!

    yupp.



    Things to look forward to:
    (2) 10" or 12" imperium audio designs subs
    set of PHD MF 6.5" comps
    Completely seal off and deaden my doors
    aquire a 2k amp
    aquire a 2 channel amp for front stage

  4. #4
    Warren89's Avatar
    Warren89 is offline Member



    Join Date
    Dec 2012
    Location
    Maine
    Posts
    55
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: rust!? I ain't got time for rust!

    If water gets on the circuit board kiss the amp bye bye.




  5. #5
    jteske88's Avatar
    jteske88 is offline CarAudio.com Elite



    Join Date
    Apr 2012
    Location
    collinsville il
    Posts
    1,118
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: rust!? I ain't got time for rust!

    well rust n moisture wont go good with electronics, i suggest new seals in the trunk or locate the leak. just a matter of time before the wrong thing gets corrdoed and fries




  6. #6
    cdc351jeferson's Avatar
    cdc351jeferson is offline Premium Member cdc351jeferson is a Supporting Member of the forum!



    Join Date
    Jul 2012
    Location
    austin tx
    Posts
    1,658
    Post Thanks / Like
    Mentioned
    12 Post(s)

    Re: rust!? I ain't got time for rust!

    Quote Originally Posted by Beatin' View Post
    Yesterday I popped the trunk to inspect and got water droplets on the amp. I wiped it down and thought no big deal.

    Today, I saw the ground terminal screw is rusted! wtf!

    There was also some condensation on the square part of the terminal but no rust.

    Is this a problem? Will I have issues down the road?
    its not one of those normal michigan cars you can see through the side panel is it?



    headunit : Sony xab-601bt
    fronts: infinity kappa 60.9's
    box : Bill Fitzmaurice Truck tuba DD 600series 10"
    amp: Kicker zx500.1
    REFS: Bradfordp2612 , Double 07 , NASTY08IMPALA , mzlady

  7. Likes BoomBoxStereo liked this post
  8. #7
    Beatin''s Avatar
    Beatin' is online now CarAudio.com Elite

    Threadstarter


    Join Date
    Nov 2012
    Location
    MI
    Posts
    986
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: rust!? I ain't got time for rust!

    I dont think there is a leak at all.

    I opened the trunk the day before and some of the water around the trunk lid dropped onto the amp. It was raining earlier. I thought I wiped it down correctly but apparently not. It was at the parking lot at work and I was kind of in a hurry to punch in. More water could have dropped onto the amp when I close the trunk. who knows....

    But it is scaring me.

    I gotta figure out a way to cover the amp. Maybe some plastic wrap or something.....




Closed Thread

Similar Threads

  1. IRS got me for the last time (Kmanian shipping delay)
    By kmanian in forum General Discussion
    Replies: 112
    Last Post: 02-10-2009, 09:49 PM
  2. I just got metered for the first time!!
    By Simek4life in forum General Discussion
    Replies: 40
    Last Post: 09-10-2008, 09:04 PM
  3. Im got some free time for boxes if anyone needs one...PM me for a quote
    By mobeious in forum Car Audio Build Logs - Cars/Trucks/SUVs
    Replies: 11
    Last Post: 08-27-2008, 12:47 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum