Closed Thread
Results 1 to 6 of 6

Reload Thread: AM radio suddenly stopped working

  1. #1
    Ragz's Avatar
    Ragz is offline Junior Member



    Join Date
    Jan 2013
    Location
    Dallas, TX
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    AM radio suddenly stopped working

    My favorite sports talk station is on the AM dial so I requently listen to both AM and FM. I have tried troubleshooting this and cannot figure anything out. I have a 2006 Ford Explorer. An aftermarket stereo, JVC KD-R210. No amp or aftermarket speakers installed, its just the aftermarket head unit. I installed the stero 2+yrs ago and have never had any issues with AM or FM reception. 2 weeks ago I flip to AM and get nothing on any station, yet FM still works fine. I scan through the AM stations and the tuner will stop on stations that it is supposed to stop on, like it recogonizes there is a broadcast on that station but I get no sound, really no static either like you would on a weak signal. The weird thing is when I start the vehicle and the radio is on and set to AM, the radio will work for a second or two and then stop the sound output, the radio doesnt turn off or anything, just the sound stops. If I flip between AM and FM I dont get the same result, its only when the vehicle is started. I have removed the stero and checked the wiring and everything appears to be connected properly, all wires seem secure, the antenna wire seems fine. I have tried reasearching online and have not found any direction as to what could be causing this. Any suggesdtions would be much appreciated.







  2. #2
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,445
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    383 Post(s)

    Re: AM radio suddenly stopped working

    Does the vehicle have an antenna amplifier?



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  3. #3
    Ragz's Avatar
    Ragz is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Dallas, TX
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: AM radio suddenly stopped working

    No it does not have an antenna amplifier.




  4. #4
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,445
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    383 Post(s)

    Re: AM radio suddenly stopped working

    There really isn't much for AM besides needing an antenna. Sounds like the radio has issues.



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  5. #5
    Ragz's Avatar
    Ragz is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Dallas, TX
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: AM radio suddenly stopped working

    The only thing I could think of was the radio or something with the antenna, but its only about 2yrs old and didn't want to believe it was the radio.. I'm sure I'll end up replacing it. Thanks for your help




  6. #6
    Ragz's Avatar
    Ragz is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Dallas, TX
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: AM radio suddenly stopped working

    Replaced the stereo and got my AM back. Can't believe the AM tuner went out in only 2yrs. Thanks for your responses Mylar.




Closed Thread

Similar Threads

  1. Rear speakers suddenly stopped working!
    By ledvedder in forum General Discussion
    Replies: 0
    Last Post: 01-16-2013, 12:41 PM
  2. Sub suddenly stopped working
    By JoeK in forum Subwoofers
    Replies: 17
    Last Post: 05-07-2012, 04:58 PM
  3. kenwood kvt-524dvd suddenly stopped working, help please?
    By Jamiej in forum General Discussion
    Replies: 0
    Last Post: 04-07-2012, 12:24 PM
  4. am radio will not work
    By audiomn in forum General Discussion
    Replies: 10
    Last Post: 12-16-2009, 01:40 AM
  5. my cd deck/radio just suddenly stopped working?
    By boombai in forum Head Units
    Replies: 6
    Last Post: 04-20-2009, 02:02 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum