Closed Thread
Results 1 to 15 of 15

Reload Thread: I need help hooking up a sellenium horn

  1. #1
    JJasonTocci's Avatar
    JJasonTocci is offline Member



    Join Date
    Jan 2013
    Location
    Tampa
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    I need help hooking up a sellenium horn

    Ok I have a sub amp already connected to my battery for my 13.5 JL. I hooked up a highs amp to the sub amp which was pretty simple. I now have both amps on when my car is on but when i connect the speaker wire from my highs amp to my selenium speaker all the horn does it make kind of a static sound. Im wondering if what could I have done wrong. Also the amp is my friends amp and we hooked up my horn to it when he had it wired in his truck. He sold me the amp and now it doesnt work.







  2. #2
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,515
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1163 Post(s)

    Re: I need help hooking up a sellenium horn

    Do you have any kind of HPF on the selenium tweeter? Do you have any idea what sound actually comes out of a tweeter?




  3. #3
    Chrispy's Avatar
    Chrispy is offline Senior VIP Member



    Join Date
    Oct 2009
    Location
    Southern IL
    Posts
    398
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    34 Post(s)

    Re: I need help hooking up a sellenium horn

    With the information you gave my guess would be you're using the pass thru on the sub amp to your highs amp which is only passing the low frequencies through. Just my guess until we have more info. What Selenium are you using exactly? What amps and head unit?




  4. #4
    JJasonTocci's Avatar
    JJasonTocci is offline Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Tampa
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: I need help hooking up a sellenium horn

    the sub amp im using is a JL XD600/1, the highs amp is Pyle PLA2378, the speaker is a selenium D250, and the headunit is just a $70 single din pioneer from walmart.




  5. #5
    Chrispy's Avatar
    Chrispy is offline Senior VIP Member



    Join Date
    Oct 2009
    Location
    Southern IL
    Posts
    398
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    34 Post(s)

    Re: I need help hooking up a sellenium horn

    So you have the RCAs coming from the JL preouts going to the Pyle correct? I'm not sure if the JL preouts are full range or whatever you have the crossover set at on the amp. Maybe someone know's but if they are not full range that's the problem. Try unhooking the RCAs from the input of the JL and go directly to the Pyle and see what happens.

    Also make sure you have the pyle on High pass and the frequency to the max which is 300 Hz and pretty low for those D250s so be easy on them.




  6. #6
    Chrispy's Avatar
    Chrispy is offline Senior VIP Member



    Join Date
    Oct 2009
    Location
    Southern IL
    Posts
    398
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    34 Post(s)

    Re: I need help hooking up a sellenium horn

    After some research I found out the JL preouts are full range. I'm not real familiar with Pioneer but do you have a low pass filter set on the head unit?




  7. #7
    JJasonTocci's Avatar
    JJasonTocci is offline Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Tampa
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: I need help hooking up a sellenium horn

    Ok sorry for not replying for a while but I just decided to take out my JL amp and sub and just hook my highs amp up and it's still making the exact same sound.




  8. #8
    SourDeez's Avatar
    SourDeez is offline CarAudio.com Veteran



    Join Date
    Apr 2007
    Location
    Fuqy u
    Posts
    4,128
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1857 Post(s)

    Re: I need help hooking up a sellenium horn

    Bad tweeter or bad amp probably



    Headunit - Stock cassette player - Pioneer P9400
    Front Stage - Pyle 8 inch subs (1000 watt peak!!) - Polk DB6.5 (about to be CDT 6.5s)
    Rear stage - Deleted (stolen) - Deleted
    Sub stage - custom built 15 inch sony xplod (5k watt peak!!!) (huge box) - Two SA12's built by Corey
    Sub amp - Pyle 8000w peak!! (spl edition) - AQ2200
    Electircal - 35 amp alt from ford festiva upgrade, stolen battery, 28 gauge solder coil for my cable - Dual D34 Yellows, 1/0 trystar OFC, 135amp alt

  9. #9
    JJasonTocci's Avatar
    JJasonTocci is offline Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Tampa
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: I need help hooking up a sellenium horn

    But it does the same thing if I hooked it up to just my sub amp, is there a way I can hook it up without an amp?




  10. #10
    SourDeez's Avatar
    SourDeez is offline CarAudio.com Veteran



    Join Date
    Apr 2007
    Location
    Fuqy u
    Posts
    4,128
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1857 Post(s)

    Re: I need help hooking up a sellenium horn

    Quote Originally Posted by JJasonTocci View Post
    But it does the same thing if I hooked it up to just my sub amp, is there a way I can hook it up without an amp?
    I take that back.

    The tweeter and amp is probably fine.

    Its most likely user error.



    Headunit - Stock cassette player - Pioneer P9400
    Front Stage - Pyle 8 inch subs (1000 watt peak!!) - Polk DB6.5 (about to be CDT 6.5s)
    Rear stage - Deleted (stolen) - Deleted
    Sub stage - custom built 15 inch sony xplod (5k watt peak!!!) (huge box) - Two SA12's built by Corey
    Sub amp - Pyle 8000w peak!! (spl edition) - AQ2200
    Electircal - 35 amp alt from ford festiva upgrade, stolen battery, 28 gauge solder coil for my cable - Dual D34 Yellows, 1/0 trystar OFC, 135amp alt

  11. #11
    JJasonTocci's Avatar
    JJasonTocci is offline Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Tampa
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: I need help hooking up a sellenium horn

    Quote Originally Posted by SourDeez View Post
    I take that back.

    The tweeter and amp is probably fine.

    Its most likely user error.
    It probably is I dont know anything about car audio so why dont you tell me what im doing wrong.. I made a video just for you.





  12. #12
    SourDeez's Avatar
    SourDeez is offline CarAudio.com Veteran



    Join Date
    Apr 2007
    Location
    Fuqy u
    Posts
    4,128
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1857 Post(s)

    Re: I need help hooking up a sellenium horn

    Ok dude. Your **** is all screwed up. You need to restart everything and stop just throwing random **** in your trunk

    The selenium tweeters you have are 8 ohm speakers rated at 150 watts

    The amp you are trying to power them with says 2000 watts.. obviously its not nearly that but still, you probably fried the **** out of that tweeter dude. You cant just throw random speakers and amps together and try to connect them and think it will work.


    Pyle PLA2378 (pla-2378) Class A/B 2-Channel Power Car Amplifier
    Selenium D250-X 1" Phenolic Horn Driver 1-3/8"-18 TPI Pro Audio Compression Driver 264-204



    Headunit - Stock cassette player - Pioneer P9400
    Front Stage - Pyle 8 inch subs (1000 watt peak!!) - Polk DB6.5 (about to be CDT 6.5s)
    Rear stage - Deleted (stolen) - Deleted
    Sub stage - custom built 15 inch sony xplod (5k watt peak!!!) (huge box) - Two SA12's built by Corey
    Sub amp - Pyle 8000w peak!! (spl edition) - AQ2200
    Electircal - 35 amp alt from ford festiva upgrade, stolen battery, 28 gauge solder coil for my cable - Dual D34 Yellows, 1/0 trystar OFC, 135amp alt

  13. #13
    JJasonTocci's Avatar
    JJasonTocci is offline Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Tampa
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: I need help hooking up a sellenium horn

    the amp i am using is from my friends truck and he was running a d250 off of it just fine and then when we plugged my d250 in it worked, once we moved the amp from his truck to my car the d250 wouldnt work anymore. yesterday i hooked it up to my other friends truck and it played




  14. #14
    SourDeez's Avatar
    SourDeez is offline CarAudio.com Veteran



    Join Date
    Apr 2007
    Location
    Fuqy u
    Posts
    4,128
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1857 Post(s)

    Re: I need help hooking up a sellenium horn

    One of you fried it



    Headunit - Stock cassette player - Pioneer P9400
    Front Stage - Pyle 8 inch subs (1000 watt peak!!) - Polk DB6.5 (about to be CDT 6.5s)
    Rear stage - Deleted (stolen) - Deleted
    Sub stage - custom built 15 inch sony xplod (5k watt peak!!!) (huge box) - Two SA12's built by Corey
    Sub amp - Pyle 8000w peak!! (spl edition) - AQ2200
    Electircal - 35 amp alt from ford festiva upgrade, stolen battery, 28 gauge solder coil for my cable - Dual D34 Yellows, 1/0 trystar OFC, 135amp alt

  15. #15
    JJasonTocci's Avatar
    JJasonTocci is offline Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Tampa
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    7 Post(s)

    Re: I need help hooking up a sellenium horn

    and if i hook it up to my friends amp and it works, then what? because i know it will




Closed Thread

Similar Threads

  1. Need help hooking up my amp.
    By RbAudio_Geek in forum Amplifiers
    Replies: 4
    Last Post: 08-18-2005, 02:16 PM
  2. Need Help Hooking up Subs
    By Punjabi in forum Subwoofers
    Replies: 1
    Last Post: 02-15-2004, 10:40 PM
  3. need help hooking up home system
    By bearynot in forum Subwoofers
    Replies: 6
    Last Post: 12-14-2003, 12:52 AM
  4. need help hooking up amp
    By southstylestang in forum Amplifiers
    Replies: 4
    Last Post: 11-13-2003, 05:40 AM
  5. Need help hooking up boss amp
    By BenTLocK in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 10-19-2002, 01:22 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum