Closed Thread
Results 1 to 6 of 6

Reload Thread: Amp and Head Unit Cutting Out at Mid Volumes??

  1. #1
    Hammerline81's Avatar
    Hammerline81 is offline Junior Member



    Join Date
    Jan 2013
    Location
    Saskatoon, SK
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon33 Amp and Head Unit Cutting Out at Mid Volumes??

    I just got my Kicker IX1000.1 a couple months ago and everything was completely fine, it rocked the crap out of my little 10'' CVR's. But the other day i was driving and i smelt a voice coil kind of burning. I had my volumes up pretty high, so i turned them down, but a few minutes later after i turned the volume down the amp went into protection mode and would cut in and out.

    I own a older Alpine CDA - 9886 head unit and if i want to rock the crap out of my subs my volume is at 25 and i believe it can go up to 35. when i smelt the voice coils i turned it down to 15, personally speaking thats not loud at all and barely working my subs.

    But at the volume 15 my amp went into protection mode and wont play over 13. I've checked through my wires, fuses, and i even did a ohm test on my two subs and everything appears to be fine. just that my amp wont let me play over 13.

    I hooked up my amp directly to the sub after testing the ohms just to see if maybe the wires inside my box were messed up internally or something stupid. when i was testing each sub the head unit completely shut off as well as my amp, the truck wasnt turned on, but the key was turned to allow power to run inside the cab.

    I dont have a cap, nor another battery for my amp, so could this stuff result in having too little of volts going to the amp? i could see my voltage reading drop a lot on my truck when i had my stuff pumping but why would it all of a sudden decide that it doesnt want to work anymore?

    P.S.
    I have owned a JL Audio JX1000/1D, i blew the thing after blowing one of my 10's but it never cut out like this before and i never owned a second battery nor a cap. so what the hell? time for a battery or cap maybe??







  2. #2
    BlurredVision's Avatar
    BlurredVision is offline CarAudio.com Elite



    Join Date
    Jan 2008
    Location
    Greenville, NC
    Age
    26
    Posts
    538
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp and Head Unit Cutting Out at Mid Volumes??

    Only thing I could think of are the battery or alt. Obviously a weak battery will make your gear malfunction. I didn't have a stereo, but my radio was shutting off from a weak battery. Come to find out my alt was on its last legs. Check both if you're sure its not another simple solution.



    Current Vehicle: 2007 Ford Edge SEL

    Head Unit: JVC KW-AV61BT

    Time to rebuild. Gonna do it right this time

    Planning a SQL setup

  3. #3
    2Dcore's Avatar
    2Dcore is offline F*It



    Join Date
    May 2011
    Location
    PA.
    Age
    39
    Posts
    673
    Post Thanks / Like
    Images
    15
    Mentioned
    5 Post(s)

    Re: Amp and Head Unit Cutting Out at Mid Volumes??

    Does it sound normal up until 13, No scratchiness or popping?



    HU- alpine CDA 117
    Front - RF 6 .5 T1 comps & RF pro audio super tweets (Amp-Memphis 16-MCA5004)
    Rear - 15" DC lvl 4 with lvl 5 soft parts
    (Amp Kicker kx2500.1
    Kinetic HC 2400's- Big 3 And a big mess of wire

  4. #4
    ThatChevyGuy's Avatar
    ThatChevyGuy is offline i heart Jager



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,170
    Post Thanks / Like
    Mentioned
    12 Post(s)

    Re: Amp and Head Unit Cutting Out at Mid Volumes??

    get a small batt like a shuriken bt20. bad voltage drop WILL fry your amp. Also be careful with your amp settings, low gain, no bass boost, no loud features. those cvr's are maxed out and are probably not in an optimal enclosure either. My truck cut out like you describe and it didn't do it at first. i bought a shuriken and problem solved. Hopefully you havent damaged your amp yet.



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  5. #5
    Hammerline81's Avatar
    Hammerline81 is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Saskatoon, SK
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp and Head Unit Cutting Out at Mid Volumes??

    The battery is a year old, but who knows what happened with it? It's an interstate and I do own a V8 so I have bigger stuff than a car (alternator, battery, etc.) but I'll check all that stuff out just in case. It sounds normal at 13, the subs are vibrating and and what not, any higher it shuts my stuff off. I'll first hook my amp up to a buddies system and we will see what happens with the amp, I'll know it's screwed if it does the same stuff I guess, but I explained this situation to the Kicker tech and he said that my amp shouldn't be blown but it sounds like I screwed my subs?




  6. #6
    Hammerline81's Avatar
    Hammerline81 is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Saskatoon, SK
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp and Head Unit Cutting Out at Mid Volumes??

    Just updating this thread to who gave me advice; I tested my amp on my buddies subs and the amp is okay. I'm getting my battery replaced as soon as possible and I'll see what happens then. Would my altinator be effected much by hooking a 12v to my truck? I know about compassitors. I thought that they would help but everyone says that they are just decoration to a stereo system. So how does a 12v battery work in this case? Ive been looking at the Kinetik battery, it's blue, not sure what the model number it is, but are they good?




Closed Thread

Similar Threads

  1. Head Unit Cutting Out?
    By gatorgrizz27 in forum General Discussion
    Replies: 11
    Last Post: 04-24-2006, 09:17 PM
  2. Head Unit Cutting Out?
    By gatorgrizz27 in forum Head Units
    Replies: 0
    Last Post: 04-18-2006, 07:00 PM
  3. Head unit cuts out when turned up
    By bigbirney420 in forum Head Units
    Replies: 10
    Last Post: 07-25-2005, 01:06 AM
  4. Head Unit Cutting Out!
    By hargenoff in forum General Discussion
    Replies: 8
    Last Post: 07-27-2003, 11:47 PM
  5. Head unit cuts out when I use AC
    By Topdawg2982 in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 08-01-2002, 01:28 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum