Closed Thread
Results 1 to 5 of 5

Reload Thread: Amp keeps going in and out of protection after a few bumps.

  1. #1
    2252B's Avatar
    2252B is offline Junior Member



    Join Date
    Jan 2013
    Location
    Milwaukee WI
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp keeps going in and out of protection after a few bumps.

    I have a Memphis 16-SR1.250 that keeps going in and out of protection. It works for a few hits then enters protection before working for a little while again. It seems to get worse the higher the volume is. If I keep the volume low it seems to work fine.

    Everything is wired correctly and I checked it with a voltmeter.

    So I was wondering if somehow the amp is drawing to much power or if my car is not able to provide it enough thus causing it to go into protection?

    Anything to help would be appreciated, thanks.







  2. #2
    itsblown's Avatar
    itsblown is offline why is there smoke?



    Join Date
    Sep 2011
    Location
    Toledo OH
    Posts
    1,147
    Post Thanks / Like
    Mentioned
    15 Post(s)

    Re: Amp keeps going in and out of protection after a few bumps.

    my username man




  3. #3
    frogcase2002's Avatar
    frogcase2002 is online now CarAudio.com Elite



    Join Date
    Dec 2011
    Location
    hamilton, ohio
    Posts
    532
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: Amp keeps going in and out of protection after a few bumps.

    What ohm are the subs and how are they wired inside the box? And what are your volts dropping to with your system up?




  4. #4
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,106
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Amp keeps going in and out of protection after a few bumps.

    ^^This. Has it always done this, is it a new install, or did it work before and all of a sudden start doing this?



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

  5. #5
    jhayar251987's Avatar
    jhayar251987 is offline Junior Member



    Join Date
    Dec 2012
    Location
    philippines
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp keeps going in and out of protection after a few bumps.

    i think wrong loading of speaker....if to much load to your am thas the reason why your amp keep on protect..or may be they have a dc out from speaker..




Closed Thread

Similar Threads

  1. JBL GTO1004 jumps in and out of protect.
    By skylineTT in forum Amplifiers
    Replies: 9
    Last Post: 02-14-2012, 06:44 PM
  2. vr4000d in and out of protection? idears?
    By da box king in forum General Discussion
    Replies: 0
    Last Post: 05-20-2010, 09:05 PM
  3. kx2500 all of a sudden started going in and out of protect...
    By aaron7114 in forum General Discussion
    Replies: 9
    Last Post: 07-13-2009, 03:30 PM
  4. kx2500 going in and out of protect...
    By aaron7114 in forum Amplifiers
    Replies: 0
    Last Post: 05-18-2008, 01:09 PM
  5. kicker kx2500.1 going in and out of protect
    By IgnoreMe in forum Amplifiers
    Replies: 24
    Last Post: 08-14-2007, 11:44 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum