Closed Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 21 of 21

Reload Thread: Subwoofer Problem! Help!

  1. #16
    Atimm693's Avatar
    Atimm693 is offline Shadetree Mechanic



    Join Date
    Nov 2006
    Location
    Up the down escalator
    Posts
    2,569
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    15 Post(s)

    Re: Subwoofer Problem! Help!

    Quote Originally Posted by fanzyboy234 View Post
    Trust me ive rewired them 4 time. + to + - to- + to + voltmeter side, - to - voltmeter side.
    Like it's been said it's not possible to have the coils on a sub test fine separately then have them read like that when connected. You do have the subs disconnected from the amp while testing right?

    Being dual 4 subs in parallel would be 2 ohms per channel, which your amp probably will support. It can support it for sure if it can be bridged. And your amp could've smoked a sub if you pushed it hard enough into clipping.



    1994 Toyota Camry
    Pioneer DEHP6400BT
    Rockford Fosgate 1050S
    12" DD 3512C
    2.5 cuft, 35hz
    1050wrms@4ohms




  2. #17
    dbjunior's Avatar
    dbjunior is offline CarAudio.com Elite



    Join Date
    Jun 2009
    Location
    ma
    Posts
    762
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    122 Post(s)

    Re: Subwoofer Problem! Help!

    If each coil is still reading good check the wire you used. What gauge is it?



    bought from MBROOKY, johnny law.Lulz, subzero, tc3k101
    sold to mytrunkslamz , vitveet, cd6551, martiandancer31 (x2), pro-rabbit, whytellyou
    Trade with cf2004

  3. #18
    maylar's Avatar
    maylar is offline Electrical Weenie



    Join Date
    Jan 2002
    Location
    Connecticut
    Age
    62
    Posts
    3,445
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    383 Post(s)

    Re: Subwoofer Problem! Help!

    Something is shorted. Could be how you attach wires to the terminals, could be the wires themselves. Think it through and you'll figure it out.



    dave
    ----------
    1999 Buick Park Ave Ultra
    Head Unit: JVC KWHDR720
    EQ: Audiocontrol EQL
    Front Stage: Hybrid Audio Technologies Imagine 5.25 mids, Morel Maximo tweets
    Sub Stage: Boston G3 10", 0.5 cu ft sealed
    Amp: PPI Phantom 900.4
    Rear Fill: Boston SE953 6X9's

  4. #19
    frogcase2002's Avatar
    frogcase2002 is offline CarAudio.com Elite



    Join Date
    Dec 2011
    Location
    hamilton, ohio
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    100 Post(s)

    Re: Subwoofer Problem! Help!

    Wire each sub in series and see if they read close to 8 then parallel to the amp




  5. #20
    fanzyboy234's Avatar
    fanzyboy234 is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Butler Pennsylvania
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5 Post(s)

    Re: Subwoofer Problem! Help!

    I wired to 8 too and.its reading the same. And my wire is 14 gauge. And no it was not hooked up to the amp




  6. #21
    fanzyboy234's Avatar
    fanzyboy234 is offline Junior Member

    Threadstarter


    Join Date
    Jan 2013
    Location
    Butler Pennsylvania
    Posts
    9
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5 Post(s)

    Re: Subwoofer Problem! Help!

    The thing is they were both reading 2 ohm but after i hooked them to.the.amp.and it went into protect mode, it stopped reading right




Closed Thread
Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Weird Subwoofer Problem - Please Help Me!
    By SnowCommando in forum Subwoofers
    Replies: 11
    Last Post: 04-07-2009, 07:05 AM
  2. Subwoofer Problem! Please Help!
    By enjoi598 in forum Subwoofers
    Replies: 2
    Last Post: 10-12-2007, 07:52 PM
  3. Need help with 2 12' Subwoofers/problem
    By paintballer in forum Subwoofers
    Replies: 9
    Last Post: 11-14-2006, 06:57 PM
  4. subwoofer problem help
    By supra06 in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 03-10-2006, 08:39 AM
  5. Need help with subwoofer problem
    By Silk in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 01-06-2003, 08:46 PM

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum