Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23

Reload Thread: Amplifier turns off when volume is turned up

  1. #1
    J1nx93's Avatar
    J1nx93 is offline Junior Member



    Join Date
    Dec 2012
    Location
    West Virginia
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amplifier turns off when volume is turned up

    I have a 2010 Jeep Wrangler. I have installed Polk db6501 components, db651 coaxials, a JVC Arsenal KDA735BT and a Kenwood X450-4 to power the speakers. I have everything wired correctly, I've checked my fuses and ground, I have heavy enough wire too. The thing is, my system turns on, plays music on FM radio until I turn the volume to 18 which isn't loud at all, before my amp kicks off. The volume can go to about 16 on a CD before the amp kicks off. When I turn on the ignition, the red light comes on the top of the amp, but when I turn the volume to those levels, it turns off completely. My ground is on a seat bolt connected to the body also.

    I REALLY need help ASAP as I'm in from college on Christmas break and have limited time. My cousin will be at my house to help at midnight so I'd like some answers by then please.

    I haven't tried the gain yet but that may be it. I don't think its my speakers or speaker wires either. There may be a slight possibility it's my ground, remote lead, gain settings or such. Please give me your expert opinions!

    Thanks.







  2. #2
    4OZGLOVES's Avatar
    4OZGLOVES is offline <--- Gina FTMFW



    Join Date
    Mar 2009
    Location
    PITT. PA
    Posts
    1,705
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Amplifier turns off when volume is turned up

    Sounds like a bad ground.



    Refs
    FJF, tooshort_128 , BushJ311(local) , FRIEK, vactor, ls2poweredgoat(X2) , chrisw91, psycoacoustics, sundownz, 01 s10, headlesskoopa, twisted_0912(x3) ,trystanmay, coma toast, lord baccus, oldschool4me, beatkeeper, scbeerbarge, dwrecked, beatkeeper1, infamous_e46, neel, plugger, Cal, Centergod79

  3. #3
    J1nx93's Avatar
    J1nx93 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    West Virginia
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier turns off when volume is turned up

    Quote Originally Posted by 4OZGLOVES View Post
    Sounds like a bad ground.
    I have it under a seat bolt thats mounted to the body. There isn't a better one possible. What do I do




  4. #4
    4OZGLOVES's Avatar
    4OZGLOVES is offline <--- Gina FTMFW



    Join Date
    Mar 2009
    Location
    PITT. PA
    Posts
    1,705
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Amplifier turns off when volume is turned up

    Quote Originally Posted by J1nx93 View Post
    I have it under a seat bolt thats mounted to the body. There isn't a better one possible. What do I do
    Seat bolts are a terrible ground. I would run a ground directly from the frame.



    Refs
    FJF, tooshort_128 , BushJ311(local) , FRIEK, vactor, ls2poweredgoat(X2) , chrisw91, psycoacoustics, sundownz, 01 s10, headlesskoopa, twisted_0912(x3) ,trystanmay, coma toast, lord baccus, oldschool4me, beatkeeper, scbeerbarge, dwrecked, beatkeeper1, infamous_e46, neel, plugger, Cal, Centergod79

  5. #5
    J1nx93's Avatar
    J1nx93 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    West Virginia
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier turns off when volume is turned up

    Quote Originally Posted by 4OZGLOVES View Post
    Seat bolts are a terrible ground. I would run a ground directly from the frame.
    How would I do so? I only have a 3 ft cable. I'd prefer not drilling a bunch.




  6. #6
    4OZGLOVES's Avatar
    4OZGLOVES is offline <--- Gina FTMFW



    Join Date
    Mar 2009
    Location
    PITT. PA
    Posts
    1,705
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Amplifier turns off when volume is turned up

    Buy a longer run of wire and come through one of the drain holes in the tub of the jeep with a grommet



    Refs
    FJF, tooshort_128 , BushJ311(local) , FRIEK, vactor, ls2poweredgoat(X2) , chrisw91, psycoacoustics, sundownz, 01 s10, headlesskoopa, twisted_0912(x3) ,trystanmay, coma toast, lord baccus, oldschool4me, beatkeeper, scbeerbarge, dwrecked, beatkeeper1, infamous_e46, neel, plugger, Cal, Centergod79

  7. #7
    orphe's Avatar
    orphe is offline CarAudio.com Elite



    Join Date
    Feb 2005
    Location
    Houston
    Posts
    1,011
    Post Thanks / Like
    Images
    1
    Mentioned
    2 Post(s)

    Re: Amplifier turns off when volume is turned up

    your amp may be porked




  8. #8
    J1nx93's Avatar
    J1nx93 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    West Virginia
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier turns off when volume is turned up

    Could it be a bad remote connection? Should I try hooking my remote to a cigarette outlet?




  9. #9
    Trevor28139's Avatar
    Trevor28139 is offline Member



    Join Date
    Dec 2012
    Location
    Rutherfordton NC
    Posts
    61
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: Amplifier turns off when volume is turned up

    is it possible that the ohm load is too low for the amp?




  10. #10
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,127
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Amplifier turns off when volume is turned up

    Quote Originally Posted by J1nx93 View Post
    Could it be a bad remote connection? Should I try hooking my remote to a cigarette outlet?
    It's probably not that. Where is it wired to now? If you want to test, just jump a little peice of wire from your amp positive to the remote. Don't leave it here though because your amp will stay on all the time.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

  11. #11
    J1nx93's Avatar
    J1nx93 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    West Virginia
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier turns off when volume is turned up

    Quote Originally Posted by gckless View Post
    It's probably not that. Where is it wired to now? If you want to test, just jump a little peice of wire from your amp positive to the remote. Don't leave it here though because your amp will stay on all the time.
    It's wired to the blue/white remote wire on the harness.




  12. #12
    frogcase2002's Avatar
    frogcase2002 is offline CarAudio.com Elite



    Join Date
    Dec 2011
    Location
    hamilton, ohio
    Posts
    534
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: Amplifier turns off when volume is turned up

    Just find a good place in the body or frame that you can reach to and scape all the paint off untill its bare metal (can find a good spot under the carpet somewhere by the amp) and just screw/bolt your ring terminal on your ground wire down...... and also how do you have speakers hooked to your amp. Could maybe be to low of an ohm load for the amp?




  13. #13
    J1nx93's Avatar
    J1nx93 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    West Virginia
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amplifier turns off when volume is turned up

    People on the jk-forum said this ground works. I may try sanding it More though. And I have 4 ohm speakers and a 4 ohm amp. Check the specs on it




  14. #14
    Join Date
    Apr 2012
    Location
    Danville, KY
    Posts
    1,109
    Post Thanks / Like
    Mentioned
    15 Post(s)

    Re: Amplifier turns off when volume is turned up

    Whats your voltage?




  15. #15
    frogcase2002's Avatar
    frogcase2002 is offline CarAudio.com Elite



    Join Date
    Dec 2011
    Location
    hamilton, ohio
    Posts
    534
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: Amplifier turns off when volume is turned up

    Quote Originally Posted by J1nx93 View Post
    People on the jk-forum said this ground works. I may try sanding it More though. And I have 4 ohm speakers and a 4 ohm amp. Check the specs on it
    Its got to be the gain then. Iv had it happen a few times with 4 Chan. Amps. They cut off all the time untill I would turn the gain down a little and it would be fine after.


    And yea with most setups a seatbelt or something will work alright but mite as well do your ground as good as you can... it can really make a big difference in your voltage drop




Closed Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. Amp Turns Off When Car is on
    By Maxipads in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 02-03-2010, 08:13 PM
  2. Replies: 4
    Last Post: 10-26-2007, 12:57 PM
  3. Fan Doesn't turn off when car is off!!
    By TTU in forum Wiring, Electrical and Installation Help
    Replies: 15
    Last Post: 05-11-2006, 07:39 PM
  4. HELP! Cd player turns off when volume turned high!
    By aspen1284 in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 03-10-2006, 03:24 PM
  5. Cd player turns off when volume goes up
    By bizarre179 in forum General Discussion
    Replies: 5
    Last Post: 08-02-2005, 11:12 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum