Closed Thread
Results 1 to 15 of 15

Reload Thread: I bet you cant figure this one out!!!

  1. #1
    treiber67's Avatar
    treiber67 is offline Member



    Join Date
    Dec 2012
    Location
    ft.lauderdale fl
    Posts
    127
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    21 Post(s)

    I bet you cant figure this one out!!!

    Ok, so ive recently installed a daily driver into my buick lasabre.....pretty much all knock off stuff yes i know im being shunned right now. Since installing my boss phantom 5000 watt....which did suprise me as to what it can do to two 15 inch cvr's ive been having issues with having to put new ones in which is stressing me out. Everytime i have it going for two to three days at a time something goes wrong with the rca's on the amplifier the outputs them selves. One the first amplifier it cut the bass in half, i got a replacement two days later the rcas dont work period. I dont have a volt meter or else id test it that way but im going to be getting another replacement boss phantom 5000 asap. Heres the thing waht would cause issues with the rcas internally on the amplifier to go out? Not enough volts from the subwoofer out-put from deck, ground wiring from chassie isnt big enough...Has anyone ever had similar problems with amplifiers? Its pissing me off, its not the amp its self i believe it has to do with the installer "myself" and what ive used to hook this system up with.
    4ga wiring kit "knock off" prolly more like 6ga
    y-splitter from subwoofer output because its one of those garbage touchscreens with a single output lol.
    i do have a second pair that ive already tried to connect two and from deck to amp.







  2. #2
    av83's Avatar
    av83 is offline CarAudio.com Veteran



    Join Date
    Mar 2012
    Location
    Illinois
    Posts
    2,999
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1322 Post(s)

    Re: I bet you cant figure this one out!!!

    Man, I don't even know where to start.

    But, just trying to be helpful here... are your amps securely mounted as to prevent tugging on the rca's? And honestly, boss is absolutely horrible. The build quality is worse than audiopipe, but at least AP will do closer to rated power. And yes, undersized wiring is a big problem.



    80prs
    SoundQubed 6.5 Pro's DD T2 Tweeters / Phoenix Gold Xenon 100.4
    FI SP4 15 D1 w/ Tantric Sounds softies / DC 5.0K
    Singer 310 6 phase 2 runs of Monster Cable 1/0 / Exide g78 AGM under hood and XS D3100 in rear
    Plenty of deadener. CCF and fiberglass insulation in doors... thanks to the advice of keep_hope_alive they sound AWESOME! :-)

  3. Thanks treiber67 thanked for this post
  4. #3
    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,733
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1108 Post(s)

    Re: I bet you cant figure this one out!!!

    That boss amp isn't terrible, it's good for 1500w, but then again build quality comes into play. Maybe something defective in the source unit? You might just be frying the amp from ****** wiring and no secondary power source (extra battery)



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)

    Quote Originally Posted by BassAndBeer View Post
    sorry man but ford will always be a ford. ford is the sony xplod of cars and trucks. you had bad experiences with chevy because your a ford guy. its what seperates the men from the boys. friend billy use to drive a ford. he drives a chevy now. they call him billy no more. hes known as bill now..

  5. #4
    treiber67's Avatar
    treiber67 is offline Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    ft.lauderdale fl
    Posts
    127
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    21 Post(s)

    Re: I bet you cant figure this one out!!!

    Rca's have plenty of lee way, i was just wondering if the ground isnt good enough to and from the amp would it cause it to pull from the rca grounds inside the amplifier. As for the output on the boss phantom 5000.1 at 1ohm.....lol its crazy to think that a 130 dollar amp will put out 1500 rms+++ i had a kicker kx1200.1 pushing these awhile back and to be honest the boss is making them it harder.




  6. #5
    treiber67's Avatar
    treiber67 is offline Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    ft.lauderdale fl
    Posts
    127
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    21 Post(s)

    Re: I bet you cant figure this one out!!!

    As for the amps efficancy....very good, i can have this thing hitting lows at the stop light and it wont go lower than 12.4 i was amazed i. I have a volt meter installed.
    Stock 140amp alt
    new battery...nothing special.




  7. #6
    treiber67's Avatar
    treiber67 is offline Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    ft.lauderdale fl
    Posts
    127
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    21 Post(s)

    Re: I bet you cant figure this one out!!!

    I should of known better to cut corners on headunit, and wiring, and amp, and subs....its all garbage. I need to hit the lottery!




  8. #7
    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,733
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1108 Post(s)

    Re: I bet you cant figure this one out!!!

    Patience and piece things together.



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)

    Quote Originally Posted by BassAndBeer View Post
    sorry man but ford will always be a ford. ford is the sony xplod of cars and trucks. you had bad experiences with chevy because your a ford guy. its what seperates the men from the boys. friend billy use to drive a ford. he drives a chevy now. they call him billy no more. hes known as bill now..

  9. #8
    pro-rabbit's Avatar
    pro-rabbit is offline Moderator pro-rabbit is a Supporting Member of the forum!

    pro-rabbit is a Supporting Vendor of the forum!

    Join Date
    Jan 2004
    Location
    OKC, OK
    Age
    33
    Posts
    12,395
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2522 Post(s)

    Re: I bet you cant figure this one out!!!

    Could be various reasons behind the issues from cheap wiring to cheap products to install failure.




  10. #9
    dbjunior's Avatar
    dbjunior is offline CarAudio.com Elite



    Join Date
    Jun 2009
    Location
    ma
    Posts
    865
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    134 Post(s)

    Re: I bet you cant figure this one out!!!

    You need a volt meter. I bet you are getting a lot more voltage drop in the rear id recommend 1/0 even if you don't get a better amp



    bought from MBROOKY, johnny law.Lulz, subzero, tc3k101
    sold to mytrunkslamz , vitveet, cd6551, martiandancer31 (x2), pro-rabbit, whytellyou
    Trade with cf2004

  11. #10
    AnthonyO's Avatar
    AnthonyO is offline StarrMountainSoundNutHugr



    Join Date
    Oct 2005
    Location
    Minot, North Dakota, United States
    Age
    44
    Posts
    1,539
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    495 Post(s)

    Re: I bet you cant figure this one out!!!

    You never answered the question though. Is the amp securely mounted? My guess is its not.



    I lost my father in 2014. My Avatar is in his memory

    2014 Ford Explorer XLT
    Factory Head-Unit integrated by Monster FX100
    SAZ1500v3 running at 2 ohm
    Exonic EXS10x in Starr Mountain Sound Enclosure

  12. #11
    treiber67's Avatar
    treiber67 is offline Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    ft.lauderdale fl
    Posts
    127
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    21 Post(s)

    Re: I bet you cant figure this one out!!!

    hehe....you are correct sir, i was just so excited to get everything in. Now was for it being mounted i was going to do double sided velcro to the amp then to the floor. It cannot be mounted to the back of the seat due to me removing it to get twice the sound....screw the peeps in the back its all about me! is the double sided velcro a no go?




  13. #12
    AnthonyO's Avatar
    AnthonyO is offline StarrMountainSoundNutHugr



    Join Date
    Oct 2005
    Location
    Minot, North Dakota, United States
    Age
    44
    Posts
    1,539
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    495 Post(s)

    Re: I bet you cant figure this one out!!!

    Well, it not being mounted is more than likely the reason your killing the amps. It doesn't take much to take out the inputs. A slight bump against something, etc. My recommndation is to not use velcro and try and find a way to use screws to attach it to something solid.



    I lost my father in 2014. My Avatar is in his memory

    2014 Ford Explorer XLT
    Factory Head-Unit integrated by Monster FX100
    SAZ1500v3 running at 2 ohm
    Exonic EXS10x in Starr Mountain Sound Enclosure

  14. #13
    treiber67's Avatar
    treiber67 is offline Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    ft.lauderdale fl
    Posts
    127
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    21 Post(s)

    Re: I bet you cant figure this one out!!!

    is it cool to just drill it right into the trunk? or is that a no no?




  15. #14
    AnthonyO's Avatar
    AnthonyO is offline StarrMountainSoundNutHugr



    Join Date
    Oct 2005
    Location
    Minot, North Dakota, United States
    Age
    44
    Posts
    1,539
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    495 Post(s)

    Re: I bet you cant figure this one out!!!

    Quote Originally Posted by treiber67 View Post
    is it cool to just drill it right into the trunk? or is that a no no?
    As long as you check and can see that there is nothing right below where you are drilling. I have see many times where people drill right into their gas tanks.



    I lost my father in 2014. My Avatar is in his memory

    2014 Ford Explorer XLT
    Factory Head-Unit integrated by Monster FX100
    SAZ1500v3 running at 2 ohm
    Exonic EXS10x in Starr Mountain Sound Enclosure

  16. #15
    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,733
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1108 Post(s)

    Re: I bet you cant figure this one out!!!

    Quote Originally Posted by VWGolfMKVI View Post
    As long as you check and can see that there is nothing right below where you are drilling. I have see many times where people drill right into their gas tanks.
    Yeah I drilled right into a fuel pump my first time installing and it was costly and could've been deadly



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)

    Quote Originally Posted by BassAndBeer View Post
    sorry man but ford will always be a ford. ford is the sony xplod of cars and trucks. you had bad experiences with chevy because your a ford guy. its what seperates the men from the boys. friend billy use to drive a ford. he drives a chevy now. they call him billy no more. hes known as bill now..

Closed Thread

Similar Threads

  1. Hmm Let's figure this one out
    By the727kid in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 11-19-2007, 09:18 PM
  2. cant figure this one out
    By jcgtpafl in forum General Discussion
    Replies: 6
    Last Post: 08-16-2007, 09:33 PM
  3. Contest: Just Try to Figure This One Out...
    By Mattman00969 in forum Wiring, Electrical and Installation Help
    Replies: 30
    Last Post: 07-19-2003, 03:52 PM
  4. Cant figure this one out ??
    By sacarap in forum General Discussion
    Replies: 2
    Last Post: 12-20-2001, 11:45 AM

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum