Closed Thread
Results 1 to 9 of 9

Reload Thread: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

  1. #1
    OgStickeyBuds1's Avatar
    OgStickeyBuds1 is offline Junior Member



    Join Date
    Dec 2012
    Location
    Cleveland,Oh
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    Idk why but everyone I turn my head unit up the fuse blows.







  2. #2
    05fronty's Avatar
    05fronty is offline SALT PETER



    Join Date
    Nov 2006
    Location
    conway,ar
    Age
    40
    Posts
    11,341
    Post Thanks / Like
    Mentioned
    53 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    interesting



    bought from ridinhi,vitveet,dbr,sicaudio and 99grandprixgt, and more ........... sold to player3,foomasta69, pitbull, brodiesel and dragnix 12887 traded with louisiana crx

    "noobs that come in the dome will get gang raped!"
    nothing but a stock fosgate system with gps and back up camera lol
    2012 nissan sentra spec v with some goodies cumming though

  3. Likes NoPh33rRaCiNg liked this post
  4. #3
    >>SQL<<'s Avatar
    >>SQL<< is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    USA
    Posts
    1,457
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    bad ground, too small power and/or ground wire, improper ohm load on amp, improper gain settings.




  5. #4
    05fronty's Avatar
    05fronty is offline SALT PETER



    Join Date
    Nov 2006
    Location
    conway,ar
    Age
    40
    Posts
    11,341
    Post Thanks / Like
    Mentioned
    53 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    kenwood/



    bought from ridinhi,vitveet,dbr,sicaudio and 99grandprixgt, and more ........... sold to player3,foomasta69, pitbull, brodiesel and dragnix 12887 traded with louisiana crx

    "noobs that come in the dome will get gang raped!"
    nothing but a stock fosgate system with gps and back up camera lol
    2012 nissan sentra spec v with some goodies cumming though

  6. Likes ZDudas liked this post
  7. #5
    Falcons's Avatar
    Falcons is offline that **** i dont like



    Join Date
    Jan 2011
    Location
    Albion, New York, United States
    Posts
    5,224
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    Dude you installed it wrong. That's why.



    Things to look forward to:
    (2) 10" or 12" imperium audio designs subs
    set of PHD MF 6.5" comps
    Completely seal off and deaden my doors
    aquire a 2k amp
    aquire a 2 channel amp for front stage

  8. #6
    OgStickeyBuds1's Avatar
    OgStickeyBuds1 is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    Cleveland,Oh
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    It didn't do that before. I use to be able to turn up all the way. It just recently started doing that.




  9. #7
    Falcons's Avatar
    Falcons is offline that **** i dont like



    Join Date
    Jan 2011
    Location
    Albion, New York, United States
    Posts
    5,224
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    Give us the 411 on the install



    Things to look forward to:
    (2) 10" or 12" imperium audio designs subs
    set of PHD MF 6.5" comps
    Completely seal off and deaden my doors
    aquire a 2k amp
    aquire a 2 channel amp for front stage

  10. #8
    robertoyoung08's Avatar
    robertoyoung08 is offline CarAudio.com Elite



    Join Date
    Aug 2009
    Location
    bay area, ca
    Posts
    1,203
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    if you havnt changed any settings or anything. then check the wiring. maybe ground got lose.



    2005 Lexus GS300
    -DC Power XP 270 H/O Alternator, Big 3, Kinetik HC2400, XS D680 in trunk
    -Stock NAV unit w/ RF 3sixty.3
    -JL HD 1200/1
    -JL HD 600/4
    -Hybrid Audio Clarus front stage; Diamond D6 rear fill
    -2x 10" Ascendant Audio Chaos in 4th order.

  11. #9
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,106
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Help!! My 1000 watt Kenwood amp keeps blowing the 40a fuse.

    Something changed. You need to find out what. Probably the wiring, look for a short somewhere.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

Closed Thread

Similar Threads

  1. My Sub amp keeps blowing fuses???
    By LowRydr in forum General Discussion
    Replies: 3
    Last Post: 03-05-2004, 02:07 PM
  2. My Sub amp keeps blowing Fuses???
    By LowRydr in forum Subwoofers
    Replies: 5
    Last Post: 03-05-2004, 01:49 PM
  3. Replies: 5
    Last Post: 12-19-2003, 04:04 PM
  4. My head unit works but keeps blowing fuses, i need help
    By bigjon16 in forum General Discussion
    Replies: 2
    Last Post: 02-10-2002, 11:54 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum