Closed Thread
Results 1 to 14 of 14

Reload Thread: Amp cutting out

  1. #1
    Join Date
    Nov 2012
    Location
    Fort lauderdale, Fl
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    42 Post(s)

    Icon8 Amp cutting out

    I installed my new 6x9's today and when I play them loud for a short time it cuts out, I played it loud and felt the amp and it's not warm at all, so I don't think it's overheating. The way I have it setup for now is a pair of rca's coming from my head unit going in the in to my subwoofer amp then out the output for the rca's into my amp powering my 6x9's temporary also i'm using a 4 channel infinity kappa four amp to power them, i have both the 6x9's wired to the rear channel. The grounds good no noise or anything and connections are all secure. Does anyone have any idea what it could be?







  2. #2
    Callingindogs's Avatar
    Callingindogs is offline Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    Fort lauderdale, Fl
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    42 Post(s)

    Re: Amp cutting out

    bump




  3. #3
    jungstah's Avatar
    jungstah is offline Senior VIP Member



    Join Date
    May 2012
    Location
    san francisco
    Posts
    278
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    78 Post(s)

    Re: Amp cutting out

    just plug the rca's directly into your kappa four and check if some sht is messed up in the rca out on sub amp



    Pioneer AVH-P2400BT
    Stock Pioneer 4" components
    Hifonics Brutus BRZ1700.1D
    Two SA-12's
    cruddy prefab ported box----new box otw

  4. #4
    garretttt4's Avatar
    garretttt4 is offline big pimpin



    Join Date
    Aug 2012
    Location
    Watertown sd
    Posts
    2,395
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1015 Post(s)

    Re: Amp cutting out

    Quote Originally Posted by Callingindogs View Post
    I installed my new 6x9's today and when I play them loud for a short time it cuts out, I played it loud and felt the amp and it's not warm at all, so I don't think it's overheating. The way I have it setup for now is a pair of rca's coming from my head unit going in the in to my subwoofer amp then out the output for the rca's into my amp powering my 6x9's temporary also i'm using a 4 channel infinity kappa four amp to power them, i have both the 6x9's wired to the rear channel. The grounds good no noise or anything and connections are all secure. Does anyone have any idea what it could be?


    My sub amp did the same thing. I used a dmm to see if my amp was putting out constant voltage. (So try that first). Mine was. So I went and replaced the speaker wire and put in new terminals and its been working for me so far. So I'd try that.....



    01 Silverado 2500hd (gasser. :/)
    Four custom mmats juggernaut 12's. (For sale, or trade for guy stuff or a 2k amp + cash.)
    Amp undecided..?


    Bought from: Jayzbent, mylows10, logan527, Timmy13091, wingsfreak9, Underfire
    Traded with: mylows10(x2), knowmadic
    Sold to: 03silverado03, foomanchu, heel4lyfe, Timmy13091, wErd

  5. #5
    Callingindogs's Avatar
    Callingindogs is offline Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    Fort lauderdale, Fl
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    42 Post(s)

    Re: Amp cutting out

    I've been thinking its the connecters on ye speaker wire, I forgot to get connecters so I used some old aluminum my dad had, I'm going out to get cold covered ones today, if the problem still persists what could it be? The RCA outputs are fine because it only cuts out of I play the music loud.
    Quote Originally Posted by garretttt4 View Post
    My sub amp did the same thing. I used a dmm to see if my amp was putting out constant voltage. (So try that first). Mine was. So I went and replaced the speaker wire and put in new terminals and its been working for me so far. So I'd try that.....




  6. #6
    garretttt4's Avatar
    garretttt4 is offline big pimpin



    Join Date
    Aug 2012
    Location
    Watertown sd
    Posts
    2,395
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1015 Post(s)

    Re: Amp cutting out

    Quote Originally Posted by Callingindogs View Post
    I've been thinking its the connecters on ye speaker wire, I forgot to get connecters so I used some old aluminum my dad had, I'm going out to get cold covered ones today, if the problem still persists what could it be? The RCA outputs are fine because it only cuts out of I play the music loud.
    it could be a short in your wire.....



    01 Silverado 2500hd (gasser. :/)
    Four custom mmats juggernaut 12's. (For sale, or trade for guy stuff or a 2k amp + cash.)
    Amp undecided..?


    Bought from: Jayzbent, mylows10, logan527, Timmy13091, wingsfreak9, Underfire
    Traded with: mylows10(x2), knowmadic
    Sold to: 03silverado03, foomanchu, heel4lyfe, Timmy13091, wErd

  7. #7
    TreyE's Avatar
    TreyE is offline Lets Get Weird



    Join Date
    Apr 2006
    Location
    Tampa
    Age
    25
    Posts
    3,724
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    143 Post(s)

    Re: Amp cutting out

    Run the RCA's from your head unit.



    Don't listen to me.

    Feedback - http://www.caraudio.com/forums/buyer-seller-feedback/227670-treye.html
    Also more recent feedback on caco.com under same username and eBay as Willy8788 100% feedback.

  8. #8
    frogcase2002's Avatar
    frogcase2002 is offline CarAudio.com Elite



    Join Date
    Dec 2011
    Location
    hamilton, ohio
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    100 Post(s)

    Re: Amp cutting out

    How are your speakers wired and how is the gain set?




  9. #9
    alec14's Avatar
    alec14 is offline CarAudio.com Elite



    Join Date
    Aug 2012
    Location
    Sault Ste. Marie, MI
    Posts
    1,755
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    650 Post(s)

    Re: Amp cutting out

    Quote Originally Posted by TreyE View Post
    Run the RCA's from your head unit.
    Definitely try this. May help your problem. Is your headunit used? It may just be glitching.



    Bought from: flastrongman, nitefury 360, luckyderder, Jayzbent, fasfocus00, flaboy22, oldschool4me, Chevy Blazin', Inter007, dross93ranger, 04murdalanche, glitchsta, photocrazy8, 2002XLT

    Traded with: mylows10 Sold to/traded with: garychoffman, juanmgarza, 04murdalanche, Markyg66, basswiigee, btolenti, supereikenator, shauncox26, eg9(x2), big scott, bad @SS chevy

    http://www.caraudio.com/forums/itrader.php?u=1018999

  10. #10
    TreyE's Avatar
    TreyE is offline Lets Get Weird



    Join Date
    Apr 2006
    Location
    Tampa
    Age
    25
    Posts
    3,724
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    143 Post(s)

    Re: Amp cutting out

    I used to have a REALLY crappy HU in my truck back in HS temporarily while I was waiting for my new one to come in. Whenever I would turn it up really loud it would cut out everything. Try turning gains up and not turning HU up so high volume wise.



    Don't listen to me.

    Feedback - http://www.caraudio.com/forums/buyer-seller-feedback/227670-treye.html
    Also more recent feedback on caco.com under same username and eBay as Willy8788 100% feedback.

  11. #11
    Callingindogs's Avatar
    Callingindogs is offline Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    Fort lauderdale, Fl
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    42 Post(s)

    Re: Amp cutting out

    I have a stock headunit so I'm using clamps to tamp the wire to a RCA converter. The subwoofer doesn't cut out, only the 6x9's
    Quote Originally Posted by TreyE View Post
    I used to have a REALLY crappy HU in my truck back in HS temporarily while I was waiting for my new one to come in. Whenever I would turn it up really loud it would cut out everything. Try turning gains up and not turning HU up so high volume wise.




  12. #12
    TreyE's Avatar
    TreyE is offline Lets Get Weird



    Join Date
    Apr 2006
    Location
    Tampa
    Age
    25
    Posts
    3,724
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    143 Post(s)

    Re: Amp cutting out

    Quote Originally Posted by Callingindogs View Post
    I have a stock headunit so I'm using clamps to tamp the wire to a RCA converter. The subwoofer doesn't cut out, only the 6x9's
    Oh. Well yea thats probably the problem. My GUESS is that the RCA's dont have enough power to push a signal to both amplifiers. Im not expert on LOC's or anything though, could be wrong.



    Don't listen to me.

    Feedback - http://www.caraudio.com/forums/buyer-seller-feedback/227670-treye.html
    Also more recent feedback on caco.com under same username and eBay as Willy8788 100% feedback.

  13. #13
    Callingindogs's Avatar
    Callingindogs is offline Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    Fort lauderdale, Fl
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    42 Post(s)

    Re: Amp cutting out

    My friend has the same setup and it had no problems, I'm going to try and ground it better tonight and add the gold tipped connecters and see how it is, if it still occurs then I'll just deal with it till I have the money for a new headunit and everything
    Quote Originally Posted by TreyE View Post
    Oh. Well yea thats probably the problem. My GUESS is that the RCA's dont have enough power to push a signal to both amplifiers. Im not expert on LOC's or anything though, could be wrong.




  14. #14
    Callingindogs's Avatar
    Callingindogs is offline Member

    Threadstarter


    Join Date
    Nov 2012
    Location
    Fort lauderdale, Fl
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    42 Post(s)

    Re: Amp cutting out

    I just replaced the speaker connectors and it didn't cut out once after playing music at almost max for 10 minutes, before it would have several times.
    Quote Originally Posted by TreyE View Post
    Oh. Well yea thats probably the problem. My GUESS is that the RCA's dont have enough power to push a signal to both amplifiers. Im not expert on LOC's or anything though, could be wrong.




Closed Thread

Similar Threads

  1. Out of ideas: Sony amp cutting out.
    By cizbryan in forum Amplifiers
    Replies: 3
    Last Post: 04-19-2003, 10:24 PM
  2. Amp Cuts Out
    By DVS1 in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 02-09-2003, 03:11 AM
  3. Why is this amp cutting out??
    By RcRacerDrew in forum Amplifiers
    Replies: 13
    Last Post: 08-07-2002, 12:05 AM
  4. Infinity amp cuts out
    By EarDrummin. in forum Amplifiers
    Replies: 17
    Last Post: 07-02-2002, 02:48 PM
  5. amp cuts out
    By Eddie_Bauaer in forum Amplifiers
    Replies: 4
    Last Post: 01-22-2002, 09:11 AM

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum