Closed Thread
Results 1 to 8 of 8

Reload Thread: Not enough power to the amp???

  1. #1
    nrlewellen's Avatar
    nrlewellen is offline Junior Member



    Join Date
    Dec 2012
    Location
    Dayton Ohio
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Not enough power to the amp???

    Hey guys, first time post for me here.
    I have had a system in my vehicle for awhile, I was using a Kenwood KAC-7252 (old i know, I have had it for about 12 years i think?) and i WAS running two MTX 12's on it and everything was running and sounding good. I have 4 gauge wire for the power and ground. I just got a pair of kicker comp 15s off of a friend. When I try to run them ill get a half-assed sound and all the lights will dim, including the amp light, then nothing happens for a couple of seconds, and then it will do the same thing again. What could be going on here?







  2. #2
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,116
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Not enough power to the amp???

    What is the resistances of them, each coil? How do you have it wired? Could be trying to wire to too low of a resistance for the amp.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

  3. #3
    cfox10's Avatar
    cfox10 is offline Rock the house.



    Join Date
    Mar 2011
    Location
    Albany, Oregon
    Posts
    1,242
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Not enough power to the amp???

    What kind of car? Amp? Final impedence at amp?




  4. #4
    nrlewellen's Avatar
    nrlewellen is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    Dayton Ohio
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Not enough power to the amp???

    Subwoofer Size 15" Peak Power Handling 500 watts RMS Power Handling 250 watts Voice Coil(s) Single Impedance (Per Voice Coil) 4 ohms Frequency Response 25 - 500 Hz Sensitivity 90.2 dB Xmax (millimeters) 9.76 mm. This is What I pulled off the website about the subs that I am running.




  5. #5
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,116
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Not enough power to the amp???

    Is this your amp?
    Kenwood KAC-7252 (kac7252) 1000 watts, 2-Channel Amplifier with

    If so, are you running it bridged? You should run those subs each wired to 2 ohms, each one going to a channel, with the amp in 2 channel operation. Or, you could wire each sub up to 8ohms, then wire them together to 4ohms, to run a single pair of wires to the amp in bridged operation.

    Reason for this is that in bridged mode, minimum impedance is 4ohms. How do you have those subs wired? If you have them wired to 1ohm, that is why it's going ino protect.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

  6. #6
    nrlewellen's Avatar
    nrlewellen is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    Dayton Ohio
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Not enough power to the amp???

    Yes that is the amp. By wiring the sub to specific ohms are you meaning how the subs are wired inside the box?? I tried bridging them and then ruthmg them on their own channel.




  7. #7
    gckless's Avatar
    gckless is offline CarAudio.com Veteran



    Join Date
    Aug 2011
    Location
    San Antonio
    Posts
    4,116
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Not enough power to the amp???

    Yes that's what I mean. How are they wired together? Pics may help.



    Quote Originally Posted by ducatipaso View Post
    15inch subs can't play fast beats, they take more power and that taxes the vehicles electrical system. You will wake up and "hear" then see the light at the end of the tunnel and it will be 3 10's pounding so hard you wont even open your trunk or turn your system on because you 15's will sound sloppy & weak.
    Quote Originally Posted by benbenondatrack View Post
    stfu lesbo.why are you worried about me so much? you must want to date me ya little cookie monster but i dont even like sweets. your just a cup full of ice, dirt dead nasty azz ice...without the water.

    Dat Build Log: http://mobileaudioforum.com/forum/showthread.php?2566-1999-Chevrolet-Blazer&highlight=1999+blazer

  8. #8
    nrlewellen's Avatar
    nrlewellen is offline Junior Member

    Threadstarter


    Join Date
    Dec 2012
    Location
    Dayton Ohio
    Posts
    4
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Not enough power to the amp???

    I will have to look when I get home, and it will probably be the morning before I am able to get any pictures of them.




Closed Thread

Similar Threads

  1. Not enough power to my Mono Amp!!
    By lionel2 in forum Amplifiers
    Replies: 6
    Last Post: 06-20-2006, 08:39 AM
  2. not enough power to amp
    By HYmanDR0ne in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 02-25-2004, 08:48 AM
  3. enough power in the amp?
    By fazes in forum Subwoofers
    Replies: 6
    Last Post: 12-27-2003, 02:08 AM
  4. I have Power to the amp but not to the subs
    By Line in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 12-21-2003, 12:27 AM
  5. not enough power to a sub?
    By greenchaos in forum Subwoofers
    Replies: 3
    Last Post: 01-23-2003, 08:29 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum