Closed Thread
Results 1 to 4 of 4

Reload Thread: Tweeter Problems

  1. #1
    deedee85's Avatar
    deedee85 is offline Junior Member



    Join Date
    Oct 2012
    Location
    UK
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Tweeter Problems

    Hey all, didn't know where else to come for help. but this place looked good so I'll give it a shot.

    The problem I'm having is both my tweeters have stopped working at the same time. The mids are fine through the crossover, however the tweeters were intermittently cutting out and then both finally died. They're being ran from a Fli459 and are a set of T1-625 components. Cheap speakers I know, but the price to sound quality is pretty good.

    Any advice you could give me would be greatly appreciated. Thanks in advance







  2. #2
    NoLoud4U's Avatar
    NoLoud4U is online now High Output SQ



    Join Date
    Apr 2011
    Location
    Va Beach, Va
    Age
    34
    Posts
    8,656
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2816 Post(s)

    Re: Tweeter Problems

    To much powa



    2014 Ford Fusion
    All stock everything.

  3. #3
    knightsdaze's Avatar
    knightsdaze is offline Member



    Join Date
    Dec 2010
    Location
    south shore, ma
    Posts
    148
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Tweeter Problems

    This^^^^^^^



    Electrical- 200amp alt- Optima yellow tops front+back- stinger 10 farad cap- cadence 1/0awg+stinger+knu fuses
    Head unit- Pioneer 9400bh
    EQ- Audiocontrol Four.1
    Active x/over- Audiocontrol 6xs
    Front stage-B.A pro 50se (in sealed centrapod)
    Soundbar- Jbl p652 (NOT for long)
    Midbass- Jl cw800 (in sealed intrapod)
    Subs- 1 RExxx 12 in cust tuned 33hz box@1ohm (thank u Mobile Enclosures)
    Amps- Sub-Orion hcca 2500.1/ Midbass-Alpine pdx 2.150/Components- Alpine pdx 4.150

  4. #4
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    6,052
    Post Thanks / Like
    Images
    28
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1161 Post(s)

    Re: Tweeter Problems

    Could have blown the crossover capacitors. Measure tweeter coil resistance with a DMM.



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/608637-2014-accord-sport-sq-build-keep_hope_alive.html
    ***My YouTube Channel https://www.youtube.com/channel/UCkYUo2EShW9lgtrfXiDvLNQ/videos
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html

Closed Thread

Similar Threads

  1. Tweeter Problem
    By Alpineforever in forum Speakers
    Replies: 2
    Last Post: 07-29-2008, 02:50 PM
  2. Tweeter problem.
    By the727kid in forum Speakers
    Replies: 15
    Last Post: 12-18-2006, 06:43 PM
  3. 98 integra tweeter problem
    By almo181 in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 09-22-2006, 06:52 PM
  4. Tweeters problem....
    By gramus_666 in forum Speakers
    Replies: 19
    Last Post: 08-31-2006, 03:17 AM
  5. Installed system but tweeter problem
    By canadian_mofo in forum Wiring, Electrical and Installation Help
    Replies: 27
    Last Post: 02-17-2006, 01:24 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum