Closed Thread
Results 1 to 4 of 4

Reload Thread: Tweeter Problems

  1. #1
    deedee85's Avatar
    deedee85 is offline Junior Member



    Join Date
    Oct 2012
    Location
    UK
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Tweeter Problems

    Hey all, didn't know where else to come for help. but this place looked good so I'll give it a shot.

    The problem I'm having is both my tweeters have stopped working at the same time. The mids are fine through the crossover, however the tweeters were intermittently cutting out and then both finally died. They're being ran from a Fli459 and are a set of T1-625 components. Cheap speakers I know, but the price to sound quality is pretty good.

    Any advice you could give me would be greatly appreciated. Thanks in advance







  2. #2
    LosIsATool's Avatar
    LosIsATool is offline DD subs are the best!



    Join Date
    Apr 2011
    Location
    Pensacola, Florida
    Age
    36
    Posts
    14,973
    Post Thanks / Like
    Mentioned
    70 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5908 Post(s)

    Re: Tweeter Problems

    To much powa



    Fuck you papermaker

    2014 Ford Fusion SE 2.0T
    JBL MS-8
    DD M1c, DD SS4A
    DD SW2508sc
    Hertz HT28
    Hertz HV165XL
    Knuconceptz OFC, Custom fit Soundrive RCAs.
    Batcap

  3. #3
    knightsdaze's Avatar
    knightsdaze is offline Member



    Join Date
    Dec 2010
    Location
    south shore, ma
    Posts
    148
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    51 Post(s)

    Re: Tweeter Problems

    This^^^^^^^



    Electrical- 200amp alt- Optima yellow tops front+back- stinger 10 farad cap- cadence 1/0awg+stinger+knu fuses
    Head unit- Pioneer 9400bh
    EQ- Audiocontrol Four.1
    Active x/over- Audiocontrol 6xs
    Front stage-B.A pro 50se (in sealed centrapod)
    Soundbar- Jbl p652 (NOT for long)
    Midbass- Jl cw800 (in sealed intrapod)
    Subs- 1 RExxx 12 in cust tuned 33hz [email protected] (thank u Mobile Enclosures)
    Amps- Sub-Orion hcca 2500.1/ Midbass-Alpine pdx 2.150/Components- Alpine pdx 4.150

  4. #4
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    6,970
    Post Thanks / Like
    Images
    28
    Mentioned
    42 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1460 Post(s)

    Re: Tweeter Problems

    Could have blown the crossover capacitors. Measure tweeter coil resistance with a DMM.



    have you been helped by me? i'd love to know. got a question? shoot me a PM.
    Matthew 6:9-15 https://www.biblegateway.com/passage/?search=Matthew+6%3A9-15&version=NIV

    --My YouTube Channel: https://www.youtube.com/channel/UCkYUo2EShW9lgtrfXiDvLNQ/videos
    --My 2014 Accord build log: http://mobileaudioforum.com/forum/showthread.php?6722-KHA-2014-Accord-Sport-SQ-Factory-Integration
    --My 2001 Accord build log: http://mobileaudioforum.com/forum/showthread.php?505-KHA-2001-Accord-EX-V6-Build-Log

Closed Thread

Similar Threads

  1. Tweeter Problem
    By Alpineforever in forum Speakers
    Replies: 2
    Last Post: 07-29-2008, 01:50 PM
  2. Tweeter problem.
    By the727kid in forum Speakers
    Replies: 15
    Last Post: 12-18-2006, 05:43 PM
  3. 98 integra tweeter problem
    By almo181 in forum Wiring, Electrical and Installation Help
    Replies: 7
    Last Post: 09-22-2006, 05:52 PM
  4. Tweeters problem....
    By gramus_666 in forum Speakers
    Replies: 19
    Last Post: 08-31-2006, 02:17 AM
  5. Installed system but tweeter problem
    By canadian_mofo in forum Wiring, Electrical and Installation Help
    Replies: 27
    Last Post: 02-17-2006, 12:24 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum