Closed Thread
Results 1 to 7 of 7

Reload Thread: amp keeps going into protect mode when the volume is turned u_

  1. #1
    meko1's Avatar
    meko1 is offline Junior Member



    Join Date
    Sep 2012
    Location
    genoa ohio
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    amp keeps going into protect mode when the volume is turned u_

    The past two days I have completely rewired everthing. New ground . New power. New rca jacks and new remote. Still keeps going into protect. So then I took speakers out of box and rewired those to four ohms(where my amp is stable at. Again went into protect mode when I turned it up. Then I tried turning the gain all the way down. It will stay powered on but when I try to adjust it. It just goes back into protect mode. Any ideas ?







  2. #2
    mclerico83's Avatar
    mclerico83 is online now CarAudio.com Veteran



    Join Date
    Oct 2009
    Location
    tampa
    Posts
    6,781
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: amp keeps going into protect mode when the volume is turned u_

    check your voltages at the amp while playing and when playing loud. if everything is good, i would say you have a blown power supply on your amp




  3. #3
    stevew007's Avatar
    stevew007 is offline CarAudio.com Veteran



    Join Date
    Aug 2006
    Location
    west sacramento
    Posts
    2,460
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: amp keeps going into protect mode when the volume is turned u_

    what amp is it? where was it mounted? have you checked the coils?



    REF'S 96maxgle, LcKmyblls, djman37, nomad40, el_chupo_ , jep772, got focus?, platestacker45, randyrsx, duece212,DB_DRAG_SPL, ProjectPechkin

    http://www.myspace.com/colorado_basswarz

  4. #4
    meko1's Avatar
    meko1 is offline Junior Member

    Threadstarter


    Join Date
    Sep 2012
    Location
    genoa ohio
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp keeps going into protect mode when the volume is turned u_

    It is a legacy rebel 1600 watt. Its mounted to the trunk, and coils?




  5. #5
    stevew007's Avatar
    stevew007 is offline CarAudio.com Veteran



    Join Date
    Aug 2006
    Location
    west sacramento
    Posts
    2,460
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: amp keeps going into protect mode when the volume is turned u_

    yeah the coil of the speaker or sub you are running. the amp sounds like a throw away to me sorry.



    REF'S 96maxgle, LcKmyblls, djman37, nomad40, el_chupo_ , jep772, got focus?, platestacker45, randyrsx, duece212,DB_DRAG_SPL, ProjectPechkin

    http://www.myspace.com/colorado_basswarz

  6. #6
    meko1's Avatar
    meko1 is offline Junior Member

    Threadstarter


    Join Date
    Sep 2012
    Location
    genoa ohio
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: amp keeps going into protect mode when the volume is turned u_

    Ohh yeah the coils are fine the subs are brand new. Yeah I'm just going to hook up an old amp in the garage and see if I get anything




  7. #7
    stevew007's Avatar
    stevew007 is offline CarAudio.com Veteran



    Join Date
    Aug 2006
    Location
    west sacramento
    Posts
    2,460
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: amp keeps going into protect mode when the volume is turned u_

    Quote Originally Posted by meko1 View Post
    Ohh yeah the coils are fine the subs are brand new. Yeah I'm just going to hook up an old amp in the garage and see if I get anything
    sounds like an idea



    REF'S 96maxgle, LcKmyblls, djman37, nomad40, el_chupo_ , jep772, got focus?, platestacker45, randyrsx, duece212,DB_DRAG_SPL, ProjectPechkin

    http://www.myspace.com/colorado_basswarz

Closed Thread

Similar Threads

  1. kenwood amp keeps going into protection mode?
    By toledokid in forum Amplifiers
    Replies: 5
    Last Post: 07-19-2009, 03:02 AM
  2. Amp keeps going into protect mode
    By jeryll in forum Amplifiers
    Replies: 1
    Last Post: 02-17-2008, 03:01 PM
  3. amp keeps going into protect mode
    By MrSwiss in forum Amplifiers
    Replies: 15
    Last Post: 05-19-2005, 04:18 PM
  4. amp keeps going into protect
    By missionpilot in forum Amplifiers
    Replies: 5
    Last Post: 01-03-2004, 06:34 PM
  5. my amp keeps going into protection mode, wtf?
    By MakaveliThaDon in forum Amplifiers
    Replies: 14
    Last Post: 08-19-2003, 05:43 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum