Closed Thread
Results 1 to 3 of 3

Reload Thread: Bad Sound quality from my system, need some help.

  1. #1
    beemer740's Avatar
    beemer740 is offline Senior VIP Member



    Join Date
    Aug 2006
    Location
    Corona, Ca
    Posts
    337
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Bad Sound quality from my system, need some help.

    Hey guys, i just picked up an 06 chrysler 300 srt8. The previous owner left the factory nav head unit but had a shop replace the factory 6x9s in the front doors and rear deck with some rockford fosgate ones. Then they added two amps one 4 channel and one mono for the 2 12 rockford p2 in the trunk. They used an lc2i. The factory headunit settings are all at 0. and i have the gains on both rockford amps set at around 6/11. The lc2i's setting are also in the middle. The ouput isnt distorted but doesnt sound clear. Any help on what could be causing this? Thanks



    Chevy 2500hd 4x4 Duramax
    Headunit:Pioneer Avh-p4300dvd
    Speakers: Image Dynamics CTX65CS and Ctx6 Coaxials
    Amps: Sundown SAZ1500d & MB Quart Q4.150
    Subs: 2 Image Dynamic ID10's


    REFS:Californiaboy5




  2. #2
    West's Avatar
    West is offline Banned



    Join Date
    Jan 2012
    Location
    Oliver Springs, TN
    Posts
    3,703
    Post Thanks / Like
    Mentioned
    73 Post(s)

    Re: Bad Sound quality from my system, need some help.

    Replace the head unit with a good one.




  3. #3
    West's Avatar
    West is offline Banned



    Join Date
    Jan 2012
    Location
    Oliver Springs, TN
    Posts
    3,703
    Post Thanks / Like
    Mentioned
    73 Post(s)

    Re: Bad Sound quality from my system, need some help.

    I also don't like rockford fosgate at all they could be the issue. Have you tried different gain settings?




Closed Thread

Similar Threads

  1. Replies: 2
    Last Post: 01-05-2012, 07:07 PM
  2. So-So Sound quality from my new Pioneer P780MP
    By ty1er in forum Head Units
    Replies: 28
    Last Post: 06-23-2006, 07:45 PM
  3. Installing a new system in my blazer, need some help
    By Beermanpb14 in forum General Discussion
    Replies: 6
    Last Post: 04-13-2006, 11:11 AM
  4. best sound quality for my system?
    By punkdcrew in forum Wiring, Electrical and Installation Help
    Replies: 8
    Last Post: 02-01-2006, 11:20 AM
  5. building my system need some help
    By wretchedhunger in forum General Discussion
    Replies: 3
    Last Post: 02-01-2006, 12:31 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum