Closed Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 16 to 30 of 36

Reload Thread: I immediately blew my new subs.

  1. #16
    therockdrummer's Avatar
    therockdrummer is offline Junior Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Scottsdale, AZ
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I immediately blew my new subs.

    Quote Originally Posted by xSPLoder808 View Post
    explain in detail how you wired up each sub
    Put the jumper in the middle +/- posts. in each sub. Wired the set of outside +/- to the terminal inside the box. Connect one terminal to the other behind box. Run one set to the mono amp. Same setup as the D4's, just now a 2ohm load.







  2. #17
    skylineTT's Avatar
    skylineTT is offline bass=sekz



    Join Date
    Jun 2007
    Location
    Dallas/Raiderland
    Posts
    4,094
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: I immediately blew my new subs.

    Quote Originally Posted by SourDeez View Post
    You must have accidently wired it to half ohm, because theres no way that two type R's will immediately blow off 1200rms and minimum gain. I had two type R's on 2400rms+ for like 2 years
    You don't got to lie craig!!



    Refs: Dipitydoo, appollyon, bad95gt, revrider1, jwh1598, ampjunkielikeme, deathpenalty18, ssackett, snoopysnooper, corey0928, SPLAudio, Clifff150, CL1CKCLACK, ShawnT, West + more

  3. #18
    skylineTT's Avatar
    skylineTT is offline bass=sekz



    Join Date
    Jun 2007
    Location
    Dallas/Raiderland
    Posts
    4,094
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: I immediately blew my new subs.

    Quote Originally Posted by therockdrummer View Post
    Put the jumper in the middle +/- posts. in each sub. Wired the set of outside +/- to the terminal inside the box. Connect one terminal to the other behind box. Run one set to the mono amp. Same setup as the D4's, just now a 2ohm load.
    yeah, that sounds correct, unless you just accidentally reversed the polarity at the box terminal. are you absolutely sure they are blown?



    Refs: Dipitydoo, appollyon, bad95gt, revrider1, jwh1598, ampjunkielikeme, deathpenalty18, ssackett, snoopysnooper, corey0928, SPLAudio, Clifff150, CL1CKCLACK, ShawnT, West + more

  4. #19
    Join Date
    May 2012
    Location
    The Roc, NY
    Posts
    1,303
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: I immediately blew my new subs.

    stick a 9v battery to the VC's. It wont hurt it. Put the + of the battery to the + VC and vice versa with the -. If the sub is blown it won't move. If it is still good, it will push the cone up and hold there till you take the battery off.



    BOYCOTT SKAR AUDIO!
    2012 TNESPL R2 WORLD CHAMPION
    TNESPL R2 ALL TIME RANKINGS RECORD HOLDER


    TEAM

    TEAM LOUD INTENTIONS
    www.youtube.com/TeamLoudIntentions

  5. #20
    SourDeez's Avatar
    SourDeez is offline CarAudio.com Veteran



    Join Date
    Apr 2007
    Location
    Fuqy u
    Posts
    4,128
    Post Thanks / Like
    Mentioned
    64 Post(s)

    Re: I immediately blew my new subs.

    Quote Originally Posted by skylineTT View Post
    You don't got to lie craig!!
    who da fuq is craig. i'm old greg



    Headunit - Stock cassette player - Pioneer P9400
    Front Stage - Pyle 8 inch subs (1000 watt peak!!) - Polk DB6.5 (about to be CDT 6.5s)
    Rear stage - Deleted (stolen) - Deleted
    Sub stage - custom built 15 inch sony xplod (5k watt peak!!!) (huge box) - Two SA12's built by Corey
    Sub amp - Pyle 8000w peak!! (spl edition) - AQ2200
    Electircal - 35 amp alt from ford festiva upgrade, stolen battery, 28 gauge solder coil for my cable - Dual D34 Yellows, 1/0 trystar OFC, 135amp alt

  6. #21
    therockdrummer's Avatar
    therockdrummer is offline Junior Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Scottsdale, AZ
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I immediately blew my new subs.

    both times, the cones stayed fully extended, and smoke came out of the vents. I assumed that meant they are blown.

    I just put a battery to them and they do jump and thud a small amount. What does this mean?




  7. #22
    Join Date
    May 2012
    Location
    The Roc, NY
    Posts
    1,303
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: I immediately blew my new subs.

    That means they are still good like I said before.



    BOYCOTT SKAR AUDIO!
    2012 TNESPL R2 WORLD CHAMPION
    TNESPL R2 ALL TIME RANKINGS RECORD HOLDER


    TEAM

    TEAM LOUD INTENTIONS
    www.youtube.com/TeamLoudIntentions

  8. #23
    Join Date
    Jul 2012
    Location
    San Diego, CA
    Age
    23
    Posts
    70
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I immediately blew my new subs.

    You paid $700 to 2 pairs of mediocre subs?! Holy crap.... and you spent over a grand on that set-up? That was your first problem.
    Secondly, it doesn't quite sound like you know what you're doing, so who knows what the issue could be. Amp could be bad sending DC current to the sub. Subs could be wired wrong. Gain set wrong. Bass boost and loudness being used?

    Also, do like xsploder said and test the sub with a battery.



    Quote Originally Posted by Imtjnotu View Post
    I put AudioTechnix sound deadener on my 21" Kicker L7 and it puts out 10 more deebeez now!

  9. #24
    Join Date
    May 2012
    Location
    The Roc, NY
    Posts
    1,303
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: I immediately blew my new subs.

    If they were blown, they would not of even moved at all and would be stiff enough for you to stand on without moving pretty much.



    BOYCOTT SKAR AUDIO!
    2012 TNESPL R2 WORLD CHAMPION
    TNESPL R2 ALL TIME RANKINGS RECORD HOLDER


    TEAM

    TEAM LOUD INTENTIONS
    www.youtube.com/TeamLoudIntentions

  10. #25
    treesive's Avatar
    treesive is offline Senior VIP Member



    Join Date
    Mar 2011
    Location
    batesville, IN
    Posts
    335
    Post Thanks / Like
    Images
    7
    Mentioned
    1 Post(s)

    Re: I immediately blew my new subs.

    It is looking like when you fried the first set you may have fried something in the amp. Next time do some more research on how to properly set and connect everything before burning up some more of your cash.



    The Ride: 1996 Chevy Tahoe 4-Door
    The Setup: Headunit: Pioneer DEH-P80PRS
    Front Stage: Dynaudio 242's
    Rear Door: Dyn 162 gt's
    Subwoofers: TC 5400 18"
    Sub Amp: PG Elite.1
    High's Amps: PG Elite.4

  11. #26
    goingdef's Avatar
    goingdef is offline CarAudio.com Veteran



    Join Date
    Jan 2008
    Location
    Norfolk VA
    Age
    34
    Posts
    2,833
    Post Thanks / Like
    Mentioned
    11 Post(s)

    Re: I immediately blew my new subs.

    sounds like the amp is shot and unloading on the sub when it powers up, even if the subs still work there not worth crap now that they rolled smoke!




  12. #27
    Canaan's Avatar
    Canaan is offline Beatin' the block down



    Join Date
    Mar 2006
    Location
    Monroe, Louisiana
    Posts
    1,496
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: I immediately blew my new subs.

    If the subs fully extended and smoked....its likely your amp is damaged.

    Disconnect your subs from the amp and stick a DMM set to DC-voltage on the amps speaker terminals.

    If you are getting DC voltage, your amp is fried.



    Canaan White...'04 Avalanche
    HU Eclipse 7200MkII
    AMPS DD C4a(front active), 2 DD M2B
    SPEAKERS (Front) DD AT28, DD VO-M65
    SUBS...SOMETHING LOUD SOON!!?
    WIRES XSCORPION
    TEAM SOUTH

    Desiard Street Pawn and Car Audio, Monroe, La...XScorpion and DD Audio Dealer.
    Shop Phone 318-343-8283

  13. #28
    Join Date
    May 2012
    Location
    The Roc, NY
    Posts
    1,303
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: I immediately blew my new subs.

    wouldn't hurt to hook em up to a home audio receiver and free air test them for any coil damage. Might of got lucky and caught it quick enough to still run them



    BOYCOTT SKAR AUDIO!
    2012 TNESPL R2 WORLD CHAMPION
    TNESPL R2 ALL TIME RANKINGS RECORD HOLDER


    TEAM

    TEAM LOUD INTENTIONS
    www.youtube.com/TeamLoudIntentions

  14. #29
    therockdrummer's Avatar
    therockdrummer is offline Junior Member

    Threadstarter


    Join Date
    Jul 2012
    Location
    Scottsdale, AZ
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I immediately blew my new subs.

    Quote Originally Posted by I<3AudioTechnix View Post
    You paid $700 to 2 pairs of mediocre subs?! Holy crap.... and you spent over a grand on that set-up? That was your first problem.
    Secondly, it doesn't quite sound like you know what you're doing, so who knows what the issue could be. Amp could be bad sending DC current to the sub. Subs could be wired wrong. Gain set wrong. Bass boost and loudness being used?

    Also, do like xsploder said and test the sub with a battery.
    I think slightly over a grand was more than fair for the results I was seeking. Also, just because I acted like a teenager on the gain knob, doesn't mean I 'don't know what I'm doing'. There is no bass boost, no loudness. See above for the results of the battery test.

    Quote Originally Posted by xSPLoder808 View Post
    If they were blown, they would not of even moved at all and would be stiff enough for you to stand on without moving pretty much.
    We will see.

    Quote Originally Posted by treesive View Post
    It is looking like when you fried the first set you may have fried something in the amp. Next time do some more research on how to properly set and connect everything before burning up some more of your cash.
    I definitely will. I have ordered the SMD DD1, should be here on Friday. But until then, I need to make sure no more brand new subs explode upon plugging them in. What exactly could have been damaged in the amp? The PDX has a LED that is supposed to indicate any issues the amp is having, but it is lighting up blue as it should. ?

    Quote Originally Posted by goingdef View Post
    sounds like the amp is shot and unloading on the sub when it powers up, even if the subs still work there not worth crap now that they rolled smoke!
    explain!




  15. #30
    Join Date
    May 2012
    Location
    The Roc, NY
    Posts
    1,303
    Post Thanks / Like
    Mentioned
    6 Post(s)

    Re: I immediately blew my new subs.

    Quote Originally Posted by therockdrummer View Post
    I think slightly over a grand was more than fair for the results I was seeking. Also, just because I acted like a teenager on the gain knob, doesn't mean I 'don't know what I'm doing'. There is no bass boost, no loudness. See above for the results of the battery test.
    I dk, that's a pretty n00b move man. Not to mention spending over a G on Alpine stuff. No offense, just kinda n00bish



    BOYCOTT SKAR AUDIO!
    2012 TNESPL R2 WORLD CHAMPION
    TNESPL R2 ALL TIME RANKINGS RECORD HOLDER


    TEAM

    TEAM LOUD INTENTIONS
    www.youtube.com/TeamLoudIntentions

  16. Likes southernboom88, I<3AudioTechnix liked this post
Closed Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast

Similar Threads

  1. blew my sisters sub and need a new one
    By Wkbdkid in forum Subwoofers
    Replies: 5
    Last Post: 07-06-2006, 01:18 PM
  2. About my new subs
    By GTGchevy in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 10-02-2002, 08:35 PM
  3. Amp to pout my new sub
    By Corsica in forum Amplifiers
    Replies: 0
    Last Post: 06-23-2002, 01:22 AM
  4. Can't hear my new sub
    By maylar in forum Subwoofers
    Replies: 7
    Last Post: 03-12-2002, 01:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum