Closed Thread
Results 1 to 5 of 5

Reload Thread: Not sure what's causing new amp to not turn on.

  1. #1
    xxbindxx's Avatar
    xxbindxx is offline Junior Member



    Join Date
    Jul 2012
    Location
    Fresno
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Not sure what's causing new amp to not turn on.

    I had an amp hooked up to my subs with everything working just fine. Just got myself a new amp and simply transferred the wires from the old to the new one but for some reason the amp does not turn on. I took it out and put the old one back in and it works just fine. I also tested the new one in a friend's set up and amp worked tip top. Not sure what the problem could be. The old amp is an SSL Evolution EV2. 1000 and the new one is a Crunch PZi 1500.1.







  2. #2
    goingdef's Avatar
    goingdef is offline CarAudio.com Veteran



    Join Date
    Jan 2008
    Location
    Norfolk VA
    Age
    34
    Posts
    2,833
    Post Thanks / Like
    Mentioned
    11 Post(s)

    Re: Not sure what's causing new amp to not turn on.

    jump the turn on lead off the hot lead in. see if it works then, maybe your hu just doesn't have enough to turn on the amp? just guessing though?




  3. #3
    Jaguar's Avatar
    Jaguar is offline Senior VIP Member



    Join Date
    Jun 2012
    Location
    GA
    Posts
    335
    Post Thanks / Like
    Mentioned
    27 Post(s)

    Re: Not sure what's causing new amp to not turn on.

    If your ground and power wire touched it will have blown the fuse on your +battery terminal (assuming you are using a fuse). It would be a reason your
    amp would not turn on as the power line has been severed (if the fuse is blown for whatever reason). I'd go with an anl fuse if it's blown, forget buss fuses.






    James 1:2-5 2 Count it all joy when you fall into various trials, 3 knowing that the testing of your faith produces patience. 4 But let patience
    have its perfect work, that you may be perfect and complete, lacking nothing
    . 5 If any of you lacks wisdom, let him ask of God, who gives to all
    liberally and without reproach, and it will be given to him
    .

  4. #4
    Mr.meyhem's Avatar
    Mr.meyhem is offline CarAudio.com Elite



    Join Date
    Nov 2011
    Location
    Cold as F***, MN
    Posts
    1,056
    Post Thanks / Like
    Images
    15
    Mentioned
    1 Post(s)

    Re: Not sure what's causing new amp to not turn on.

    Quote Originally Posted by Jaguar View Post
    If your ground and power wire touched it will have blown the fuse on your +battery terminal (assuming you are using a fuse). It would be a reason your
    amp would not turn on as the power line has been severed (if the fuse is blown for whatever reason). I'd go with an anl fuse if it's blown, forget buss fuses.
    if this was true his old am wouldn't have worked when he hooked it back up. when the amp is on put a dmm on the terminals and see if u have current.



    Obsidian 15 D2 3.5 cubes 31hrtz
    Apsm 1300
    Alpine Type R 6.5 comps
    Cadence 250.2
    KnuKonceptz Kollossus Flex 4 awg
    AP LOC
    Distro Block
    2/0 Big 3
    ELD bypass in progress

  5. #5
    CrossoverOre's Avatar
    CrossoverOre is offline CarAudio.com Elite



    Join Date
    May 2012
    Location
    oregon
    Posts
    1,001
    Post Thanks / Like
    Images
    7
    Mentioned
    0 Post(s)

    Re: Not sure what's causing new amp to not turn on.

    make sure the ground is solid and power wire at the batt is solid too. My guess is there is enough juice to make the old amp fire up but not the crunch. Personally I am not a fan of crunch. Ive seen the amps fry and take out the speakers on its way.




Closed Thread

Similar Threads

  1. not sure what amp to buy
    By butler239 in forum Amplifiers
    Replies: 24
    Last Post: 05-05-2010, 11:42 AM
  2. not sure what amp to get..
    By robmusic42 in forum Amplifiers
    Replies: 1
    Last Post: 05-24-2009, 07:47 PM
  3. Help with 2 subs, 2 amps, 2 6x9's. Not sure what to do.
    By Dan.Wood in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 04-16-2009, 03:28 PM
  4. What would cause an amp to only work sometimes?
    By Nevalite in forum Amplifiers
    Replies: 6
    Last Post: 03-18-2008, 05:14 PM
  5. Replies: 3
    Last Post: 02-09-2008, 05:23 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum