Closed Thread
Results 1 to 3 of 3

Reload Thread: Rockford Fosgate T0

  1. #1
    BanginTacoma's Avatar
    BanginTacoma is offline Junior Member



    Join Date
    May 2012
    Location
    Lake Charles, LA
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 Rockford Fosgate T0

    Today my electrical system in my truck like totally failed on me. I have one Rockford Fosgate T0 12 on a Hifonics 1000.1D amp. It's running at 2Ohms so it's getting around 750watts. I have 4GA power and ground wires with 12GA Kicker speaker wire.

    Heres a video showing how dim it was going. It has never dimmed this bad before. It use to be just a slight dim which the electrical system only needed like 2 seconds to catch back up with.
    https://www.youtube.com/watch?v=QvLO...E&feature=plcp

    If anybody knows why this happened feel free to say something. I shut down the truck and started it back up and it seemed to be fine from there so idk. I'm puzzled. BTW sorry for the country music. All my music that I listen to that beats is on my iPhone and I couldn't record a video and stream the music at the same time I guess so I had to throw on the radio and that station was beating the hardest at the moment.

    Edit: I did notice however that one of the terminals on my box was hot. I couldn't see whether it was the positive or negative one becuz it was dark tho.



    ---Current System---
    Headunit: Pioneer AVIC-Z120BT
    Mids and Highs: Crescendo PWX 6.5's in the front, Stock in the rear
    Sub(s):1 AmericanBass XFL 15 in a ported box at 40Hz
    Amp(s):1 Hifonics 1600.1 w/ Bass Knob, Hifonics ZRX 1000.4
    Wiring: Rockford 0GA Power and Ground, Tsunami 4GA power wire and RCA's, Memphis Holder with 150amp Fuse

    All in a 2005 Toyota Sequoia.




  2. #2
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,920
    Post Thanks / Like
    Images
    28
    Mentioned
    159 Post(s)

    Re: Rockford Fosgate T0

    could be a failing terminal causing a slight short which is drawing more current from the amp. i've had those plastic terminals melt on me before.



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://mobileaudioforum.com/forum/showthread.php?6722-KHA-2014-Accord-Sport-SQ-Factory-Integration
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

  3. #3
    BanginTacoma's Avatar
    BanginTacoma is offline Junior Member

    Threadstarter


    Join Date
    May 2012
    Location
    Lake Charles, LA
    Posts
    26
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 Re: Rockford Fosgate T0

    Well I had a terminal cup melt on me before too. So this time I did some bolt connections.

    Melted Terminal Cup
    Rockford Fosgate T0-melted-plastic-terminal-cup.jpg
    Bolt Connections
    Rockford Fosgate T0-bolt-connections.jpg
    It was the bolt on the left that got hot too. Just that one though. The other one was fine.



    ---Current System---
    Headunit: Pioneer AVIC-Z120BT
    Mids and Highs: Crescendo PWX 6.5's in the front, Stock in the rear
    Sub(s):1 AmericanBass XFL 15 in a ported box at 40Hz
    Amp(s):1 Hifonics 1600.1 w/ Bass Knob, Hifonics ZRX 1000.4
    Wiring: Rockford 0GA Power and Ground, Tsunami 4GA power wire and RCA's, Memphis Holder with 150amp Fuse

    All in a 2005 Toyota Sequoia.

Closed Thread

Similar Threads

  1. Wiring for a Rockford Fosgate 800.2 amp
    By Ynot in forum Wiring, Electrical and Installation Help
    Replies: 12
    Last Post: 01-08-2002, 07:04 PM
  2. Rockford Fosgate Subs and Amp
    By <Fosgate Playa> in forum Subwoofers
    Replies: 3
    Last Post: 01-02-2002, 10:10 PM
  3. Best way to wire a Rockford Fosgate 800.2
    By Ynot in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 12-29-2001, 12:11 AM
  4. Rockford Fosgate Punch HE
    By Intel13 in forum Amplifiers
    Replies: 3
    Last Post: 12-27-2001, 09:27 PM
  5. Rockford fosgate RFR3112
    By avistar23 in forum Subwoofers
    Replies: 3
    Last Post: 12-25-2001, 12:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum