Closed Thread
Results 1 to 3 of 3

Reload Thread: Intermittent sound from 3 out of 4 speakers

  1. #1
    Headache's Avatar
    Headache is offline Junior Member



    Join Date
    Apr 2012
    Location
    Blacksburg, VA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Intermittent sound from 3 out of 4 speakers

    I have a 2004 Subaru Legacy wagon with a pioneer head unit that is 4.5 years old with factory speakers. I have made no changes to the system or setup, but earlier this week only my front left speaker was working. I parked my car and when I started it later, all speakers were working again. A couple days later, I started the car and only the front left speaker worked. It seems like they are either working or not, no cutting in and out, no distortion.

    I checked the head unit connection and everything seems to be fine. I removed the passenger door panel and the wiring to the speaker looks fine. No frayed wires or bad connections.


    Any ideas?







  2. #2
    lloydon's Avatar
    lloydon is offline Junior Member



    Join Date
    Sep 2012
    Location
    L.E.H., NJ
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Intermittent sound from 3 out of 4 speakers

    I have the same problem on my 2005 Subaru Baja. Dealers want to charge too much about something they know nothing about. Trying to tell me it's the speakers. Speakers aren't intermittent. My problem is any speaker or none can come on or off. It has to be oxidation on the connector from the radio to the speakers. If I can find the connector, I think re-seating it will help. It might also be a sender (relay).




  3. #3
    Join Date
    May 2012
    Location
    Chicago
    Posts
    142
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    58 Post(s)

    Re: Intermittent sound from 3 out of 4 speakers

    I think oxidation would be a great explanation. I drive a 20+ year old car which sat for a while and the head unit had a similar issue. I mean, I suppose it could be a short as well, but I wouldn't even be surprised if your head unit is going bad. Although, since a fellow subi owner is experiencing similar issues, it might be a subaru specific problem. I know I kind of stated the obvious/already said here. But hopefully I helped a little.




Closed Thread

Similar Threads

  1. My head unit plays, but no sound out of speakers.
    By broncolaxman307 in forum Wiring, Electrical and Installation Help
    Replies: 10
    Last Post: 05-12-2010, 03:18 AM
  2. no sound out of speakers...headunit still on
    By jerZey in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 10-16-2006, 05:11 PM
  3. I have no sound coming out of my speakers
    By Polaris in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 02-26-2006, 04:05 PM
  4. No sound from one of the rear speakers
    By afekturkit in forum Speakers
    Replies: 0
    Last Post: 06-16-2004, 03:31 AM
  5. Almost no sound out of speakers...
    By vespa in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 01-06-2002, 09:31 AM

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum