Closed Thread
Results 1 to 4 of 4

Reload Thread: Amp not working!!!!!!!!!!!!!

  1. #1
    cr916's Avatar
    cr916 is offline Junior Member



    Join Date
    Apr 2012
    Location
    Sacramento, Ca
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Amp not working!!!!!!!!!!!!!

    I have a planet audio tq1201d amp that when i hook up i dont get any sound out of, and it dosent go into protection mode, i was wondering if anyone has an idean of what might be wrong with it?







  2. #2
    CRSO's Avatar
    CRSO is offline Jersey Trash Collecktah



    Join Date
    Apr 2012
    Location
    Jersey. We Got Hella Bricks.......
    Posts
    409
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Amp not working!!!!!!!!!!!!!

    Could be a lot of things... Are you getting a power status light?




  3. #3
    brodeisel's Avatar
    brodeisel is offline The Cool Newb



    Join Date
    Jun 2011
    Location
    iowa
    Posts
    4,319
    Post Thanks / Like
    Mentioned
    38 Post(s)

    Re: Amp not working!!!!!!!!!!!!!

    remote wire, rcas



    Bought from- pjc, boomsday, El Weenie, Sacsking, BassinBuick, Kangaroux
    Sold to- Mast240,

  4. #4
    cr916's Avatar
    cr916 is offline Junior Member

    Threadstarter


    Join Date
    Apr 2012
    Location
    Sacramento, Ca
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Amp not working!!!!!!!!!!!!!

    Yes im gettin a power status light and everything is hooked up correctly




Closed Thread

Similar Threads

  1. bass knob for hifonics amp not working.
    By kyleg94cavy in forum Amplifiers
    Replies: 2
    Last Post: 01-23-2004, 09:14 AM
  2. Amp not working
    By BooLeaN in forum Amplifiers
    Replies: 2
    Last Post: 12-22-2003, 11:52 AM
  3. Amp not working, cant figure out the weak link.
    By BobTheSlob in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 05-18-2003, 03:32 PM
  4. Amp not working need help fast!
    By QuadPioneer in forum Subwoofers
    Replies: 3
    Last Post: 03-07-2003, 08:32 PM
  5. Kicker Impulse Amp not working
    By Trancer in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 08-10-2002, 02:24 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum