Closed Thread
Results 1 to 10 of 10

Reload Thread: Sub cutting on and off

  1. #1
    kalkx's Avatar
    kalkx is offline Member



    Join Date
    Apr 2011
    Location
    florida
    Posts
    64
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Sub cutting on and off

    My problem is whenever i startup and get going my sub plays normally on any levels but after about a minute or two you can hear it start to turn on and off repeatedly like its trying to play but theres a loose connection i checked everything going into the amp and the wires look fine so I have no idea where i should start or if its even a wiring problem?







  2. #2
    dragonrage's Avatar
    dragonrage is offline CarAudio.com Elite



    Join Date
    Feb 2007
    Location
    Massachusetts
    Posts
    571
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    What kind of car?
    What kind of amp(s)?
    What kind of subs and what impedance are they wired to?
    What gauge wire? What type of fuse and what amperage is it?
    What is your amp grounded to? How long is the ground wire?
    Is your amp mounted upside down? Some amps don't like that and will overheat much easier that way.
    Does your amp get hot?
    Have you measured the voltage at the amp and/or the voltage drop across the wires?



    2009 Pontiac G8 GT - Selling/Trading soon...
    Ebay: ddfromma | Heatware feedback: ddfromma

  3. Thanks audiobaun thanked for this post
  4. #3
    poisoned10's Avatar
    poisoned10 is offline Member



    Join Date
    Jan 2012
    Location
    Richmond
    Posts
    108
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    Quote Originally Posted by kalkx View Post
    My problem is whenever i startup and get going my sub plays normally on any levels but after about a minute or two you can hear it start to turn on and off repeatedly like its trying to play but theres a loose connection i checked everything going into the amp and the wires look fine so I have no idea where i should start or if its even a wiring problem?

    Don't forget to check the wires connected to the sub.



    Head Unit: JVC-AVX840
    Amp: MB Quart Onyx 1000.1
    Sub: Kicker 12" L7
    Big 3 Upgrade

  5. #4
    smokesnugs's Avatar
    smokesnugs is offline Member



    Join Date
    Jan 2012
    Location
    Space Coast of Florida
    Posts
    38
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    How can I go about testing my voltage and how will I know if it's all flowing properly?




  6. #5
    slim217's Avatar
    slim217 is offline Member



    Join Date
    Nov 2011
    Location
    illinois
    Posts
    124
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    mine would do that at one point it was my fuse under hood wasnt connecting very good




  7. #6
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,569
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: Sub cutting on and off

    Sounds to me like you have wired your subwoofer to the wrong ohm load.I could be wrong, but what it sounds like to me.Check your wiring configuration, and check the specs of the amplifier and make sure that that amplifier is stable at that ohms load.Just a suggestion.




  8. #7
    kalkx's Avatar
    kalkx is offline Member

    Threadstarter


    Join Date
    Apr 2011
    Location
    florida
    Posts
    64
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    its wired at 2 ohms but i think you guys might be right it probably came loose at the sub the terminals arent that friendly to wire so stuff was probably loose




  9. #8
    Pumper's Avatar
    Pumper is offline Member



    Join Date
    Dec 2011
    Location
    Denver, co
    Posts
    55
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    I have the same issue bro! This happened to me on 2 amps and on 2 subs, same wiring. So it has to be the wiring.

    The guy said it must be the power cable in my case. I'm about to buy a new ground and power cable and just put those in. Hopefully it fixes them. (I'll let you know once I take it back to him)

    When mine goes off, does it just rattle without any bass? If so, I know how you feel.




  10. #9
    kalkx's Avatar
    kalkx is offline Member

    Threadstarter


    Join Date
    Apr 2011
    Location
    florida
    Posts
    64
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    Quote Originally Posted by Pumper View Post
    I have the same issue bro! This happened to me on 2 amps and on 2 subs, same wiring. So it has to be the wiring.

    The guy said it must be the power cable in my case. I'm about to buy a new ground and power cable and just put those in. Hopefully it fixes them. (I'll let you know once I take it back to him)

    When mine goes off, does it just rattle without any bass? If so, I know how you feel.
    it doesnt really rattle more like a popping noise its so weird though because somedays I can play for extended periods of time and have no problem than instantly it will start to play weird other days i turn on my truck and its already being weird it sounds more like if you take a 9v battery and then take your speaker wire and put them together




  11. #10
    Pumper's Avatar
    Pumper is offline Member



    Join Date
    Dec 2011
    Location
    Denver, co
    Posts
    55
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Sub cutting on and off

    Is it like a popping behind the sub? Like the sub isn't moving but it's farting? I'm getting that quite often now. Can't wait until I wire my NEW ground and power cables. I'm hoping that will fix the issue. (My old ones were not the correct gauge)




Closed Thread

Similar Threads

  1. subs go on and off?
    By andycc529 in forum New Member Introduction
    Replies: 1
    Last Post: 08-12-2009, 05:00 AM
  2. Kenwood KDC-x692 cuts on and off
    By Ballinboricua13 in forum Head Units
    Replies: 2
    Last Post: 05-28-2009, 04:09 PM
  3. HELP: subs skip beats, turn on and off
    By 1skrew in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 12-25-2008, 04:55 PM
  4. screen cuts on and off?
    By d77543020 in forum Car Video, Security and Electronics
    Replies: 1
    Last Post: 08-28-2006, 12:11 PM
  5. turning sub amp on and off
    By Johnston_2007 in forum Amplifiers
    Replies: 4
    Last Post: 08-23-2005, 01:48 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum