Closed Thread
Results 1 to 3 of 3

Reload Thread: Swap to Kenwood 318DDX, amp, subwoofer help needed

  1. #1
    TCAS007's Avatar
    TCAS007 is offline Junior Member



    Join Date
    Dec 2011
    Location
    UT
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 Swap to Kenwood 318DDX, amp, subwoofer help needed

    Hi guys!
    I am new here, just found the board when I was trying to find help for a small problem I have.

    I own a 2007 Ford Expedition Eddie Bauer and the stock CD6 MP3 radio broke. So I got the Kenwood 318DDX installed. They seemed professional and charged me adapters, harness kit,...
    While I was driving I had no time to play with the settings but after being home I definately found out that there is way less BASS then before with the stock Ford radio.

    I am almost sure that I have a sub with a Ford amp at the left rear side and that it is no more working.

    The radio settings do not give me the subwoofer option either.

    So as I have to drive for an hour to go back on Monday, please tell me if there is anything I can fix or check myself. Or is this just normal? I doubt it.

    I have to admit that I never had to do with anything Ford and radios so I am a bit lost. But my ears know what a bass sounds and even the sound is good, there is not bass enough.

    See the attachments for additional info.

    Thanks so much!

    Eric
    Attached Thumbnails Attached Thumbnails Swap to Kenwood 318DDX, amp, subwoofer help needed-kenwood.jpg   Swap to Kenwood 318DDX, amp, subwoofer help needed-amp_ford.jpg   Swap to Kenwood 318DDX, amp, subwoofer help needed-settings.jpg   Swap to Kenwood 318DDX, amp, subwoofer help needed-sub.jpg  







  2. #2
    >>SQL<<'s Avatar
    >>SQL<< is offline CarAudio.com Elite



    Join Date
    May 2011
    Location
    USA
    Posts
    1,457
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Swap to Kenwood 318DDX, amp, subwoofer help needed

    Sounds like the factory subwoofer is no longer working.
    You are going to most likely bring it back to the shop that installed it.
    I would think getting it to work with the new radio should not be too hard.




  3. #3
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,389
    Post Thanks / Like
    Mentioned
    46 Post(s)

    Re: Swap to Kenwood 318DDX, amp, subwoofer help needed

    Ya take it back to where you had the HU installed, and let them know that there is an issue with one of your speakers/subwoofer, and make them do it right.They should not have let you leave with the speaker not working properly, or at least letting you know that an extra part may be needed?Sounds like they tried to pull a shaft on you/lazy installers/taking your hard earned money Dont mess with anything other than the HU, as if you do, they will say you tampered with it, and void the workmanship/so called warranty.You are the customer, and should have received the service that you paid for,and you did not IMO




Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum