Closed Thread
Results 1 to 5 of 5

Reload Thread: Help with Amp/Subwoofers Please

  1. #1
    aj213121's Avatar
    aj213121 is offline Junior Member



    Join Date
    Jun 2011
    Location
    chicago
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Help with Amp/Subwoofers Please

    Alright, to begin, I have the Rockford Fosgate Prime R500-1 Amplifier and a 12'' Pioneer TS-w309d4 subwoofer(s). Before when i only had one sub i was running it at 2ohms and it was very loud, but just recently i added another subwoofer of the same kind and since my amp cannot support a 1ohm load i was forced to wire it into a 4ohm load, but now it seems like i had more bass when i was using only 1 sub. I'm not sure how that is possible and i was just looking for some help. Would re-tuning my amplifier help or what? I just dont want to mess up the settings i currently have on the amp if changing it isnt going to work. As of right now I have my subs wired at 1ohm which causes my amp to go into protect mode after about 30 minutes, but it is giving me some mad bass, but im looking to wire it correctly with nearly the same results before i damage my amp.







  2. #2
    sam_b03's Avatar
    sam_b03 is offline Senior VIP Member



    Join Date
    Feb 2009
    Location
    western OKlahoma
    Posts
    338
    Post Thanks / Like
    Mentioned
    19 Post(s)

    Re: Help with Amp/Subwoofers Please

    if you look at the wattage rates, they usually get cut in half when doubling the Ohm load. So basicly you are sending a 1/4 of the power per speaker. Half the watts and twice the speaker.



    CDT 642 powered by Clarion Apx 4360
    SA-12 powered by MB Quart ONYX1500.1

  3. #3
    aj213121's Avatar
    aj213121 is offline Junior Member

    Threadstarter


    Join Date
    Jun 2011
    Location
    chicago
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Help with Amp/Subwoofers Please

    So what would you recommend doing? I was thinking i probably need an amp that can handle a 1ohm load but im not sure lol because the bass really stinks at 4ohms and i can really only wire them at either 4 or 1 ohm

    And to add...i have my gains and frequency still set to when i had one sub installed if that makes any difference. I was just wondering if i should re-tune this stuff since i added another sub and if that would make my bass a lot better at 4ohms




  4. #4
    All_Logix's Avatar
    All_Logix is offline Formerly CivicGTi



    Join Date
    Dec 2010
    Location
    Texas
    Posts
    694
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Help with Amp/Subwoofers Please

    Don't change your freq or gains, you have 3 options.... go back to 1 sub, get an amp that is 1 ohm stable or really hig power for good output @ 4 ohms...OR, get new subs that have 4 ohm SVC or 2 ohm DVC




  5. #5
    murph's Avatar
    murph is offline Low for Life



    Join Date
    Sep 2011
    Location
    Richmond,VA
    Posts
    3,904
    Post Thanks / Like
    Mentioned
    89 Post(s)

    Re: Help with Amp/Subwoofers Please




    Hu: kenwood kdc-x995
    Sub: Boston acoustics G5 12 in a quasi 6th order
    Amp: Eclipse Xa5000
    Front Speakers: Eclipse sc6500
    HIT UP FOR BASS ---> http://www.youtube.com/user/BassWithMurph?feature=mhee

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum