Closed Thread
Results 1 to 4 of 4

Reload Thread: MTX 1000xd won't go out of protection mode.

  1. #1
    rbai76's Avatar
    rbai76 is offline Junior Member



    Join Date
    Jun 2011
    Location
    Annapolis, MD
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)

    MTX 1000xd won't go out of protection mode.

    So I bought an MTX 1000xd amp from classfields here. Im not sure if it works or not, I opened it up and didn't see anything blown or melted.

    I also wired my cherokee with knukonceptz 0 gauge dual amp kit, fuses are all good. Only problem is when everything is connected and when the amp starts up it is green for like .5 seconds then turns to red and buzzes. Now could this be a grounding issue or do you think it could have to do something with the amp it self. The power is the problem because I have unplugged everything and plugged back in once at a time to see what the problem was and it is the power. I have sanded down the paint under the carpet in the back of my car and it is connected there. I have touched around a few spots but still in protection mode.

    Tell me what you guys think

    Thanks







  2. #2
    Shinju's Avatar
    Shinju is offline CarAudio.com Veteran



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    4,821
    Post Thanks / Like
    Mentioned
    23 Post(s)

    Re: MTX 1000xd won't go out of protection mode.

    Get your money back if you just got it, Or pay 95.00 to MTX for a flate rate amp repair.



    List of Ref's Just ask, Shinju on all Car Audio Forums!


    Flawless Ebay Feedback User: Shadox2k2

  3. #3
    keep_hope_alive's Avatar
    keep_hope_alive is offline Acoustics Engineer keep_hope_alive is a Supporting Member of the forum!



    Join Date
    May 2007
    Location
    Quad Cities, IL
    Posts
    5,920
    Post Thanks / Like
    Images
    28
    Mentioned
    159 Post(s)

    Re: MTX 1000xd won't go out of protection mode.

    are speaker wires connected during this time? if so, disconnect them.



    have you been helped by me? i'd love to know. shoot me a PM.

    My 2014 Accord build log: http://mobileaudioforum.com/forum/showthread.php?6722-KHA-2014-Accord-Sport-SQ-Factory-Integration
    *My 2001 Accord build log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long.html
    *2005 Scion tC Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/516096-2005-scion-tc-sq-hertz-audison-pioneer-build-log.html
    *1998 Astro Van Build Log: http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/567468-kha-does-spl-build-1996-astro-van.html

  4. #4
    rbai76's Avatar
    rbai76 is offline Junior Member

    Threadstarter


    Join Date
    Jun 2011
    Location
    Annapolis, MD
    Posts
    22
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: MTX 1000xd won't go out of protection mode.

    Quote Originally Posted by keep_hope_alive View Post
    are speaker wires connected during this time? if so, disconnect them.
    Yes, I have done it connected and disconnected. I have tried with only power, ground and the remote power cables connected and still does it.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum