Closed Thread
Results 1 to 8 of 8

Reload Thread: got a few questions about my amp wiring

  1. #1
    thunderhack's Avatar
    thunderhack is offline Junior Member



    Join Date
    Jun 2011
    Location
    louisville, ky
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    got a few questions about my amp wiring

    got an amp today and installed pretty easily but i am having some trouble:
    1-when i first turned on the car after hooking the amp all up, the fuse that was in it blew, so i want to know if i grounded it right?

    first they gave me the wire and o-ring thing but they weren't together, so i guess what im trying to say is how do i properly put the two items together and lastly
    3-where should i ground it if i am putting it under my seat---i previously had it connected to where the seat belt bolt connect was( i have a 94 geo prizm )

    thanks!







  2. #2
    All_Logix's Avatar
    All_Logix is offline Formerly CivicGTi



    Join Date
    Dec 2010
    Location
    Texas
    Posts
    694
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    49 Post(s)

    Re: got a few questions about my amp wiring

    Well first, to ground I would just run to the chassis of the vehicle which a seat belt bolt is generally a good location because it is so deeply threaded into the sheet metal on the car. AND lastly, the best way to connect the ring terminal and the wire is with crimps.

    But the issue with the fuse blowing in the amp is generally an issue with the draw from the amp....is the gained cranked WAY up or is it getting really hot?




  3. #3
    thunderhack's Avatar
    thunderhack is offline Junior Member

    Threadstarter


    Join Date
    Jun 2011
    Location
    louisville, ky
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: got a few questions about my amp wiring

    the gain was all the way down and it never turned on, the fuse blew as soon as the car was turned on




  4. #4
    All_Logix's Avatar
    All_Logix is offline Formerly CivicGTi



    Join Date
    Dec 2010
    Location
    Texas
    Posts
    694
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    49 Post(s)

    Re: got a few questions about my amp wiring

    humm I don't mean to insult your intelligence but the power and ground weren't touching were they?




  5. Thanks thunderhack thanked for this post
  6. #5
    thunderhack's Avatar
    thunderhack is offline Junior Member

    Threadstarter


    Join Date
    Jun 2011
    Location
    louisville, ky
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: got a few questions about my amp wiring

    your good- im positive you know much more than i do about this stuff, and no the weren't touching on the amp it went for positive-rem-ground, im probably an idiot for this, but do you have to use the wire terminals when attaching them to the amp? or can you just attach the wire straight up to the amp?




  7. #6
    Dirtrider4eva's Avatar
    Dirtrider4eva is offline √\_The CaUsE__



    Join Date
    Mar 2011
    Location
    Milwaukee, WI
    Posts
    4,289
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    840 Post(s)

    Re: got a few questions about my amp wiring

    you can do either, it doesnt matter. i feel like you crossed a wire, or your amp is bad.. was it blown before you even turned it on?..
    check your battery connections as well, they could be poorly attatched.
    Should you have an IN line fuse from the power wire near the bat?



    welcome to
    Where b-stock is the new a-stock
    TEAM WEST

  8. Thanks thunderhack thanked for this post
  9. #7
    thunderhack's Avatar
    thunderhack is offline Junior Member

    Threadstarter


    Join Date
    Jun 2011
    Location
    louisville, ky
    Posts
    18
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: got a few questions about my amp wiring

    got it all hooked up --correctly! for some strange reason the positive was in negative slot and vice versa. cant believe i did that but hey im new to this stuff.




  10. #8
    bhsdriller's Avatar
    bhsdriller is offline CarAudio.com Veteran



    Join Date
    Jul 2007
    Location
    bakersfield,ca
    Posts
    4,491
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    344 Post(s)

    Re: got a few questions about my amp wiring

    that will usually do it...glad you figured it out



    Team Flex Issues
    4 18" Mayhems
    2 bc5500's


    Bought from: ameduce(x2), Hatchet_Warrior, jeeper07,DB_DRAG_SPL,ssackett, lyttleviet,MillzThaYungin, blackbonnie, ryan1126, Goindef154(x2), Lonnie, dave_damage

    Sold to: Ilovebass, nismos14, chednompton, teen, jonesy

  11. Thanks thunderhack thanked for this post
Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum