Closed Thread
Results 1 to 4 of 4

Reload Thread: It just doesn't sound right!! Help a newbie..

  1. #1
    julesMI's Avatar
    julesMI is offline Junior Member



    Join Date
    Apr 2011
    Location
    Canton, MI
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    It just doesn't sound right!! Help a newbie..

    Hey all! Hoping you experts can help me figure out how to get the best output from my setup. I'm wondering if I should shell out for a JL CleanSweep, try a rewire, change the sub enclosure, or get diff gear. Here's background info:

    I have a 2007 Charger R/T w/ Perf Pkg - came with a good Boston setup, 6 speakers + 276w amp to power all 6 (not sure of watts per chann). I guess there's only 1 pair of full range channels that were powering the rear 6x9s. At least that's what installer #1 told me.

    The doors just blew (midrange only) and I replaced them with BA SC60 components (tweets, mids, & passive xovers). Dude who installed said he had to run the SC60s off the full-range channels since they're components, so the only pair of full channels are running both the rears & new doors. Now I've got ZERO bass from rears and my ears are bleeding from too much high & mid (even cranked way down on HU). So, do some more research and pick out a sub/amp/box & had it installed this week - 10" BA G110-4, GTA-802, sealed .56 cuft box. Went with BA again on someone's suggestion that it'll handle diff types of tunes well.

    I can barely tell there's a sub in the trunk! (Diff) installer says it's not that loud bc my seat backs are extra dense, but still sounds weak with seatback down. Played around with amp settings per manual and no joy. I don't want some gangster boom, but I can't feel anything. WTF is going on?? Are these installers just BS'in me or what am I missing? Wrong brand or sub? Wrong wiring/channel setup? Try a ported box? Need a 2nd 10" + amp? Add sound processor?

    What should I try next? The I was happy with the original OEM system and now I'm in about $700 aftermarket and it sounds like ****. Want to keep the factory HU for wheel controls & so it's less obvious I have aftermarket stuff. I've researched all over online and talked to every audiophile I know, but still not sure.

    Help me experts!! Sorry for the novel, just wanted to include ALL setup specs & problems!







  2. #2
    WhyUmad's Avatar
    WhyUmad is offline Member



    Join Date
    Apr 2011
    Location
    FL
    Posts
    128
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)

    Re: It just doesn't sound right!! Help a newbie..

    I would change the head unit but if you're set on doing it the hard way than keep the factory deck, get a clean sweep and some new installers




  3. #3
    Heeltoeclutch's Avatar
    Heeltoeclutch is offline CarAudio.com Elite



    Join Date
    Jan 2011
    Location
    San Diego/Flint, MI
    Age
    23
    Posts
    1,256
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: It just doesn't sound right!! Help a newbie..

    I'm sorry man, I can only imagine how frustrating this must be Welcome and I have no doubt that you will be able to get help from this forum.

    Did they use a Line out converter or use high-level signal for the amp input? Meaning are there RCAs coming from the amp or does it have a "speaker level input?"

    It would help if you could take a pic of the sides of the amp or tell us what the crossovers are set to, all that stuff.



    Feedback-ness
    http://www.caraudio.com/forums/buyer-seller-feedback/503302-heeltoeclutch-feedback.html

  4. #4
    disturbed471985's Avatar
    disturbed471985 is offline CarAudio.com Veteran



    Join Date
    Jun 2009
    Location
    Greenwood, La
    Age
    29
    Posts
    7,107
    Post Thanks / Like
    Mentioned
    11 Post(s)

    Re: It just doesn't sound right!! Help a newbie..

    Would need to know all your amp setting and hu settings to even begin to narrow it down.



    RIP Maynard "My heart"

    HU - Eclipse CD7000
    Front Stage - 4 Silver flute 6.5's - 4 Seas Prestige tweets
    Front Stage amp - DB Drive A7 125.4
    Subwoofer - 1 TRF 15" Custom built
    Subwoofer Amp - 2 - Skar SK-2500's & Sundown 5k & 2 Nendo bc2000's " swap back and forth between them"
    Box - Secret
    Wiring - Knukonceptz everything, Big 3, Sprinter S12V370F & HC1800

Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum