Closed Thread
Results 1 to 2 of 2

Reload Thread: Upgrading Factory Mach System in 2002 Ford Expedition

  1. #1
    youthman's Avatar
    youthman is offline Junior Member



    Join Date
    Mar 2011
    Location
    Florida
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Upgrading Factory Mach System in 2002 Ford Expedition

    I just purchased a 2002 Ford Expedition Eddie Bauer with Mach Audio System. The amp or sub does not work. This is my wife's car so I don't need anything to SLAM, I just need at least SOME bass. I'm guessing the Mach system has some form of Xover on the door speakers because they produce absolutely NO bass at all...NONE.

    I began looking on Craigslist for some upgrades and tonight I picked a Kenwood Excelon KDC-X794 HU, Polk/Momo MMC650 Component Speakers, and an old school MTX Thunder 240 amp for $140 which I thought was a pretty good deal and definitely budget friendly.

    I've ordered the Mounting Bracket for the HU but need to buy the rest of wiring. I've installed a few systems over the years but I've never had any experience with a car with "Premium Sound System"...basically a car with a factory amp and sub installed.

    So here are my questions:

    1. Do I need to buy the standard harness or the "Premium Harness" that is designed to go with the Mach System?

    2. Should I try to use the existing speaker wires or run all new wire?

    3. Any recommendations for inexpensive speaker cables? I use monoprice.com for all my Home Audio needs. Should I just buy them there?

    4. I want to use the existing sub enclosure on the side wall. Any recommendations for a budget 8" sub that could go there? There is a JL 8W0 for $45 locally. I know this is JL's entry level but again, I just at least need some bass. I don't need it to set off building alarms. I've read that I will likely need to get a heat gun to push the "hump" inside the custom sub enclosure because most aftermarket sub's magnet hit the "hump". I will also need to patch the hole in the back of the sub enclosure. For some reason, Ford decided to put a screw into the magnet of the factory sub to help hold it in place. Hope that makes sense.

    Thanks in advance for your help.

    Michael







  2. #2
    youthman's Avatar
    youthman is offline Junior Member

    Threadstarter


    Join Date
    Mar 2011
    Location
    Florida
    Posts
    7
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Upgrading Factory Mach System in 2002 Ford Expedition

    Anyone have any advice they can offer?




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum