Closed Thread
Results 1 to 2 of 2

Reload Thread: Amp wont stay powered?

  1. #1
    Dirtrider4eva's Avatar
    Dirtrider4eva is offline √\_The CaUsE__



    Join Date
    Mar 2011
    Location
    Milwaukee, WI
    Posts
    4,289
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    840 Post(s)

    Amp wont stay powered?

    I'm running a kicker 08zx 750.1 mono block amp off an 8 gauge power wire. ground wire is drilled into the body, (sand papered area first of about a quarter). The amp is powering a 15" alpine 1542d sub at 2 ohms. I just bought the amp off a buddy about 2 weeks back. he had it on a 15" kicker square, and cranked it, no problems, when i even have it on for a matter of 30 seconds, it goes into protection, then 15 seconds playing, protection mode, 5 seconds playing, then protection for a long while. Is it my battery, amp wire? my battery isnt in the best conditions, and i feel it is either the inline power fuse terminal (a little odd for my last amp blew that fuse and melted terminal a bit, or battery for it is 8 years old). Let me know!
    - its in a 2000 celica gt.







  2. #2
    plugitin's Avatar
    plugitin is offline She Bangs plugitin is a Supporting Member of the forum!



    Join Date
    Jul 2009
    Location
    Da U.P. eh?
    Age
    24
    Posts
    6,473
    Post Thanks / Like
    Images
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    111 Post(s)

    Re: Amp wont stay powered?

    i would say the 8 gauge wiring helps none at all...go atleast 4 gauge with that amp man



    Team DC Audio


    Refs: absoluteaudio, rab, walnut, seedubs1, dbeez, -leister-, Louisiana_crx, bubbagumper6, DS Autpsports, Mr.Ronin_2U, lil98cabrio, wone, micah_jones, grinder1989

Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum