Closed Thread
Results 1 to 9 of 9

Reload Thread: Problem getting power HELP

  1. #1
    Masterluke5000's Avatar
    Masterluke5000 is offline Junior Member



    Join Date
    Feb 2011
    Location
    Willoughby, OH
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 Problem getting power HELP

    So i have had my current system for about 4 months. 2 12in American Bass XD subs, Soundstream dtr1400.1 rated at 1400rms at 1 ohm (which is how my subs are wired)

    Recently my amp has been cutting out while driving for up to a minute. It used to snap right back on after a while. After about a week of that, it wouldnt even power my subs when i started my car. (protect mode light was on), and a few days after that, the amp power light would turn on when i started my car but fade off after about three seconds. Now it wont turn on at all. I recently replaced my battery.

    I redid my ground to a more secure place in the trunk. its now on the frame of the car. Im running 4 ga wire as the amp recommends and a 100 amp fuse under the hood.

    I was convinced my amp was shot until today when i hooked up my buddies amp and the power light would not go on.

    Can anyone please help?







  2. #2
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,472
    Post Thanks / Like
    Mentioned
    81 Post(s)

    Re: Problem getting power HELP

    is the fuse intact?




  3. #3
    Masterluke5000's Avatar
    Masterluke5000 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Willoughby, OH
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem getting power HELP

    yes, i have two 100 amps and i switched them out and no luck




  4. #4
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,472
    Post Thanks / Like
    Mentioned
    81 Post(s)

    Re: Problem getting power HELP

    have you checked your headunit to make sure the remote turn on is working fine? if the amp isn't even turning on that sounds like more of a remote turnon issue rather than a power issue




  5. #5
    Masterluke5000's Avatar
    Masterluke5000 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Willoughby, OH
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem getting power HELP

    not sure what that means or how to check it but its not shutting off anymore, it just wont even turn on.




  6. #6
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,472
    Post Thanks / Like
    Mentioned
    81 Post(s)

    Re: Problem getting power HELP

    the remote turn on is the blue wire coming out of the back of your headunit. it's usually run along the car with the RCA's that come from the preouts of your headunit. i'd check to see the wire hasn't split anywhere and that it's secured at the headunit




  7. #7
    Masterluke5000's Avatar
    Masterluke5000 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Willoughby, OH
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem getting power HELP

    I completely ruled out checking my headunit because i had it professionally installed, but the shop i got it done at has been pissing me off lately so i wouldnt doubt it was done incorrectly. thanks. also does it matter how thick the remote wire is? because mine is pretty thin..




  8. #8
    Masterluke5000's Avatar
    Masterluke5000 is offline Junior Member

    Threadstarter


    Join Date
    Feb 2011
    Location
    Willoughby, OH
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Problem getting power HELP

    Is there a way to pop out the headunit easily? There are so many pieces in my car that have to come out when they installed the installation kit and headunit i really dont wanna spend hours putting that back together..




  9. #9
    Kangaroux's Avatar
    Kangaroux is offline I put on



    Join Date
    Dec 2010
    Location
    Maine
    Posts
    9,472
    Post Thanks / Like
    Mentioned
    81 Post(s)

    Re: Problem getting power HELP

    The remote wire is supposed to be very thin. As for getting the headunit out, i'm no expert on that, maybe someone else can help you on that..




  10. Thanks Masterluke5000 thanked for this post
Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum