Closed Thread
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 15 of 50

Reload Thread: Voltage drop with good electrical. What am I doing wrong?

  1. #1
    hatedonmostly's Avatar
    hatedonmostly is offline throwin' hunnits, hunnits



    Join Date
    Jun 2009
    Location
    Detroit, MI
    Age
    23
    Posts
    6,382
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Voltage drop with good electrical. What am I doing wrong?

    Setup in sig. I have:
    -Two MB Quart DSC1500.1Ds strapped at 1.2 ohm (0.6 ohm each amp)
    -Two Sprinter 100Ah batteries in the rear
    -Crappy stock battery up front (for now)
    -136A alternator
    -Big three done in 1/0 (positive to alternator positive, chassis ground to the driver's side fender, engine ground to the top of the engine block)
    -Wiring is done as follows: Amps to distribution block (one for + and -), two runs of wire from distribution block to rear batteries (one for + and -), two runs of wire from rear batteries to front battery (one for + and -). No interaction with the chassis or frame of the vehicle, everything is directly connected.

    I realize two 1500W amps strapped at 0.6 is going to be hard on an electrical no matter what, but a buddy of mine ran one of these amps at 0.5 with only a stock front battery, 80A alt, and a Deka in the rear and only dropped 0.4.

    No clue what I am doing wrong, all of my connections are soldered, each run of wire from front batt to rear is about 20 ft long and each run from rear batt bank to cabin, where the distros/amps are, is 10 ft long. All batteries and alt are working properly








  2. #2
    SicAudio's Avatar
    SicAudio is offline did you fart dude?



    Join Date
    Apr 2009
    Location
    melting HO alts...
    Age
    43
    Posts
    6,202
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    1 at .5 is no where near as taxing as 2 at 1.2 is

    you need more juice...



    Quote Originally Posted by slammedincouch View Post
    Sic rolled me in front of my mom earlier...
    Quote Originally Posted by misfit138 View Post
    How did you manage to pack that much stupid into such a small amount of words?
    Quote Originally Posted by Magnus View Post
    I got rick rolled by SicAudio lulz
    Quote Originally Posted by Magnus View Post
    I just got rick rolled by SicAudio again lulz.
    Quote Originally Posted by chickaboom View Post
    awww.... dude! I can't believe you were the first! to rick roll me! I am a noob!
    sold to: Johnny Law.Lulz/Worstenemy453,Pumkinman, j1b1e1, DexterMoped, miyagi gboo559,CSU87,nate2587, MichaelLane, SmLLySack. MR_Imperial, Herrrerra, ltr450racer690, 05fronty bought from: TripleB45, bigwheel15, (kroid77 but never recieved..)
    helping noobs daily PM me

  3. #3
    SicAudio's Avatar
    SicAudio is offline did you fart dude?



    Join Date
    Apr 2009
    Location
    melting HO alts...
    Age
    43
    Posts
    6,202
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    i wouldnt attempt that setup without at least 400ah of batt on that small alt...



    Quote Originally Posted by slammedincouch View Post
    Sic rolled me in front of my mom earlier...
    Quote Originally Posted by misfit138 View Post
    How did you manage to pack that much stupid into such a small amount of words?
    Quote Originally Posted by Magnus View Post
    I got rick rolled by SicAudio lulz
    Quote Originally Posted by Magnus View Post
    I just got rick rolled by SicAudio again lulz.
    Quote Originally Posted by chickaboom View Post
    awww.... dude! I can't believe you were the first! to rick roll me! I am a noob!
    sold to: Johnny Law.Lulz/Worstenemy453,Pumkinman, j1b1e1, DexterMoped, miyagi gboo559,CSU87,nate2587, MichaelLane, SmLLySack. MR_Imperial, Herrrerra, ltr450racer690, 05fronty bought from: TripleB45, bigwheel15, (kroid77 but never recieved..)
    helping noobs daily PM me

  4. #4
    Phoenix Risen's Avatar
    Phoenix Risen is offline OG.... Original Ginger



    Join Date
    Jun 2010
    Location
    Dayton/Springfield, Ohio
    Posts
    4,064
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    350 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    double check all of your grounds as well, it could be something as simple as needing a washer on a connection somewhere, had it happen to me a couple times.

    also how far is your voltage dropping exactly?



    R.I.P. 2008 Hyundai Tiburon GS
    2005 Subaru Baja turbo, build in planing stages.

  5. #5
    hatedonmostly's Avatar
    hatedonmostly is offline throwin' hunnits, hunnits

    Threadstarter


    Join Date
    Jun 2009
    Location
    Detroit, MI
    Age
    23
    Posts
    6,382
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    Quote Originally Posted by SicAudio View Post
    1 at .5 is no where near as taxing as 2 at 1.2 is

    you need more juice...
    Shouldn't it only draw double what one would, since it's just two of the amps strapped?

    I have another 88Ah batt I want to put under the hood but haven't had the time yet

    Quote Originally Posted by Phoenix Risen View Post
    double check all of your grounds as well, it could be something as simple as needing a washer on a connection somewhere, had it happen to me a couple times.

    also how far is your voltage dropping exactly?
    What grounds exactly? Everything is directly connected to a battery... Nate was telling me about an issue you had with a washer, I use washers on all of my connections; I can take pictures of every bit of my install if necessary, but what was your exact issue again?

    Prolly into the 11's...amps aren't shutting off even with that low ohm load + voltage drop combo though.





  6. #6
    Boomsday's Avatar
    Boomsday is online now CarAudio.com Veteran



    Join Date
    Apr 2010
    Location
    My House
    Posts
    3,548
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    695 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    The AH of your batteries dont mean much when the car is running, CCA and resistance are the most important numbers




  7. #7
    hatedonmostly's Avatar
    hatedonmostly is offline throwin' hunnits, hunnits

    Threadstarter


    Join Date
    Jun 2009
    Location
    Detroit, MI
    Age
    23
    Posts
    6,382
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    I know, the point I'm trying to make is that they are large batteries...and I'm not the first person to use them for car audio, so I know they are fine for what I am trying to use them for.





  8. #8
    Boomsday's Avatar
    Boomsday is online now CarAudio.com Veteran



    Join Date
    Apr 2010
    Location
    My House
    Posts
    3,548
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    695 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    Quote Originally Posted by loudrc View Post
    I know, the point I'm trying to make is that they are large batteries...and I'm not the first person to use them for car audio, so I know they are fine for what I am trying to use them for.
    Well I vote Better Batteries first and Bigger alt second




  9. #9
    hatedonmostly's Avatar
    hatedonmostly is offline throwin' hunnits, hunnits

    Threadstarter


    Join Date
    Jun 2009
    Location
    Detroit, MI
    Age
    23
    Posts
    6,382
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    Batteries are fine and alt should be big enough to get the job done until I can afford a H/O...





  10. #10
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    21
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    118 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    if you arent going to take anyones advice whats the point in making this thread at all???



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  11. #11
    Boomsday's Avatar
    Boomsday is online now CarAudio.com Veteran



    Join Date
    Apr 2010
    Location
    My House
    Posts
    3,548
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    695 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    Quote Originally Posted by loudrc View Post
    Batteries are fine and alt should be big enough to get the job done until I can afford a H/O...
    Apparently not if your having bad drops




  12. #12
    hatedonmostly's Avatar
    hatedonmostly is offline throwin' hunnits, hunnits

    Threadstarter


    Join Date
    Jun 2009
    Location
    Detroit, MI
    Age
    23
    Posts
    6,382
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    Quote Originally Posted by [zack] View Post
    if you arent going to take anyones advice whats the point in making this thread at all???
    Just because I don't have XS Power batteries doesn't mean that my batteries ****...same with the alt, just because it's not a forum boner like DC Power doesn't mean that it's garbage.





  13. #13
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    21
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    118 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    Quote Originally Posted by loudrc View Post
    Just because I don't have XS Power batteries doesn't mean that my batteries ****...same with the alt, just because it's not a forum boner like DC Power doesn't mean that it's garbage.
    they havent said anything about either of those brands. everyone has told you that you need either more batteries or a bigger alt.
    and thats a fact. if you didnt you wouldnt be having the issue



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  14. #14
    hatedonmostly's Avatar
    hatedonmostly is offline throwin' hunnits, hunnits

    Threadstarter


    Join Date
    Jun 2009
    Location
    Detroit, MI
    Age
    23
    Posts
    6,382
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    I know, I have another battery to add which should help.

    I guess I'm too used to CACO, those fegs are convinced that you have to have designer equipment like XS Power...





  15. #15
    oxsign's Avatar
    oxsign is offline No Affiliation oxsign is a Supporting Member of the forum!

    oxsign is a Supporting Vendor of the forum!

    Join Date
    Jan 2006
    Location
    Sanford, FL
    Posts
    5,657
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    203 Post(s)

    Re: Voltage drop with good electrical. What am I doing wrong?

    ^^^^^^^^this^^^^^^^^ You asked, and the remedy has been given. What else do you want to hear?




Closed Thread
Page 1 of 4 1 2 3 4 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum