Closed Thread
Results 1 to 5 of 5

Reload Thread: Is this fuse required to get power to the amp? (see pic)

  1. #1
    Join Date
    Dec 2010
    Location
    East Texas
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Is this fuse required to get power to the amp? (see pic)

    I've just installed a new stereo but I can't get my amp to turn on for some reason. I've quadruple checked every connection I know to check and I'm thinking it could be either:

    1. The amp is broken.

    2. The remote on cable might not be getting its 12 volts from the deck and I should try hooking it to the red wire.

    3. The fuse box on the amp power cable mysteriously lost its fuses. Is this fuse/fuses necessary to power the amp? The fuse box I am talking about is located on the amp power cable about a foot away from the battery. Check out the picture.


    Is this fuse required to get power to the amp? (see pic)-amp-power-cable.jpg


    Any help is appreciated







  2. #2
    porksoda's Avatar
    porksoda is offline Dakota GOD!!!



    Join Date
    Aug 2007
    Location
    nm
    Posts
    614
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Is this fuse required to get power to the amp? (see pic)

    If there is no fuse then there will be no power getting to the amp.
    So looks like you need a fuse.
    That should be all.



    My truck build: http://www.stevemeadedesigns.com/board/topic/111744-1998-dodge-dakota-build/page__pid__1565536#entry1565536

  3. Thanks NewLogic87 thanked for this post
  4. #3
    sierrawitdaslap's Avatar
    sierrawitdaslap is offline BassHead!!!



    Join Date
    Jan 2010
    Location
    Watson/Thibodaux,Louisiana
    Age
    23
    Posts
    60
    Post Thanks / Like
    Images
    10
    Mentioned
    0 Post(s)

    Re: Is this fuse required to get power to the amp? (see pic)

    lulz



    1997 GMC Sierra Ext. Cab
    Sony HU
    Stock Door and Rears
    (2)Power Acoustic tweets
    (2)Volfenhag 6x9's(dont laugh)on 300w Jensen amp
    (1)50w Powerhorn (also on Jensen amp)
    (2) 18 Fi SSD's on a RF P1000.1
    14.7 cube box after sub and port displacement tuned @ 30Hz
    Stock electrical

  5. #4
    kr15's Avatar
    kr15 is offline Polluting Residentials



    Join Date
    Feb 2010
    Location
    California
    Posts
    3,103
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Is this fuse required to get power to the amp? (see pic)

    This post takes the cake as the most absurd I have ever seen on this site....get a new hobby, that is all



    Team Flex Issues
    45s out the trunk..lowww

    REFS- Supergumby5000, Lastcall, 919motoring, hippishake, daboyfromdabx (great seller), beach22

  6. #5
    Join Date
    Nov 2010
    Location
    Brandon , FL
    Age
    32
    Posts
    4,627
    Post Thanks / Like
    Mentioned
    5 Post(s)

    Re: Is this fuse required to get power to the amp? (see pic)

    Will this speaker play if i don't hook it to anything?? LOL. WTF???




Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum