Closed Thread
Results 1 to 6 of 6

Reload Thread: Radio/Antenna Problem with new deck

  1. #1
    wrelam's Avatar
    wrelam is offline Junior Member



    Join Date
    Nov 2010
    Location
    Boone, NC
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Radio/Antenna Problem with new deck

    I did a a couple searches but didn't find something that seemed as specific as the problem I'm having.

    I have a 1997 Ford Explorer and replaced the stock head unit with a Kenwood HD 545. Everything went smoothly and it will play CDs and play music from an auxilary source, but when I select HD Radio, it does not allow me to change the station, seek for stations, or do anything except change the source. As well, when it is on HD Radio, it will not produce any sound. I double checked the antenna plug into the back of the unit and replugged it in but that didn't change anything.
    Does anyone know of something else I should be doing? I'm not sure if it's the antenna, or the connection, or my head unit. The stock one was working just fine with the radio before I put the new one in.







  2. #2
    benzmansl65amg's Avatar
    benzmansl65amg is offline CarAudio.com Elite



    Join Date
    May 2007
    Location
    Mobile AL
    Age
    24
    Posts
    1,905
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Radio/Antenna Problem with new deck

    Does AM/FM work or just HD radio you need a tuner for HD radio



    Head Unit: Kenwood KDC-X996
    Components: Image Dynamics CXS62 V.2
    Amplifier: Rockford Fosgate T600-4
    Subwoofers: Image Dynamics IDQ10v3
    Electrical Upgrades: HO Alt and Big 3
    refs: trunks9_us, calikid, bassjunky, pickup1, bumpin buick, wgsj_fortvalley, holla105, Louisianacrx, pioneerspl1990, N2caraudio.com, terra, canyouhearmatt and many others

  3. #3
    wrelam's Avatar
    wrelam is offline Junior Member

    Threadstarter


    Join Date
    Nov 2010
    Location
    Boone, NC
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Radio/Antenna Problem with new deck

    Well the way to access AM/FM is on the HD Radio source, you then hit the band button to switch between AM/FM/HD Radio, but, that band button doesn't do anything. The default setting is FM so currently all I know is that FM Radio does not receive any signal. Also, this deck comes with an HD tuner in it, so it should work... I think

    Thanks for the quick reply!




  4. #4
    wrelam's Avatar
    wrelam is offline Junior Member

    Threadstarter


    Join Date
    Nov 2010
    Location
    Boone, NC
    Posts
    3
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Radio/Antenna Problem with new deck

    Nevermind. For some reason it decided to start working today. I'm not exactly sure what happened but the HD Radio and other radio settings are working just fine now. I love this new deck!




  5. #5
    nateberrier's Avatar
    nateberrier is offline ******



    Join Date
    Jun 2009
    Location
    Douche, Ohio
    Posts
    4,637
    Post Thanks / Like
    Images
    3
    Mentioned
    13 Post(s)

    Re: Radio/Antenna Problem with new deck

    sounds like something goofy with the deck, I dont listen to the radio



    Refs: mrmakinmoves[SCAMMER] AKA ICHASEPAPER2010, skydeaner, fukinmovin, mossberg385t, grimreper912003, LBC99, Dbeez, Michaellane, thegreatestpenn, truckstoy, ge_off_me, btr, cupid6969, johnprdeye, jh8909, tylerj, UMWDawg92, nu2spl, zerosktr111, SPLAUDIO, $LICK CALIFA$, jfroghobo

    http://www.execution-audio.com/

  6. #6
    Bfat567's Avatar
    Bfat567 is offline j-body love



    Join Date
    Dec 2009
    Location
    New York
    Posts
    201
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Radio/Antenna Problem with new deck

    Quote Originally Posted by nateberrier View Post
    I dont listen to the radio
    Dont even have the antenna hooked up in my car : )



    Quote Originally Posted by TheLow View Post
    the amount of fuck I do not give is unmeasurable.

Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum