Closed Thread
Results 1 to 11 of 11

Reload Thread: Mono Amp Protection Light Help!

  1. #1
    Tmoly's Avatar
    Tmoly is offline Junior Member



    Join Date
    Oct 2010
    Location
    White Rock, BC
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Mono Amp Protection Light Help!

    I have a alpine pdx 1.1000 1000w amp running 2x 10" alpine type R's.
    I also have a 4 channel alpine vpowered mrp-f240 running my 4 speakers

    I have 4 gage power running into a distribution block and I have 2x 8 gage power running out of it into both my amps.

    I have 4 gage ground running into a distribution block and I have 2x 8 gage ground running out of it into both my amps.

    remote and rcas obv too.

    The problem is my subs were working fine the first 2 days I had them the settings were on fairly low and I wasn't pumping them that hard. then all of a sudden I hear a noise and my subs cut out. The blue light is now illuminating red meaning the protection mode has triggered. every time my car turns on the light is blue and then I hear a *tic* noise and the light turns red.

    Also when I installed my 4 channel amp which was done after my mono was in, I started to hear a loud whine coming from my speakers that only comes on when the car is started. the whine gets louder and more high pitched the higher the RPMS get. I have power running on the left and rca's/ speaker wire running on the right.

    -----------

    Ive shortened the ground wires to both my amps but nothing, checked all the fuses and they seem to be intact... Does anyone know what might be causing these problems????
    Last edited by Tmoly; 11-13-2010 at 06:58 PM. Reason: Spelling







  2. #2
    BrownVanMan's Avatar
    BrownVanMan is offline CarAudio.com Elite



    Join Date
    May 2009
    Location
    Minneapolis MN
    Posts
    1,973
    Post Thanks / Like
    Mentioned
    8 Post(s)

    Re: Mono Amp Protection Light Help!

    8g for 1000 watts=fail




  3. #3
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    20
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mono Amp Protection Light Help!

    also prob need to beef up your electrical, my guess is your voltage is dropping too low and sendind the amp into protect



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  4. #4
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    20
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mono Amp Protection Light Help!

    also sounds like alternator whine, do you have a pioneer HU?
    if not find a better ground



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  5. #5
    Tmoly's Avatar
    Tmoly is offline Junior Member

    Threadstarter


    Join Date
    Oct 2010
    Location
    White Rock, BC
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mono Amp Protection Light Help!

    yea I got an alpine HU, I read the stickied thread ima try those options.

    How am I suppose to get 4 gage to both my amps, I dont want to have to run another power cord. Can you get distribution blocks like 4 gage in and 2x 4 gages out....




  6. #6
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    20
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mono Amp Protection Light Help!

    gotta run 0 awg to the distro, then 2 4 awgs out



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  7. #7
    Tmoly's Avatar
    Tmoly is offline Junior Member

    Threadstarter


    Join Date
    Oct 2010
    Location
    White Rock, BC
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mono Amp Protection Light Help!

    I took the 4gage going in to my distribution block and put it going directly into the mono amp meaning the 4 channel is getting no power. And still the same thing happens....




  8. #8
    CL1CKCLACK's Avatar
    CL1CKCLACK is offline CarAudio.com Boss



    Join Date
    Dec 2009
    Location
    Land Of The Hicks...
    Age
    20
    Posts
    5,167
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mono Amp Protection Light Help!

    that wouldnt solve the voltage issue, have you checked all of that?



    1996 Mitsu Clipse GSX 450whp
    1997 Eagle Talon TSI

    refs:
    wes007parks, ridinswangaz, madmat, treylittlefield, mendezm9
    MHD2000, RetroAudioInc, power-fanatic07, Carnivorous18, Spltuscon
    Ridinhi, Wingsfreak9, Pro-Rabbit, 2000LaDe, nom nom
    DBBOOM, hrtbrk1, dgaf_, dirtbikkerrob, Nik592, SkylineTT

  9. #9
    ThatChevyGuy's Avatar
    ThatChevyGuy is offline i heart Jager



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,212
    Post Thanks / Like
    Mentioned
    12 Post(s)

    Re: Mono Amp Protection Light Help!

    checked your power wire fuse?



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

  10. #10
    Tmoly's Avatar
    Tmoly is offline Junior Member

    Threadstarter


    Join Date
    Oct 2010
    Location
    White Rock, BC
    Posts
    5
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Mono Amp Protection Light Help!

    Quote Originally Posted by cl1ckclack View Post
    that wouldnt solve the voltage issue, have you checked all of that?
    Have I checked all what?


    and yes I have the power wire fuse is fine and because the 4 channel amp is still working fine.




  11. #11
    ThatChevyGuy's Avatar
    ThatChevyGuy is offline i heart Jager



    Join Date
    Jul 2006
    Location
    Arkansas
    Posts
    12,212
    Post Thanks / Like
    Mentioned
    12 Post(s)

    Re: Mono Amp Protection Light Help!

    You probably blew your amp then.



    REFS:
    Squeak9798, Kumbos310w6, BigBangTheory, Jmanpc, MillzThaYungin, WLDock, -Leister-, ThomasG, J31Rob (and a few more I have forgotten)
    Quote Originally Posted by Spider Monkey View Post
    eat my asshole you insignificant bastard child of a retarded dingleberry cunt wrinkle fuck toy
    Quote Originally Posted by subzero View Post
    her pussy better be that nicest pussy you ever ever ever had. she better suck, swallow, jack off, eat ass and snatch, make sammiwich, do yard work and fix the vehicals while nude. Because a bitch like that is definately gonna cause alot of stress in your life, even thou she keeps your wallet and your balls drained.
    Quote Originally Posted by 05fronty View Post
    bitch you better swallow and not make a mess

Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum